aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-03-12 01:03:43 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-16 19:34:33 +0100
commit57d05b694964d6919fc9bf8dc236271b49608087 (patch)
tree054928c21cfb258e61a423791ee5f7fed8699499
parent.travis.yml: bump to portage-2.3.62 (diff)
downloadqt-57d05b694964d6919fc9bf8dc236271b49608087.tar.gz
qt-57d05b694964d6919fc9bf8dc236271b49608087.tar.bz2
qt-57d05b694964d6919fc9bf8dc236271b49608087.zip
dev-qt/qtdeclarative: Drop USE xml
xmllistmodel was moved to qtdeclarative in upstream commit 0477a057fd02050fd330760bf046f5e0e91a9331. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-qt/qtdeclarative/metadata.xml1
-rw-r--r--dev-qt/qtdeclarative/qtdeclarative-5.12.9999.ebuild13
-rw-r--r--dev-qt/qtdeclarative/qtdeclarative-5.13.9999.ebuild11
-rw-r--r--dev-qt/qtdeclarative/qtdeclarative-5.9999.ebuild13
4 files changed, 5 insertions, 33 deletions
diff --git a/dev-qt/qtdeclarative/metadata.xml b/dev-qt/qtdeclarative/metadata.xml
index 6333b589..cffb0c60 100644
--- a/dev-qt/qtdeclarative/metadata.xml
+++ b/dev-qt/qtdeclarative/metadata.xml
@@ -9,7 +9,6 @@
<flag name="gles2">Use GLES 2.0 or later instead of full OpenGL</flag>
<flag name="localstorage">Build the LocalStorage import for QtQuick (requires QtSql)</flag>
<flag name="widgets">Enable QtWidgets support</flag>
- <flag name="xml">Build the XmlListModel import for QtQuick (requires QtXmlPatterns)</flag>
</use>
<upstream>
<bugs-to>https://bugreports.qt.io/</bugs-to>
diff --git a/dev-qt/qtdeclarative/qtdeclarative-5.12.9999.ebuild b/dev-qt/qtdeclarative/qtdeclarative-5.12.9999.ebuild
index 8876b08e..b3c3411f 100644
--- a/dev-qt/qtdeclarative/qtdeclarative-5.12.9999.ebuild
+++ b/dev-qt/qtdeclarative/qtdeclarative-5.12.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -11,7 +11,7 @@ if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd"
fi
-IUSE="gles2 +jit localstorage +widgets xml"
+IUSE="gles2 +jit localstorage +widgets"
# qtgui[gles2=] is needed because of bug 504322
COMMON_DEPEND="
@@ -21,10 +21,6 @@ COMMON_DEPEND="
~dev-qt/qttest-${PV}
localstorage? ( ~dev-qt/qtsql-${PV} )
widgets? ( ~dev-qt/qtwidgets-${PV}[gles2=] )
- xml? (
- ~dev-qt/qtnetwork-${PV}
- ~dev-qt/qtxmlpatterns-${PV}
- )
"
DEPEND="${COMMON_DEPEND}
${PYTHON_DEPS}
@@ -47,11 +43,6 @@ src_prepare() {
tools/qmlscene/qmlscene.pro \
tools/qml/qml.pro
- qt_use_disable_mod xml xmlpatterns \
- src/imports/imports.pro \
- tests/auto/quick/quick.pro \
- tests/auto/quick/examples/examples.pro
-
qt5-build_src_prepare
}
diff --git a/dev-qt/qtdeclarative/qtdeclarative-5.13.9999.ebuild b/dev-qt/qtdeclarative/qtdeclarative-5.13.9999.ebuild
index 31657b80..b3c3411f 100644
--- a/dev-qt/qtdeclarative/qtdeclarative-5.13.9999.ebuild
+++ b/dev-qt/qtdeclarative/qtdeclarative-5.13.9999.ebuild
@@ -11,7 +11,7 @@ if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd"
fi
-IUSE="gles2 +jit localstorage +widgets xml"
+IUSE="gles2 +jit localstorage +widgets"
# qtgui[gles2=] is needed because of bug 504322
COMMON_DEPEND="
@@ -21,10 +21,6 @@ COMMON_DEPEND="
~dev-qt/qttest-${PV}
localstorage? ( ~dev-qt/qtsql-${PV} )
widgets? ( ~dev-qt/qtwidgets-${PV}[gles2=] )
- xml? (
- ~dev-qt/qtnetwork-${PV}
- ~dev-qt/qtxmlpatterns-${PV}
- )
"
DEPEND="${COMMON_DEPEND}
${PYTHON_DEPS}
@@ -47,11 +43,6 @@ src_prepare() {
tools/qmlscene/qmlscene.pro \
tools/qml/qml.pro
- qt_use_disable_mod xml xmlpatterns \
- src/imports/imports.pro \
- tests/auto/quick/quick.pro \
- tests/auto/quick/examples/examples.pro
-
qt5-build_src_prepare
}
diff --git a/dev-qt/qtdeclarative/qtdeclarative-5.9999.ebuild b/dev-qt/qtdeclarative/qtdeclarative-5.9999.ebuild
index 8876b08e..b3c3411f 100644
--- a/dev-qt/qtdeclarative/qtdeclarative-5.9999.ebuild
+++ b/dev-qt/qtdeclarative/qtdeclarative-5.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -11,7 +11,7 @@ if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd"
fi
-IUSE="gles2 +jit localstorage +widgets xml"
+IUSE="gles2 +jit localstorage +widgets"
# qtgui[gles2=] is needed because of bug 504322
COMMON_DEPEND="
@@ -21,10 +21,6 @@ COMMON_DEPEND="
~dev-qt/qttest-${PV}
localstorage? ( ~dev-qt/qtsql-${PV} )
widgets? ( ~dev-qt/qtwidgets-${PV}[gles2=] )
- xml? (
- ~dev-qt/qtnetwork-${PV}
- ~dev-qt/qtxmlpatterns-${PV}
- )
"
DEPEND="${COMMON_DEPEND}
${PYTHON_DEPS}
@@ -47,11 +43,6 @@ src_prepare() {
tools/qmlscene/qmlscene.pro \
tools/qml/qml.pro
- qt_use_disable_mod xml xmlpatterns \
- src/imports/imports.pro \
- tests/auto/quick/quick.pro \
- tests/auto/quick/examples/examples.pro
-
qt5-build_src_prepare
}