aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-04-09 20:06:08 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-04-09 20:09:58 +0200
commit9a5c96c676c7fbe248a10d59f8803872f4a9e2be (patch)
tree9c11a271357b563d92c6589e713f4976fc780fa7
parentdev-qt/qtcore: Reduce indentation in pkg_pretend (diff)
downloadqt-9a5c96c676c7fbe248a10d59f8803872f4a9e2be.tar.gz
qt-9a5c96c676c7fbe248a10d59f8803872f4a9e2be.tar.bz2
qt-9a5c96c676c7fbe248a10d59f8803872f4a9e2be.zip
dev-qt/qtcore: Update 5.15.0_beta3
Package-Manager: Portage-2.3.98, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-qt/qtcore/qtcore-5.15.0_beta3.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/dev-qt/qtcore/qtcore-5.15.0_beta3.ebuild b/dev-qt/qtcore/qtcore-5.15.0_beta3.ebuild
index 9b476abf..7469ab23 100644
--- a/dev-qt/qtcore/qtcore-5.15.0_beta3.ebuild
+++ b/dev-qt/qtcore/qtcore-5.15.0_beta3.ebuild
@@ -3,7 +3,7 @@
EAPI=7
QT5_MODULE="qtbase"
-inherit qt5-build
+inherit linux-info qt5-build
DESCRIPTION="Cross-platform application development framework"
@@ -11,7 +11,7 @@ if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
fi
-IUSE="icu systemd"
+IUSE="icu old-kernel systemd"
DEPEND="
dev-libs/double-conversion:=
@@ -44,6 +44,15 @@ QT5_GENTOO_PRIVATE_CONFIG=(
PATCHES=( "${FILESDIR}/${PN}-5.14.1-cmake-macro-backward-compat.patch" ) # bug 703306
+pkg_pretend() {
+ use kernel_linux || return
+ get_running_version
+ if kernel_is -lt 3 17 && ! use old-kernel; then
+ ewarn "The running kernel is older than 3.17. USE=old-kernel is needed for ${CATEGORY}/${PN}"
+ ewarn "to function on this kernel properly. See Bug #669994."
+ fi
+}
+
src_prepare() {
# don't add -O3 to CXXFLAGS, bug 549140
sed -i -e '/CONFIG\s*+=/s/optimize_full//' src/corelib/corelib.pro || die
@@ -59,6 +68,8 @@ src_configure() {
-no-feature-statx # bug 672856
$(qt_use icu)
$(qt_use !icu iconv)
+ $(qt_use !old-kernel feature-renameat2) # needs Linux 3.16, bug 669994
+ $(qt_use !old-kernel feature-getentropy) # needs Linux 3.17, bug 669994
$(qt_use systemd journald)
)
qt5-build_src_configure