aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2018-01-26 13:29:29 +1100
committerMichael Palimaka <kensington@gentoo.org>2018-02-02 22:53:56 +1100
commit9f81240ffd41cda7bb75286c95bb49e8623e43de (patch)
treeefbe2a719981762e8ab06228b2aa42104db61a03
parentdev-qt/qtdbus: add QT5_GENTOO_PRIVATE_CONFIG (diff)
downloadqt-9f81240f.tar.gz
qt-9f81240f.tar.bz2
qt-9f81240f.zip
dev-qt/qtgui: add QT5_GENTOO_PRIVATE_CONFIG
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--dev-qt/qtgui/qtgui-5.10.0.ebuild6
-rw-r--r--dev-qt/qtgui/qtgui-5.10.9999.ebuild6
-rw-r--r--dev-qt/qtgui/qtgui-5.11.9999.ebuild4
-rw-r--r--dev-qt/qtgui/qtgui-5.9.4.ebuild4
-rw-r--r--dev-qt/qtgui/qtgui-5.9.9999.ebuild6
-rw-r--r--dev-qt/qtgui/qtgui-5.9999.ebuild4
6 files changed, 27 insertions, 3 deletions
diff --git a/dev-qt/qtgui/qtgui-5.10.0.ebuild b/dev-qt/qtgui/qtgui-5.10.0.ebuild
index e7b6eb22..0e281afe 100644
--- a/dev-qt/qtgui/qtgui-5.10.0.ebuild
+++ b/dev-qt/qtgui/qtgui-5.10.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -120,6 +120,10 @@ QT5_GENTOO_CONFIG=(
xcb::XKB
)
+QT5_GENTOO_PRIVATE_CONFIG=(
+ :gui
+)
+
src_prepare() {
# egl_x11 is activated when both egl and xcb are enabled
use egl && QT5_GENTOO_CONFIG+=(xcb:egl_x11) || QT5_GENTOO_CONFIG+=(egl:egl_x11)
diff --git a/dev-qt/qtgui/qtgui-5.10.9999.ebuild b/dev-qt/qtgui/qtgui-5.10.9999.ebuild
index e7b6eb22..0e281afe 100644
--- a/dev-qt/qtgui/qtgui-5.10.9999.ebuild
+++ b/dev-qt/qtgui/qtgui-5.10.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -120,6 +120,10 @@ QT5_GENTOO_CONFIG=(
xcb::XKB
)
+QT5_GENTOO_PRIVATE_CONFIG=(
+ :gui
+)
+
src_prepare() {
# egl_x11 is activated when both egl and xcb are enabled
use egl && QT5_GENTOO_CONFIG+=(xcb:egl_x11) || QT5_GENTOO_CONFIG+=(egl:egl_x11)
diff --git a/dev-qt/qtgui/qtgui-5.11.9999.ebuild b/dev-qt/qtgui/qtgui-5.11.9999.ebuild
index e699a859..0e281afe 100644
--- a/dev-qt/qtgui/qtgui-5.11.9999.ebuild
+++ b/dev-qt/qtgui/qtgui-5.11.9999.ebuild
@@ -120,6 +120,10 @@ QT5_GENTOO_CONFIG=(
xcb::XKB
)
+QT5_GENTOO_PRIVATE_CONFIG=(
+ :gui
+)
+
src_prepare() {
# egl_x11 is activated when both egl and xcb are enabled
use egl && QT5_GENTOO_CONFIG+=(xcb:egl_x11) || QT5_GENTOO_CONFIG+=(egl:egl_x11)
diff --git a/dev-qt/qtgui/qtgui-5.9.4.ebuild b/dev-qt/qtgui/qtgui-5.9.4.ebuild
index c5c08fae..aeb8b422 100644
--- a/dev-qt/qtgui/qtgui-5.9.4.ebuild
+++ b/dev-qt/qtgui/qtgui-5.9.4.ebuild
@@ -119,6 +119,10 @@ QT5_GENTOO_CONFIG=(
xcb::XKB
)
+QT5_GENTOO_PRIVATE_CONFIG=(
+ :gui
+)
+
src_prepare() {
# egl_x11 is activated when both egl and xcb are enabled
use egl && QT5_GENTOO_CONFIG+=(xcb:egl_x11) || QT5_GENTOO_CONFIG+=(egl:egl_x11)
diff --git a/dev-qt/qtgui/qtgui-5.9.9999.ebuild b/dev-qt/qtgui/qtgui-5.9.9999.ebuild
index 0e4e3eed..aeb8b422 100644
--- a/dev-qt/qtgui/qtgui-5.9.9999.ebuild
+++ b/dev-qt/qtgui/qtgui-5.9.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -119,6 +119,10 @@ QT5_GENTOO_CONFIG=(
xcb::XKB
)
+QT5_GENTOO_PRIVATE_CONFIG=(
+ :gui
+)
+
src_prepare() {
# egl_x11 is activated when both egl and xcb are enabled
use egl && QT5_GENTOO_CONFIG+=(xcb:egl_x11) || QT5_GENTOO_CONFIG+=(egl:egl_x11)
diff --git a/dev-qt/qtgui/qtgui-5.9999.ebuild b/dev-qt/qtgui/qtgui-5.9999.ebuild
index 26f4bb0b..a43ff0cc 100644
--- a/dev-qt/qtgui/qtgui-5.9999.ebuild
+++ b/dev-qt/qtgui/qtgui-5.9999.ebuild
@@ -120,6 +120,10 @@ QT5_GENTOO_CONFIG=(
xcb::XKB
)
+QT5_GENTOO_PRIVATE_CONFIG=(
+ :gui
+)
+
src_prepare() {
# egl_x11 is activated when both egl and xcb are enabled
use egl && QT5_GENTOO_CONFIG+=(xcb:egl_x11) || QT5_GENTOO_CONFIG+=(egl:egl_x11)