aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-02-09 17:23:29 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-02-09 20:22:20 +0100
commitbb3e4735560877bc5e06bb6f5cc36ce3869c7249 (patch)
tree133fe4c0adb9a6eed5b0eee0fb5dfb664f6780ca
parentdev-qt/qtcore: Fix cmake macro compat. for upgrade from <Qt-5.14 (diff)
downloadqt-bb3e4735560877bc5e06bb6f5cc36ce3869c7249.tar.gz
qt-bb3e4735560877bc5e06bb6f5cc36ce3869c7249.tar.bz2
qt-bb3e4735560877bc5e06bb6f5cc36ce3869c7249.zip
dev-qt/qtgui: Fix cmake macro compat. for upgrade from <Qt-5.14
Closes: https://bugs.gentoo.org/703306 Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> (cherry picked from commit 9f10d5690b0a924021f54c7b09b4ce152fd37e0b)
-rw-r--r--dev-qt/qtgui/files/qtgui-5.14.1-cmake-macro-backward-compat.patch50
-rw-r--r--dev-qt/qtgui/qtgui-5.14.9999.ebuild5
-rw-r--r--dev-qt/qtgui/qtgui-5.15.9999.ebuild5
3 files changed, 58 insertions, 2 deletions
diff --git a/dev-qt/qtgui/files/qtgui-5.14.1-cmake-macro-backward-compat.patch b/dev-qt/qtgui/files/qtgui-5.14.1-cmake-macro-backward-compat.patch
new file mode 100644
index 00000000..30b5abc3
--- /dev/null
+++ b/dev-qt/qtgui/files/qtgui-5.14.1-cmake-macro-backward-compat.patch
@@ -0,0 +1,50 @@
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sun, 9 Feb 2020 11:45:00 +0100
+Subject: [PATCH] qtcore: Fix cmake macro compat. for upgrade from <Qt-5.14
+
+In upstream commit:
+
+https://code.qt.io/cgit/qt/qtbase.git/commit/?h=5.14&id=63d9cd17
+
+_populate_$${CMAKE_MODULE_NAME}_plugin_properties in 5.14.0 gained an additional argument
+IsDebugAndRelease without providing backward compatibility. This macro is used (at least) for
+QtGui and QtDesigner plugins added by qtimageformats, qtsvg, qtvirtualkeyboard and qtwayland.
+During upgrade from <Qt-5.14 to >=Qt-5.14, as a consequence of slot upgrade rebuilds, some
+reverse dependencies are slated for rebuild before these Qt consumers have been rebuilt and their
+cmake files regenerated, leading to cmake errors like:
+
+https://bugs.gentoo.org/703306
+https://bugs.gentoo.org/705198
+
+From mkspecs/features/create_cmake.prf:
+
+# CMAKE_DEBUG_AND_RELEASE is used to tell the _populate_$${CMAKE_MODULE_NAME}_target_properties
+# functions whether a Configuration specific generator expression needs to be added to the values
+# of INTERFACE_LINK_LIBRARIES and INTERFACE_LINK_OPTIONS. For debug_and_release builds, we do need
+# configuration specific values. For singular builds (only release or only debug), we want the
+# values to be applied regardless of the configuration.
+# This would allow on Linux and macOS (and with a recent enough version of CMake on Windows) to
+# build a Debug configuration of an application, even if Qt was built in a Release configuration.
+
+qt5-build.eclass is configuring either as 'release' or as 'debug', so we make IsDebugAndRelease
+optional and default to FALSE.
+
+--- a/mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in 2020-01-23 13:37:32.000000000 +0100
++++ b/mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in 2020-02-09 15:15:21.156219814 +0100
+@@ -538,8 +538,14 @@
+
+ file(GLOB pluginTargets \"${CMAKE_CURRENT_LIST_DIR}/Qt5$${CMAKE_MODULE_NAME}_*Plugin.cmake\")
+
+- macro(_populate_$${CMAKE_MODULE_NAME}_plugin_properties Plugin Configuration PLUGIN_LOCATION
+- IsDebugAndRelease)
++ macro(_populate_$${CMAKE_MODULE_NAME}_plugin_properties Plugin Configuration PLUGIN_LOCATION)
++ set(IsDebugAndRelease FALSE)
++ set (list_var ${ARGN})
++ list(LENGTH list_var num_extra_arg)
++ if (${num_extra_arg} GREATER 0)
++ list(GET list_var 0 IsDebugAndRelease)
++ endif()
++
+ set_property(TARGET Qt5::${Plugin} APPEND PROPERTY IMPORTED_CONFIGURATIONS ${Configuration})
+
+ !!IF isEmpty(CMAKE_PLUGIN_DIR_IS_ABSOLUTE)
diff --git a/dev-qt/qtgui/qtgui-5.14.9999.ebuild b/dev-qt/qtgui/qtgui-5.14.9999.ebuild
index f613f170..e077dd59 100644
--- a/dev-qt/qtgui/qtgui-5.14.9999.ebuild
+++ b/dev-qt/qtgui/qtgui-5.14.9999.ebuild
@@ -133,7 +133,10 @@ QT5_GENTOO_PRIVATE_CONFIG=(
:gui
)
-PATCHES=( "${FILESDIR}/qt-5.12-gcc-avx2.patch" ) # bug 672946
+PATCHES=(
+ "${FILESDIR}/qt-5.12-gcc-avx2.patch" # bug 672946
+ "${FILESDIR}/${PN}-5.14.1-cmake-macro-backward-compat.patch" # bug 703306
+)
src_prepare() {
# don't add -O3 to CXXFLAGS, bug 549140
diff --git a/dev-qt/qtgui/qtgui-5.15.9999.ebuild b/dev-qt/qtgui/qtgui-5.15.9999.ebuild
index 169389df..e1bbc622 100644
--- a/dev-qt/qtgui/qtgui-5.15.9999.ebuild
+++ b/dev-qt/qtgui/qtgui-5.15.9999.ebuild
@@ -133,7 +133,10 @@ QT5_GENTOO_PRIVATE_CONFIG=(
:gui
)
-PATCHES=( "${FILESDIR}/qt-5.12-gcc-avx2.patch" ) # bug 672946
+PATCHES=(
+ "${FILESDIR}/qt-5.12-gcc-avx2.patch" # bug 672946
+ "${FILESDIR}/${PN}-5.14.1-cmake-macro-backward-compat.patch" # bug 703306
+)
src_prepare() {
# don't add -O3 to CXXFLAGS, bug 549140