aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2019-02-04 20:38:31 +0200
committerJimi Huotari <chiitoo@gentoo.org>2019-02-04 20:39:20 +0200
commitbf2b3bb1663224ea5a711de4be9d972352002d2b (patch)
treee13938a7ebfab147d741673b4db5fefa980efd37 /dev-qt/qtwebengine
parentdev-qt/qtwebengine: remove unneeded GCC patch from 5.{,13.}9999 (diff)
downloadqt-bf2b3bb1663224ea5a711de4be9d972352002d2b.tar.gz
qt-bf2b3bb1663224ea5a711de4be9d972352002d2b.tar.bz2
qt-bf2b3bb1663224ea5a711de4be9d972352002d2b.zip
dev-qt/qtwebengine: fix build with USE="system-icu"
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'dev-qt/qtwebengine')
-rw-r--r--dev-qt/qtwebengine/files/qtwebengine-5.13.0-fixup-system-icu.patch17
-rw-r--r--dev-qt/qtwebengine/qtwebengine-5.13.9999.ebuild2
-rw-r--r--dev-qt/qtwebengine/qtwebengine-5.9999.ebuild2
3 files changed, 21 insertions, 0 deletions
diff --git a/dev-qt/qtwebengine/files/qtwebengine-5.13.0-fixup-system-icu.patch b/dev-qt/qtwebengine/files/qtwebengine-5.13.0-fixup-system-icu.patch
new file mode 100644
index 00000000..e7fb9f81
--- /dev/null
+++ b/dev-qt/qtwebengine/files/qtwebengine-5.13.0-fixup-system-icu.patch
@@ -0,0 +1,17 @@
+From https://codereview.qt-project.org/#/c/251995/
+
+--- a/src/3rdparty/chromium/url/url_idna_icu.cc
++++ b/src/3rdparty/chromium/url/url_idna_icu.cc
+@@ -86,8 +86,10 @@ bool IDNToASCII(const base::char16* src, int src_len, CanonOutputW* output) {
+ while (true) {
+ UErrorCode err = U_ZERO_ERROR;
+ UIDNAInfo info = UIDNA_INFO_INITIALIZER;
+- int output_length = uidna_nameToASCII(uidna, src, src_len, output->data(),
+- output->capacity(), &info, &err);
++ int output_length = uidna_nameToASCII(uidna,
++ reinterpret_cast<const UChar*>(src), src_len,
++ reinterpret_cast<UChar*>(output->data()), output->capacity(),
++ &info, &err);
+ if (U_SUCCESS(err) && info.errors == 0) {
+ output->set_length(output_length);
+ return true;
diff --git a/dev-qt/qtwebengine/qtwebengine-5.13.9999.ebuild b/dev-qt/qtwebengine/qtwebengine-5.13.9999.ebuild
index cff56886..ff148cf7 100644
--- a/dev-qt/qtwebengine/qtwebengine-5.13.9999.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-5.13.9999.ebuild
@@ -79,6 +79,8 @@ DEPEND="${RDEPEND}
pax_kernel? ( sys-apps/elfix )
"
+PATCHES=( "${FILESDIR}/${PN}-5.13.0-fixup-system-icu.patch" )
+
src_prepare() {
use pax_kernel && PATCHES+=( "${FILESDIR}/${PN}-5.11.2-paxmark-mksnapshot.patch" )
diff --git a/dev-qt/qtwebengine/qtwebengine-5.9999.ebuild b/dev-qt/qtwebengine/qtwebengine-5.9999.ebuild
index cff56886..ff148cf7 100644
--- a/dev-qt/qtwebengine/qtwebengine-5.9999.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-5.9999.ebuild
@@ -79,6 +79,8 @@ DEPEND="${RDEPEND}
pax_kernel? ( sys-apps/elfix )
"
+PATCHES=( "${FILESDIR}/${PN}-5.13.0-fixup-system-icu.patch" )
+
src_prepare() {
use pax_kernel && PATCHES+=( "${FILESDIR}/${PN}-5.11.2-paxmark-mksnapshot.patch" )