aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qtwaylandscanner/qtwaylandscanner-5.15.4.9999.ebuild')
-rw-r--r--dev-qt/qtwaylandscanner/qtwaylandscanner-5.15.4.9999.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-qt/qtwaylandscanner/qtwaylandscanner-5.15.4.9999.ebuild b/dev-qt/qtwaylandscanner/qtwaylandscanner-5.15.4.9999.ebuild
new file mode 100644
index 00000000..1d586e68
--- /dev/null
+++ b/dev-qt/qtwaylandscanner/qtwaylandscanner-5.15.4.9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+QT5_MODULE="qtwayland"
+inherit qt5-build
+
+DESCRIPTION="Tool that generates certain boilerplate C++ code from Wayland protocol xml spec"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+DEPEND="=dev-qt/qtcore-${QT5_PV}*:5="
+RDEPEND="${DEPEND}
+ !<dev-qt/qtwayland-5.15.3:5
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/qtwaylandscanner
+)