aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2016-06-06 16:58:46 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2016-06-06 16:58:46 -0700
commitd5bd4bc41fde6fe82ddb942a1496300d8b4c19c6 (patch)
tree7f6d87eae33705a1a3512b66ed3afdc0469e689b
parentinfra-boxes: go more parallel to use CPU better. (diff)
parenttool-uclibc: extend =sys-devel/gcc-config-1.8-r1 to all hardened arches (diff)
downloadreleng-d5bd4bc41fde6fe82ddb942a1496300d8b4c19c6.tar.gz
releng-d5bd4bc41fde6fe82ddb942a1496300d8b4c19c6.tar.bz2
releng-d5bd4bc41fde6fe82ddb942a1496300d8b4c19c6.zip
Merge master back into thor.thor-wip
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
-rw-r--r--config/amd64-auto.conf2
-rw-r--r--config/x86-auto.conf2
-rw-r--r--tools-musl/portage.amd64.hardened/package.accept_keywords1
-rw-r--r--tools-musl/portage.armv7a.hardened/package.accept_keywords1
-rw-r--r--tools-uclibc/portage.amd64.hardened/package.accept_keywords1
-rw-r--r--tools-uclibc/portage.armv7a.hardened/package.accept_keywords1
-rw-r--r--tools-uclibc/portage.i686.hardened/package.accept_keywords1
-rw-r--r--tools-uclibc/portage.ppc.hardened/package.accept_keywords1
-rwxr-xr-xtools/catalyst-auto9
9 files changed, 14 insertions, 5 deletions
diff --git a/config/amd64-auto.conf b/config/amd64-auto.conf
index 7116cacc..6120a6ab 100644
--- a/config/amd64-auto.conf
+++ b/config/amd64-auto.conf
@@ -1,4 +1,4 @@
-distdir="/usr/portage/distfiles"
+distdir="/release/tmp/distfiles/"
portdir="/release/trees/portage-auto"
options="autoresume bindist pkgcache preserve_libs seedcache snapcache"
sharedir="/usr/lib64/catalyst/"
diff --git a/config/x86-auto.conf b/config/x86-auto.conf
index 27b50975..f4e934ff 100644
--- a/config/x86-auto.conf
+++ b/config/x86-auto.conf
@@ -1,4 +1,4 @@
-distdir="/usr/portage/distfiles"
+distdir="/release/tmp/distfiles/"
portdir="/release/trees/portage-auto"
options="autoresume bindist pkgcache preserve_libs seedcache snapcache"
sharedir="/usr/lib64/catalyst/"
diff --git a/tools-musl/portage.amd64.hardened/package.accept_keywords b/tools-musl/portage.amd64.hardened/package.accept_keywords
new file mode 100644
index 00000000..6a816089
--- /dev/null
+++ b/tools-musl/portage.amd64.hardened/package.accept_keywords
@@ -0,0 +1 @@
+=sys-devel/gcc-config-1.8-r1 ~amd64
diff --git a/tools-musl/portage.armv7a.hardened/package.accept_keywords b/tools-musl/portage.armv7a.hardened/package.accept_keywords
new file mode 100644
index 00000000..6a816089
--- /dev/null
+++ b/tools-musl/portage.armv7a.hardened/package.accept_keywords
@@ -0,0 +1 @@
+=sys-devel/gcc-config-1.8-r1 ~amd64
diff --git a/tools-uclibc/portage.amd64.hardened/package.accept_keywords b/tools-uclibc/portage.amd64.hardened/package.accept_keywords
new file mode 100644
index 00000000..6a816089
--- /dev/null
+++ b/tools-uclibc/portage.amd64.hardened/package.accept_keywords
@@ -0,0 +1 @@
+=sys-devel/gcc-config-1.8-r1 ~amd64
diff --git a/tools-uclibc/portage.armv7a.hardened/package.accept_keywords b/tools-uclibc/portage.armv7a.hardened/package.accept_keywords
new file mode 100644
index 00000000..f2838f26
--- /dev/null
+++ b/tools-uclibc/portage.armv7a.hardened/package.accept_keywords
@@ -0,0 +1 @@
+=sys-devel/gcc-config-1.8-r1 ~arm
diff --git a/tools-uclibc/portage.i686.hardened/package.accept_keywords b/tools-uclibc/portage.i686.hardened/package.accept_keywords
new file mode 100644
index 00000000..e44f7f06
--- /dev/null
+++ b/tools-uclibc/portage.i686.hardened/package.accept_keywords
@@ -0,0 +1 @@
+=sys-devel/gcc-config-1.8-r1 ~x86
diff --git a/tools-uclibc/portage.ppc.hardened/package.accept_keywords b/tools-uclibc/portage.ppc.hardened/package.accept_keywords
new file mode 100644
index 00000000..57ef89d5
--- /dev/null
+++ b/tools-uclibc/portage.ppc.hardened/package.accept_keywords
@@ -0,0 +1 @@
+=sys-devel/gcc-config-1.8-r1 ~ppc
diff --git a/tools/catalyst-auto b/tools/catalyst-auto
index e0388980..719c3ccf 100755
--- a/tools/catalyst-auto
+++ b/tools/catalyst-auto
@@ -303,6 +303,9 @@ fi
build_failure=0
+timeprefix=""
+which time >/dev/null && timeprefix="time"
+
for a in "" ${SETS}; do
if [ -z "${a}" ]; then
specs_var="SPECS"
@@ -314,7 +317,7 @@ for a in "" ${SETS}; do
for i in ${!specs_var}; do
LOGFILE="${TMPDIR}/log/$(echo "${i}" | sed -e 's:/:_:' -e 's:\.spec$::').log"
- run_cmd "time catalyst -a -p -c ${CATALYST_CONFIG} -f ${i}" ${LOGFILE}
+ run_cmd "${timeprefix} catalyst -a -p -c ${CATALYST_CONFIG} -f ${i}" ${LOGFILE}
if [ $? != 0 ]; then
build_failure=1
send_email "Catalyst fatal build error - ${i}" "" "${LOGFILE}"
@@ -324,7 +327,7 @@ for a in "" ${SETS}; do
for i in ${!optional_specs_var}; do
LOGFILE="${TMPDIR}/log/$(echo "${i}" | sed -e 's:/:_:' -e 's:\.spec$::').log"
- run_cmd "time catalyst -a -p -c ${CATALYST_CONFIG} -f ${i}" ${LOGFILE}
+ run_cmd "${timeprefix} catalyst -a -p -c ${CATALYST_CONFIG} -f ${i}" ${LOGFILE}
if [ $? != 0 ]; then
build_failure=1
send_email "Catalyst non-fatal build error - ${i}" "" "${LOGFILE}"
@@ -334,7 +337,7 @@ for a in "" ${SETS}; do
for i in ${!specs_var} ${!optional_specs_var}; do
LOGFILE="${TMPDIR}/log/$(echo "${i}" | sed -e 's:/:_:' -e 's:\.spec$::')_purge.log"
- run_cmd "time catalyst -P -c ${CATALYST_CONFIG} -f ${i}" "${LOGFILE}"
+ run_cmd "${timeprefix} catalyst -P -c ${CATALYST_CONFIG} -f ${i}" "${LOGFILE}"
done
update_symlinks