aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/spike/spike-1.0.0.ebuild')
-rw-r--r--app-emulation/spike/spike-1.0.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-emulation/spike/spike-1.0.0.ebuild b/app-emulation/spike/spike-1.0.0.ebuild
new file mode 100644
index 0000000..7da7a73
--- /dev/null
+++ b/app-emulation/spike/spike-1.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+inherit eutils autotools
+
+DESCRIPTION="The RISC-V ISA Simulator"
+HOMEPAGE="https://github.com/riscv/riscv-isa-sim/"
+SRC_URI="https://github.com/riscv/riscv-isa-sim/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+
+S="${WORKDIR}/riscv-isa-sim-${PV}"
+src_prepare() {
+ default
+ sed -i -e "/install_libs_dir/s:/lib:/$(get_libdir):g" Makefile.in || die
+ sed -i -e "/<string/a#include <stdexcept>" \
+ fesvr/dtm.cc riscv/devices.h || die
+ eautoreconf
+}