aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-12-03 00:10:50 -0500
committerMike Frysinger <vapier@gentoo.org>2012-12-24 03:01:36 -0500
commite0675f1bce06463ec51286f56afa2c2b7b505dd1 (patch)
tree57e7e2215303010bb34a9b9bee7725c8fcbeb04c /configure.ac
parentsb_efuncs: fix usage of portage handlers (diff)
downloadsandbox-e0675f1bce06463ec51286f56afa2c2b7b505dd1.tar.gz
sandbox-e0675f1bce06463ec51286f56afa2c2b7b505dd1.tar.bz2
sandbox-e0675f1bce06463ec51286f56afa2c2b7b505dd1.zip
sb_gdb: improve gdb integration
Add a dedicated entry point for connecting gdb to make it easy to connect gdb at arbitrary points (ala printf style debugging). This also smooths a lot of the common steps when automatically launching gdb such as making sure the process is closer to the crash point when the user takes over control of gdb. Finally, switch to using clone rather than fork since the latter relies on the C lib's fork which implicitly can grab locks. If we're crashing in the middle of a func that already holds those locks, the fork call will hang indefinitely on us. Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index dca43f7..fc63f4d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -146,6 +146,8 @@ AC_TYPE_SIGNAL
AC_FUNC_STAT
AC_CHECK_FUNCS_ONCE(m4_flatten([
backtrace
+ clone
+ __clone2
creat64
faccessat
fchmodat