aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2019-01-06 15:51:18 +0100
committerHorea Christian <horea.christ@yandex.com>2019-01-06 15:51:54 +0100
commit3deb3266cc23db1815042c373997195ee6f9c93b (patch)
tree27e5e769301124899f7db233f9ebd6189569b75d
parentsci-libs/nibabel: PYTHON_COMPAT and EAPI bump (diff)
downloadsci-3deb3266cc23db1815042c373997195ee6f9c93b.tar.gz
sci-3deb3266cc23db1815042c373997195ee6f9c93b.tar.bz2
sci-3deb3266cc23db1815042c373997195ee6f9c93b.zip
sci-biology/samri: updated ebuild
including test suite, EAPI, and PYTHON_COMPAT bump Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Horea Christian <horea.christ@yandex.com>
-rw-r--r--sci-biology/samri/samri-9999.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/sci-biology/samri/samri-9999.ebuild b/sci-biology/samri/samri-9999.ebuild
index 24078c41e..df5845e98 100644
--- a/sci-biology/samri/samri-9999.ebuild
+++ b/sci-biology/samri/samri-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
inherit distutils-r1 git-r3
@@ -48,10 +48,9 @@ python_test() {
export MPLBACKEND="agg"
export PATH=${TEST_DIR}/scripts:$PATH
export PYTHONIOENCODING=utf-8
- pytest || die
- for i in examples/*.py; do
- echo "Executing ${EPYTHON} ${i}"
- ${EPYTHON} "$i" || die "Example Python script $i failed with ${EPYTHON}"
- done
./test_scripts.sh || die "Test scripts failed."
+ sed -i -e \
+ "/def test_bru2bids():/i@pytest.mark.skip('Removed in full test suite, as this is already tested in `test_scripts.sh`')" \
+ samri/pipelines/tests/test_repos.py || die
+ pytest -vv || die
}