aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2019-01-22 16:17:58 +0100
committerMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2019-01-22 16:17:58 +0100
commit458e1564c2fa03fefffd8a8f9dc8975d95f26c3f (patch)
treec52b8e0a3fa2e3fca0041aafe8023544ebc251bc
parentsci-libs/io_lib: add libdeflate to USE flags and require it (diff)
downloadsci-458e1564c2fa03fefffd8a8f9dc8975d95f26c3f.tar.gz
sci-458e1564c2fa03fefffd8a8f9dc8975d95f26c3f.tar.bz2
sci-458e1564c2fa03fefffd8a8f9dc8975d95f26c3f.zip
sci-libs/libmaus2: upstream moved from github to gitlab
https://github.com/gt1/libmaus2/issues/28#issuecomment-456336598 Package-Manager: Portage-2.3.56, Repoman-2.3.12 Signed-off-by: Martin Mokrejs <mmokrejs@fold.natur.cuni.cz>
-rw-r--r--sci-libs/libmaus2/Manifest2
-rw-r--r--sci-libs/libmaus2/libmaus2-2.0.587.ebuild (renamed from sci-libs/libmaus2/libmaus2-2.0.499.ebuild)15
-rw-r--r--sci-libs/libmaus2/libmaus2-9999.ebuild11
3 files changed, 13 insertions, 15 deletions
diff --git a/sci-libs/libmaus2/Manifest b/sci-libs/libmaus2/Manifest
index 51c8ba1af..3b40b8924 100644
--- a/sci-libs/libmaus2/Manifest
+++ b/sci-libs/libmaus2/Manifest
@@ -1 +1 @@
-DIST 2.0.499-release-20180606122508.tar.gz 3610083 BLAKE2B 6495ba6eff89331544bb8999728cca0d86eba6dc0b9cf65aad298b0153f3d7d9c521b8eee6351972f10db0ae1de5ec554d4c149f57b9e3c31a376297d2fb0594 SHA512 b8ce37f0d2dc74bca2ee175c533338d86a60cff26219c9f7f050448fc544980e7ed4b7cefa17fb67fb0f42c8b11cae8d832f37bb2afa23379a7ce2e229d4f990
+DIST libmaus2-2.0.587.tar.gz 3692835 BLAKE2B 624c19d065f4f383888baacf228c53c76f2ff63b425e251b82687a6932c89b069974771f0c15d5bb6d2054ecaa323f0d8c8562572d566044089315c12dd8a2e6 SHA512 f0df4832f8bf7104550ea348653664049d116dfec19132cff71046269e87a4b396f9325abe1a9bea549dd2880931bf68427704df60b88016ff74ab9ffed9ec3e
diff --git a/sci-libs/libmaus2/libmaus2-2.0.499.ebuild b/sci-libs/libmaus2/libmaus2-2.0.587.ebuild
index cebe44161..1c61df056 100644
--- a/sci-libs/libmaus2/libmaus2-2.0.499.ebuild
+++ b/sci-libs/libmaus2/libmaus2-2.0.587.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -7,36 +7,35 @@ inherit autotools
DESCRIPTION="Library for biobambam2"
HOMEPAGE="https://github.com/gt1/libmaus"
-SRC_URI="https://github.com/gt1/libmaus2/archive/2.0.499-release-20180606122508.tar.gz"
+SRC_URI="https://gitlab.com/german.tischler/libmaus2/-/archive/master/${P}.tar.gz"
LICENSE="BSD-2 GPL-2 GPL-3 MIT ZLIB" # BUG: incomplete list of licenses, see AUTHORS
SLOT="0"
-KEYWORDS=""
+KEYWORDS="~amd64 ~x86"
IUSE="cpu_flags_x86_ssse3 cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2"
DEPEND="
!sci-libs/libmaus
- sci-libs/io_lib
+ >=sci-libs/io_lib-1.14.11
app-arch/snappy
- sci-biology/seqan
sci-libs/fftw
sci-libs/hdf5
net-libs/gnutls
dev-libs/nettle"
# --with-daligner
# --with-irods
-S="${WORKDIR}"/libmaus2-2.0.499-release-20180606122508
+S="${WORKDIR}"/libmaus2-master-27828cd78121d5e4b19c263c5527e462360f5901
src_configure(){
local CONFIG_OPTS
use cpu_flags_x86_ssse3 && CONFIG_OPTS+=( --enable-ssse3 )
( use cpu_flags_x86_sse4_1 || use cpu_flags_x86_sse4_2 ) && CONFIG_OPTS+=( --enable-sse4 )
- econf --with-snappy --with-seqan --with-io_lib $CONFIG_OPTS \
+ econf --with-snappy --with-io_lib $CONFIG_OPTS \
--with-lzma --with-gnutls --with-nettle --with-hdf5 --with-gmp --with-fftw
}
pkg_postinst(){
- einfo "The io_lib, snappy and seqan dependencies are not strictly needed"
+ einfo "The io_lib, snappy dependencies are not strictly needed"
einfo "but were forced for optimal libmaus2 performance."
einfo "igzip is only used if gzip level is set to 11."
}
diff --git a/sci-libs/libmaus2/libmaus2-9999.ebuild b/sci-libs/libmaus2/libmaus2-9999.ebuild
index 01aa74a92..c371d5432 100644
--- a/sci-libs/libmaus2/libmaus2-9999.ebuild
+++ b/sci-libs/libmaus2/libmaus2-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -7,7 +7,7 @@ inherit autotools git-r3
DESCRIPTION="Library for biobambam2"
HOMEPAGE="https://github.com/gt1/libmaus"
-EGIT_REPO_URI="https://github.com/gt1/libmaus2.git"
+EGIT_REPO_URI="https://gitlab.com/german.tischler/libmaus2"
LICENSE="BSD-2 GPL-2 GPL-3 MIT ZLIB" # BUG: incomplete list of licenses, see AUTHORS
SLOT="0"
@@ -16,9 +16,8 @@ IUSE="cpu_flags_x86_ssse3 cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2"
DEPEND="
!sci-libs/libmaus
- sci-libs/io_lib
+ >=sci-libs/io_lib-1.14.11
app-arch/snappy
- sci-biology/seqan
sci-libs/fftw
sci-libs/hdf5
net-libs/gnutls
@@ -35,12 +34,12 @@ src_configure(){
local CONFIG_OPTS
use cpu_flags_x86_ssse3 && CONFIG_OPTS+=( --enable-ssse3 )
( use cpu_flags_x86_sse4_1 || use cpu_flags_x86_sse4_2 ) && CONFIG_OPTS+=( --enable-sse4 )
- econf --with-snappy --with-seqan --with-io_lib $CONFIG_OPTS \
+ econf --with-snappy --with-io_lib $CONFIG_OPTS \
--with-lzma --with-gnutls --with-nettle --with-hdf5 --with-gmp --with-fftw
}
pkg_postinst(){
- einfo "The io_lib, snappy and seqan dependencies are not strictly needed"
+ einfo "The io_lib, snappy dependencies are not strictly needed"
einfo "but were forced for optimal libmaus2 performance."
einfo "igzip is only used if gzip level is set to 11."
}