aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2020-05-05 00:03:51 -0500
committerMatthias Maier <tamiko@gentoo.org>2020-05-05 01:04:45 -0500
commita59a74dc85efffa65ac15d8f39a24e0dd37db58f (patch)
tree4c429c5507ec372ac9a7a9b46baa401c489457e9
parentdev-lang/icc: version bump to 2020 update 1 (diff)
downloadsci-a59a74dc85efffa65ac15d8f39a24e0dd37db58f.tar.gz
sci-a59a74dc85efffa65ac15d8f39a24e0dd37db58f.tar.bz2
sci-a59a74dc85efffa65ac15d8f39a24e0dd37db58f.zip
dev-lang/ifc: version bump to 2020 update 1
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
-rw-r--r--dev-lang/ifc/Manifest1
-rw-r--r--dev-lang/ifc/ifc-19.1.1.217.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-lang/ifc/Manifest b/dev-lang/ifc/Manifest
index e20607e91..0007a0681 100644
--- a/dev-lang/ifc/Manifest
+++ b/dev-lang/ifc/Manifest
@@ -1,2 +1,3 @@
DIST parallel_studio_xe_2018_update2_professional_edition.tgz 3877755304 BLAKE2B c8852df23abf080f482002a37af7781b3fbae3ecec448914ea5a237fa2b925073d1a3dc2dd94ba64002ff0f6c7e9b18b25fa7ada811a83b10344eb9b92cb37ff SHA512 a9b644b0305d83a9d0daa14d146cb3ce79949db55a410afe48d62259414e6256d9ef533a04bb50807103511db2016c4abcbbf769146854a25638f402a6d0f2be
DIST parallel_studio_xe_2019_update4_professional_edition.tgz 2629662464 BLAKE2B a5619f33535063ccd7310378504ca960aa8512527cef7e0884fae5570633c1823e50ff7135adbbc571b4d47e0b6fcc01afe8639e09feb50a7f289eeec3f61ca0 SHA512 d8f6780a3671f30a1bad5d3a9792062c73b31188dc31fbd38212e98abc593f1c8f64bb970a8a4fce9ce237afef18ed38adf8fd81aa73b63ec964224590d4a34d
+DIST parallel_studio_xe_2020_update1_professional_edition.tgz 2783012958 BLAKE2B 975103ec4551a0e3bd84034ce771a5fc459d5de47f4247b5915b54d9c827e50e913f9054a103424b764f730190675d42b52a97e68551b34df6b3d8d9b922517a SHA512 00a3334bcdb8b30216ecb40fcfc709b27d043697606a53f522c90b05cf8598e1e60311d629ec17b6fe1016a7d2a27f4b428abddc9eba39badebfd8a9b53de404
diff --git a/dev-lang/ifc/ifc-19.1.1.217.ebuild b/dev-lang/ifc/ifc-19.1.1.217.ebuild
new file mode 100644
index 000000000..4157a3eec
--- /dev/null
+++ b/dev-lang/ifc/ifc-19.1.1.217.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+INTEL_DIST_PV=2020_update1_professional_edition
+
+inherit intel-sdp-r1
+
+DESCRIPTION="Intel FORTRAN Compiler"
+HOMEPAGE="http://software.intel.com/en-us/articles/intel-composer-xe/"
+
+IUSE="doc"
+KEYWORDS="-* ~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="~dev-libs/intel-common-${PV}[compiler]"
+
+MY_PV="$(ver_rs 3 '-')" # 20.1.0-607630
+
+QA_PREBUILT="*"
+
+CHECKREQS_DISK_BUILD=400M
+
+INTEL_DIST_DAT_RPMS=( "ifort-common-${MY_PV}-${MY_PV}.noarch.rpm" )
+INTEL_DIST_AMD64_RPMS=( "ifort-${MY_PV}-${MY_PV}.x86_64.rpm" )
+INTEL_DIST_X86_RPMS=( "ifort-32bit-${MY_PV}-${MY_PV}.x86_64.rpm" )
+
+pkg_setup() {
+ if use doc; then
+ INTEL_DIST_DAT_RPMS+=( "ifort-doc-19.1-${MY_PV}.noarch.rpm" )
+ fi
+}
+
+src_install() {
+ # already provided in dev-libs/intel-common
+ rm \
+ "${WORKDIR}"/opt/intel/compilers_and_libraries_2020.1.217/linux/compiler/include/omp_lib.f90 \
+ "${WORKDIR}"/opt/intel/compilers_and_libraries_2020.1.217/linux/compiler/include/intel64/omp_lib.mod \
+ "${WORKDIR}"/opt/intel/compilers_and_libraries_2020.1.217/linux/compiler/include/intel64/omp_lib_kinds.mod \
+ || die "rm failed"
+
+ intel-sdp-r1_src_install
+}