aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSean Vig <sean.v.775@gmail.com>2015-10-11 17:50:30 -0500
committerSean Vig <sean.v.775@gmail.com>2015-10-11 17:53:30 -0500
commite9f4de03c0738a170fd3e882f10f1bd92a83b499 (patch)
tree237bbdb0946070a3d992934e3e01b1d71a3a6405
parentUpdate envytools-9999.ebuild (diff)
downloadsci-e9f4de03.tar.gz
sci-e9f4de03.tar.bz2
sci-e9f4de03.zip
dev-python/jupyter_client: Version bump to 4.1.1
-rw-r--r--dev-python/jupyter_client/ChangeLog5
-rw-r--r--dev-python/jupyter_client/Manifest1
-rw-r--r--dev-python/jupyter_client/jupyter_client-4.1.1.ebuild35
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/jupyter_client/ChangeLog b/dev-python/jupyter_client/ChangeLog
index 677764699..514e85b7f 100644
--- a/dev-python/jupyter_client/ChangeLog
+++ b/dev-python/jupyter_client/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Id$
+*jupyter_client-4.1.1 (11 Oct 2015)
+
+ 11 Oct 2015; Sean Vig <sean.v.775@gmail.com> +jupyter_client-4.1.1.ebuild:
+ dev-python/jupyter_client: Version bump to 4.1.1
+
22 Sep 2015; Marius Brehler <marbre@linux.sungazer.de>
jupyter_client-9999.ebuild:
dev-python/jupyter_client: Add ~x86 to KEYWORDS, fixes #561032
diff --git a/dev-python/jupyter_client/Manifest b/dev-python/jupyter_client/Manifest
index 0b1336113..8ce850c6f 100644
--- a/dev-python/jupyter_client/Manifest
+++ b/dev-python/jupyter_client/Manifest
@@ -1 +1,2 @@
DIST jupyter_client-4.0.0.tar.gz 249339 SHA256 a39a4181ea2021daf6e821acae836999ef6e0fefe603813a7a7d4658d2ffa2ac SHA512 460fb992e6ce9767a89f839eafb1fd8a0039b4b6f3735728149c35c340fd2f3ec68feefd648226217fabed2db883e34d995dfe3254db1c41100f5b6232762ddb WHIRLPOOL e556ead2df89203c6b28f3fe6877928a72466eed796ac3e5017303cb35e8148fa8ad88aad12de05d887ee99b359459b974bca44f9d23fda25111c4e56d2abebb
+DIST jupyter_client-4.1.1.tar.gz 250227 SHA256 ff1ef5c6c3031a62db46ec6329867b4cb1595e6102a7819b3b5252b0c524bdb8 SHA512 08104fef5fd2522944ac5f1b2140a8267ffd97b0dba518f9fa792c08102ff8dbc4def592150433dfd893aed3596876ff254c9ea17b9b2e7a9622f773bd9d2606 WHIRLPOOL d7164a07a43c5d6cd78b30bedb6ec8e8bc367cca4ddf920fee27edc9337d6f1124ae840546d90d47ad1c0a84bd1677e452925c022cebfa5556c499f7fa8ee18d
diff --git a/dev-python/jupyter_client/jupyter_client-4.1.1.ebuild b/dev-python/jupyter_client/jupyter_client-4.1.1.ebuild
new file mode 100644
index 000000000..7a24b82ff
--- /dev/null
+++ b/dev-python/jupyter_client/jupyter_client-4.1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python{3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="http://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-14.4.0[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ )
+ "
+
+python_test() {
+ nosetests --with-coverage jupyter_client || die
+}