aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/behaviopy/behaviopy-9999.ebuild')
-rw-r--r--sci-biology/behaviopy/behaviopy-9999.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sci-biology/behaviopy/behaviopy-9999.ebuild b/sci-biology/behaviopy/behaviopy-9999.ebuild
new file mode 100644
index 000000000..2aee7c999
--- /dev/null
+++ b/sci-biology/behaviopy/behaviopy-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Neuroimaging tools for Python"
+HOMEPAGE="https://github.com/TheChymera/behaviopy"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/TheChymera/behaviopy"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="evaluation test"
+KEYWORDS=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/seaborn[${PYTHON_USEDEP}]
+ dev-python/statsmodels[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ "
+ #evaluation? ( sci-biology/psychopy[${PYTHON_USEDEP}] )
+
+src_prepare() {
+ if ! use evaluation; then
+ rm behaviopy/evaluation.py || die
+ fi
+ default
+}
+
+python_test() {
+ cd behaviopy/examples
+ echo "backend : Agg" > matplotlibrc || die
+ for i in *py; do
+ echo "Executing $i"
+ ${EPYTHON} $i || die
+ done
+}