aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 99b50bd..1f2b2b6 100644
--- a/Makefile
+++ b/Makefile
@@ -114,7 +114,9 @@ SED_PC_CMD = 's|@version@|$(VERSION)|g; \
all: $(PROGRAMS) sparse.pc
-install: $(INST_PROGRAMS) $(LIBS) $(LIB_H) sparse.pc
+all-installable: $(INST_PROGRAMS) $(LIBS) $(LIB_H) sparse.pc
+
+install: all-installable
$(Q)install -d $(DESTDIR)$(BINDIR)
$(Q)install -d $(DESTDIR)$(LIBDIR)
$(Q)install -d $(DESTDIR)$(MAN1DIR)