summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2009-09-08 18:49:04 +0000
committerIan Stakenvicius <axs@gentoo.org>2009-09-08 18:49:04 +0000
commit07d7519e95d13a1f08ac02e61dca98dc50b1299d (patch)
tree41e7e2815327534057dd66c9bc69a66e2c473f68 /app-misc/mswinurl_launcher/mswinurl_launcher-1.0.ebuild
parentdev-python/greenlet: Add a patch that avoids ez_setup behavior (diff)
downloadsunrise-07d7519e95d13a1f08ac02e61dca98dc50b1299d.tar.gz
sunrise-07d7519e95d13a1f08ac02e61dca98dc50b1299d.tar.bz2
sunrise-07d7519e95d13a1f08ac02e61dca98dc50b1299d.zip
app-misc/mswinurl_launcher: New package for bug #283698 - thanks to ssuominen for the ebuild help
svn path=/sunrise/; revision=9198
Diffstat (limited to 'app-misc/mswinurl_launcher/mswinurl_launcher-1.0.ebuild')
-rw-r--r--app-misc/mswinurl_launcher/mswinurl_launcher-1.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-misc/mswinurl_launcher/mswinurl_launcher-1.0.ebuild b/app-misc/mswinurl_launcher/mswinurl_launcher-1.0.ebuild
new file mode 100644
index 000000000..c094f4cbd
--- /dev/null
+++ b/app-misc/mswinurl_launcher/mswinurl_launcher-1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/conky-1.7.0_rc1.ebuild,v 1.1 2009/03/17 01:22:09 omp Exp $
+
+inherit eutils fdo-mime
+
+DESCRIPTION="A launcher and desktop association for Microsoft Windows *.URL (text/x-uri) files"
+HOMEPAGE="http://bugs.launchpad.net/ubuntu/+source/mime-support/+bug/185165/comments/12"
+SRC_URI="http://launchpadlibrarian.net/20406796/mswinurl_launcher.py"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-util/desktop-file-utils"
+RDEPEND="dev-lang/python"
+
+S=${WORKDIR}
+
+src_unpack() {
+ cp "${DISTDIR}/${A}" "${S}" || die "could not copy ${A} to ${S}"
+}
+
+src_install() {
+ dobin ${PN}.py || die
+ domenu "${FILESDIR}/${PN}.desktop" || die
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}