summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Lockwood (dunc) <dunc@lemonia.org>2009-02-23 17:48:53 +0000
committerDuncan Lockwood (dunc) <dunc@lemonia.org>2009-02-23 17:48:53 +0000
commit66e31fa6cd24037ab22e9a70b90d427cd648bfac (patch)
tree125df7baab527edb2639be8212523021473eaf43 /dev-lang
parentapp-cdr/acetoneiso2: renamed to app-cdr/acetoneiso (diff)
downloadsunrise-66e31fa6cd24037ab22e9a70b90d427cd648bfac.tar.gz
sunrise-66e31fa6cd24037ab22e9a70b90d427cd648bfac.tar.bz2
sunrise-66e31fa6cd24037ab22e9a70b90d427cd648bfac.zip
dev-lang/faust: New Ebuild for bug 90698. Thanks to volkmar and scarabeus for ebuild help and scarabeus for review
svn path=/sunrise/; revision=7959
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/faust/ChangeLog9
-rw-r--r--dev-lang/faust/Manifest5
-rw-r--r--dev-lang/faust/faust-0.9.9.4.ebuild41
-rw-r--r--dev-lang/faust/files/faust-0.9.9.4_Makefile.patch49
-rw-r--r--dev-lang/faust/metadata.xml5
5 files changed, 109 insertions, 0 deletions
diff --git a/dev-lang/faust/ChangeLog b/dev-lang/faust/ChangeLog
new file mode 100644
index 000000000..7e2d394c4
--- /dev/null
+++ b/dev-lang/faust/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-lang/faust
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 23 Feb 2009; Duncan Lockwood (dunc) <dunc@lemonia.org>
+ +faust-0.9.9.4.ebuild, +files/faust-0.9.9.4_Makefile.patch, +metadata.xml:
+ New Ebuild for bug 90698. Thanks to volkmar and scarabeus for ebuild help
+ and scarabeus for review
+
diff --git a/dev-lang/faust/Manifest b/dev-lang/faust/Manifest
new file mode 100644
index 000000000..c14ab10a5
--- /dev/null
+++ b/dev-lang/faust/Manifest
@@ -0,0 +1,5 @@
+AUX faust-0.9.9.4_Makefile.patch 2006 RMD160 e9eb8699ce0f3512c96e420e20e03878c68a0386 SHA1 e1a12198dc3eaaf1200b66ea0aaae03fb2e18bcc SHA256 ef2072648f3972c2f9e55727556ba51f6c24412c2be312c0191dbd9575d8055e
+DIST faust-0.9.9.4b.tar.gz 3934697 RMD160 c126b11f23451a28ec932f9b51bf080613fab4e7 SHA1 65882219ccd96fb8a64eec208bbad3a127b7a777 SHA256 0509f9a49f0f1c7a03a2c14f560793b1f65cbaf9e0efcd44c572f93af5a39dea
+EBUILD faust-0.9.9.4.ebuild 1081 RMD160 51262a619baa6bfffbf0b1204d65279932be930c SHA1 906609b54499bedda5351551b6d703dc54247549 SHA256 861e0fa35a8af993a870347173a58b077bd8c346512a46798cccf77cf197cf28
+MISC ChangeLog 353 RMD160 81489df5cc594ea8cc0086e6d2dbf1dad6a3efbc SHA1 de3fa2664c9815620227cee6aeea4e29f041aef7 SHA256 25647d0fa8b6eda8bcdaa0587e5c5cc749cb47688949b529363252cbbaa1723e
+MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/dev-lang/faust/faust-0.9.9.4.ebuild b/dev-lang/faust/faust-0.9.9.4.ebuild
new file mode 100644
index 000000000..15559a9e9
--- /dev/null
+++ b/dev-lang/faust/faust-0.9.9.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Functional programming language for realtime audio plugins and applications development"
+HOMEPAGE="http://faust.grame.fr/"
+SRC_URI="mirror://sourceforge/faudiostream/${P}b.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc examples"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}_Makefile.patch"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed"
+ dodoc README || die "Installing README failed"
+
+ if use doc; then
+ dodoc documentation/faust{-quick-reference,-soft-computing,_tutorial}.pdf \
+ || die "Installing docs failed"
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc examples/* || die "Installing examples failed"
+ fi
+}
+
+pkg_postinst() {
+ elog "Please note that faust is only concerned with creating C++ source "
+ elog "code. To actually compile this source code, you must have available "
+ elog "libraries for one or more of ALSA, jack, OSS, ladspa or PD"
+}
diff --git a/dev-lang/faust/files/faust-0.9.9.4_Makefile.patch b/dev-lang/faust/files/faust-0.9.9.4_Makefile.patch
new file mode 100644
index 000000000..883c32ed4
--- /dev/null
+++ b/dev-lang/faust/files/faust-0.9.9.4_Makefile.patch
@@ -0,0 +1,49 @@
+--- ../faust-0.9.9.4_orig/Makefile 2008-03-27 14:59:11.000000000 +0000
++++ Makefile 2009-02-19 20:50:53.000000000 +0000
+@@ -1,5 +1,8 @@
+ version := 0.9.9.4
+-prefix := /usr/local
++DESTDIR ?= /
++PREFIX ?= /usr/local
++destdir := $(DESTDIR)
++prefix := $(PREFIX)
+ arch := $(wildcard architecture/*.*)
+ mfiles := $(wildcard examples/Makefile.*)
+ vname := faust-$(version)-$(shell date +%y%m%d.%H%M%S)
+@@ -16,7 +19,7 @@ help :
+ @echo "make parser : generate the parser from the lex and yacc files"
+ @echo "make clean : remove all object files"
+ @echo "make doc : generate the documentation using doxygen"
+- @echo "make install : install the compiler and the architecture files in $(prefix)/bin $(prefix)/lib/faust"
++ @echo "make install : install the compiler and the architecture files in $(destdir)/$(prefix)/bin $(destdir)/$(prefix)/lib/faust"
+ @echo "make uninstall : undo what install did"
+ @echo "make dist : make a tar.gz file ready for distribution"
+ @echo "make log : make a changelog file"
+@@ -36,18 +39,18 @@ doc :
+
+
+ install :
+- mkdir -p $(prefix)/lib/faust/
+- install compiler/faust $(prefix)/bin
+- install -m 0644 $(arch) $(prefix)/lib/faust/
+- - test -d $(prefix)/lib/faust/VST && rm -rf $(prefix)/lib/faust/VST
+- cp -r architecture/VST $(prefix)/lib/faust/
+- find $(prefix)/lib/faust/ -name CVS | xargs rm -rf
+- install -m 0644 $(mfiles) $(prefix)/lib/faust/
++ mkdir -p $(destdir)/$(prefix)/lib/faust/
++ install -D compiler/faust $(destdir)/$(prefix)/bin/faust
++ install -m 0644 $(arch) $(destdir)/$(prefix)/lib/faust/
++ - test -d $(destdir)/$(prefix)/lib/faust/VST && rm -rf $(destdir)/$(prefix)/lib/faust/VST
++ cp -r architecture/VST $(destdir)/$(prefix)/lib/faust/
++ find $(destdir)/$(prefix)/lib/faust/ -name CVS | xargs rm -rf
++ install -m 0644 $(mfiles) $(destdir)/$(prefix)/lib/faust/
+
+
+ uninstall :
+- rm -rf $(prefix)/lib/faust/
+- rm -f $(prefix)/bin/faust
++ rm -rf $(destdir)/$(prefix)/lib/faust/
++ rm -f $(destdir)/$(prefix)/bin/faust
+
+ dist :
+ $(MAKE) -C compiler clean
diff --git a/dev-lang/faust/metadata.xml b/dev-lang/faust/metadata.xml
new file mode 100644
index 000000000..7e3286984
--- /dev/null
+++ b/dev-lang/faust/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted</herd>
+</pkgmetadata>