summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/fms/ChangeLog5
-rw-r--r--net-p2p/fms/Manifest6
-rw-r--r--net-p2p/fms/files/fms-0.3.28-glibc-2.9.patch11
-rw-r--r--net-p2p/fms/files/gcc-4.4-include.patch48
-rw-r--r--net-p2p/fms/fms-0.3.28.ebuild8
5 files changed, 75 insertions, 3 deletions
diff --git a/net-p2p/fms/ChangeLog b/net-p2p/fms/ChangeLog
index b4074bd59..58df5a0bf 100644
--- a/net-p2p/fms/ChangeLog
+++ b/net-p2p/fms/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 13 Jan 2009; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ fms-0.3.28.ebuild, +files/fms-0.3.28-glibc-2.9.patch,
+ +files/gcc-4.4-include.patch:
+ Fix build errors with newer glibc and gcc
+
13 Jan 2009; Dennis Nezic <dennisn@dennisn.dyndns.org> -fms-0.3.25.ebuild,
+fms-0.3.28.ebuild:
Updated version
diff --git a/net-p2p/fms/Manifest b/net-p2p/fms/Manifest
index 4bea64a31..30166ab23 100644
--- a/net-p2p/fms/Manifest
+++ b/net-p2p/fms/Manifest
@@ -1,5 +1,7 @@
AUX fms 280 RMD160 544c3c246a4fe48d131eccdc10290a8577586aff SHA1 77e544cc0d4109edc414c96fdac90f075a79af31 SHA256 b34b78556f529af1f7c43b17656448210b63f3624be868d4d3f396b02e7336ed
+AUX fms-0.3.28-glibc-2.9.patch 295 RMD160 93d412d23c96c491363aed67c20418ccc4bd5b8c SHA1 f44fb3799cc5ef981ffeecab432edf4d084b979b SHA256 2d033bf62737aa64265ccd9c565dadb46effa848fd3bd84836f9f434a96c328d
+AUX gcc-4.4-include.patch 1605 RMD160 439f95a6e249564249dc712b713b51a15db65113 SHA1 214922e7baa788c9373c77188cac5c536021c535 SHA256 a8f5590308f8c03a43fb7f7570fc41c46324ca7ec09269da40a698d1456696e7
DIST fms-src-0.3.28.zip 1275422 RMD160 24a366b366c81137d88ed448e1c65463fc0981d0 SHA1 38c774244b24b62aa18c0c32dba230c4003d0b42 SHA256 f531e578b2a135219b516549591da804a63ec0995f9d7fb963317f4de514e181
-EBUILD fms-0.3.28.ebuild 1407 RMD160 c9fc1c336847bb3fcebb37281fea208a77a57a79 SHA1 b338fc027f9a50efb81cf3a810fddbfaaed7765b SHA256 9f256fbc7240ed496caa2d16e5ff4f38749a4b2559a77de091800b5f1041a786
-MISC ChangeLog 623 RMD160 7cc465fb8664a5e5a18bf493c6f8559019254310 SHA1 b17df72390af69c8870b739be2eca422fb0a22b4 SHA256 e6fef1d35dfd1696b7fa4e277e71585fdc525db9e84499887905cf938b63c802
+EBUILD fms-0.3.28.ebuild 1525 RMD160 04bec2fe6016b059a5a0f3fbdc94a85420f559f9 SHA1 a3e48983431de4594369d9326e767dae3f39db04 SHA256 71098c3bfa8b1e00112d90bb60ca58da6118fa7412510d48336fd0480ce0d3e8
+MISC ChangeLog 815 RMD160 b57f99385fc75fcb0f2aed3763e8e94e57abdb32 SHA1 9e02f9443e25d7bfdd30317e2c57ac8251d7b5a8 SHA256 d57e11e584bc4ac0dfa6cd8fdb4af68d38e2bf2db05f63cb0e02f5d90a203221
MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/net-p2p/fms/files/fms-0.3.28-glibc-2.9.patch b/net-p2p/fms/files/fms-0.3.28-glibc-2.9.patch
new file mode 100644
index 000000000..c54264738
--- /dev/null
+++ b/net-p2p/fms/files/fms-0.3.28-glibc-2.9.patch
@@ -0,0 +1,11 @@
+--- src/freenet/fcpv2.cpp 2009-01-04 18:43:26.000000000 +0100
++++ src/freenet/fcpv2.cpp.new 2009-01-13 19:08:03.000000000 +0100
+@@ -3,6 +3,8 @@
+ #include <sstream>
+ #include <algorithm>
+ #include <cstdarg>
++#include <cstring>
++#include <cstdlib>
+
+ #ifdef _WIN32
+ #include <ws2tcpip.h>
diff --git a/net-p2p/fms/files/gcc-4.4-include.patch b/net-p2p/fms/files/gcc-4.4-include.patch
new file mode 100644
index 000000000..6b9540e19
--- /dev/null
+++ b/net-p2p/fms/files/gcc-4.4-include.patch
@@ -0,0 +1,48 @@
+--- src/freenet/siteinserter.cpp 2009-01-04 16:20:56.000000000 +0100
++++ src/freenet/siteinserter.cpp.new 2009-01-13 19:37:36.000000000 +0100
+@@ -4,6 +4,7 @@
+ #include <Poco/DateTime.h>
+ #include <Poco/Timespan.h>
+ #include <Poco/DateTimeFormatter.h>
++#include <cstdio>
+
+ #ifdef XMEM
+ #include <xmem.h>
+--- src/http/fmshttprequesthandlerfactory.cpp 2008-12-03 19:17:26.000000000 +0100
++++ src/http/fmshttprequesthandlerfactory.cpp.new 2009-01-13 19:38:32.000000000 +0100
+@@ -23,6 +23,7 @@
+ #include "../../include/http/pages/forumthreadspage.h"
+ #include "../../include/http/pages/forumviewthreadpage.h"
+ #include "../../include/http/pages/forumcreatepostpage.h"
++#include <cstdio>
+
+ FMSHTTPRequestHandlerFactory::FMSHTTPRequestHandlerFactory()
+ {
+--- src/http/pages/showimagepage.cpp 2008-12-01 18:22:38.000000000 +0100
++++ src/http/pages/showimagepage.cpp.new 2009-01-13 19:40:59.000000000 +0100
+@@ -1,4 +1,5 @@
+ #include "../../../include/http/pages/showimagepage.h"
++#include <cstdio>
+
+ #ifdef XMEM
+ #include <xmem.h>
+--- src/nntp/uwildmat.cpp 2008-05-02 08:39:44.000000000 +0200
++++ src/nntp/uwildmat.cpp.new 2009-01-13 19:52:18.000000000 +0100
+@@ -67,6 +67,7 @@
+ #include "../../include/nntp/uwildmat.h"
+ #include <string>
+ #include <cstring>
++#include <stdint.h>
+
+ #define ABORT -1
+
+--- src/nntp/mime/Mime.cpp 2008-05-02 08:38:38.000000000 +0200
++++ src/nntp/mime/Mime.cpp.new 2009-01-13 20:01:33.000000000 +0100
+@@ -13,6 +13,7 @@
+ #include <stdlib.h>
+ #include <time.h>
+ #include <cstring>
++#include <stdio.h>
+
+ #ifndef _WIN32
+ #define stricmp strcasecmp
diff --git a/net-p2p/fms/fms-0.3.28.ebuild b/net-p2p/fms/fms-0.3.28.ebuild
index c9659332f..5a610b74d 100644
--- a/net-p2p/fms/fms-0.3.28.ebuild
+++ b/net-p2p/fms/fms-0.3.28.ebuild
@@ -6,7 +6,7 @@ inherit eutils cmake-utils
DESCRIPTION="A spam-resistant message board application for Freenet"
HOMEPAGE="http://freenetproject.org/tools.html"
-SRC_URI="http://individual.utoronto.ca/nezic/${PN}-src-${PV}.zip"
+SRC_URI="http://dev.gentooexperimental.org/~tommy/distfiles/${PN}-src-${PV}.zip"
LICENSE="GPL-2"
SLOT="0"
@@ -26,6 +26,12 @@ pkg_setup() {
enewuser freenet -1 -1 /var/freenet freenet
}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/{${P}-glibc-2.9,gcc-4.4-include}.patch
+}
+
src_compile() {
local mycmakeargs="-DI_HAVE_READ_THE_README=ON
-DUSE_BUNDLED_SQLITE=OFF