summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/vdr-muggle/vdr-muggle-0.1.11.ebuild')
-rw-r--r--media-plugins/vdr-muggle/vdr-muggle-0.1.11.ebuild82
1 files changed, 0 insertions, 82 deletions
diff --git a/media-plugins/vdr-muggle/vdr-muggle-0.1.11.ebuild b/media-plugins/vdr-muggle/vdr-muggle-0.1.11.ebuild
deleted file mode 100644
index df0c5c3..0000000
--- a/media-plugins/vdr-muggle/vdr-muggle-0.1.11.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-RESTRICT="mirror"
-
-inherit vdr-plugin
-
-DESCRIPTION="Video Disk Recorder Muggle Plugin"
-HOMEPAGE="http://www.selbstgetippt.de/selbstgetippt/Muggle.html"
-SRC_URI="http://www.selbstgetippt.de/selbstgetippt/Muggle_files/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 -amd64"
-IUSE="flac vorbis graphtft mysql embedded postgres sqlite"
-
-DEPEND=">=media-video/vdr-1.2.6
- media-libs/taglib
- media-libs/libmad
- mysql? ( >=dev-db/mysql-4.0 )
- sqlite? ( dev-db/sqlite )
- postgres? ( dev-db/postgresql )
- vorbis? ( >=media-libs/libvorbis-1.0 )
- flac? ( media-libs/flac )"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- vdr-plugin_pkg_setup
-
- if ! use mysql && ! use sqlite && ! use postgres; then
- echo
- eerror "Please choose on of the following use flags"
- eerror "mysql sqlite postgres for your vaforited databank"
- echo
- die "No DB use flag added"
- fi
-}
-
-src_unpack() {
- vdr-plugin_src_unpack
- cd "${S}"
-
- sed -i "s:#include <vdr/getopt.h>:#include <getopt.h>:" muggle.c
-
- use graphtft && epatch "${FILESDIR}/${P}_graphTFT_Cover.diff"
-
- use vorbis && sed -i "s:# HAVE_VORBISFILE=1:HAVE_VORBISFILE=1:" Makefile
-
- use flac && sed -i "s:# HAVE_FLAC=1:HAVE_FLAC=1:" Makefile
-
-
- if use mysql && use embedded ; then
-
- einfo "Compiling with support for embedded mysql."
- if has_version '<dev-db/mysql-4.1.11'
- then
- ewarn "The resulting binary will not work with an external server"
- ewarn "because your libmysqlclient is not version >= 4.1.11"
- fi
-
- elif use mysql && ! use embedded && sed -i "s:#.*HAVE_ONLY_SERVER=1:HAVE_ONLY_SERVER=1:" Makefile ; then
-
- einfo "Compiling with mysql support, without support for embedded mysql."
-
- elif use sqlite && sed -i "s:# HAVE_SQLITE = 1:HAVE_SQLITE = 1:" Makefile ; then
-
- einfo "Compiling with sqlite support"
-
- else
-
- einfo "Compiling with postgres support"
- use postgres && sed -i "s:HAVE_MYSQL = 1:HAVE_PG:" Makefile
- fi
-}
-
-
-src_install() {
- vdr-plugin_src_install
-
- dobin mugglei
-}