summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to '006-vim-8.2.5066-crosscompile.patch')
-rw-r--r--006-vim-8.2.5066-crosscompile.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/006-vim-8.2.5066-crosscompile.patch b/006-vim-8.2.5066-crosscompile.patch
new file mode 100644
index 0000000..a78a43e
--- /dev/null
+++ b/006-vim-8.2.5066-crosscompile.patch
@@ -0,0 +1,23 @@
+Skip failing configure checks during cross-compile builds (bug #473372).
+
+--- a/src/configure.ac
++++ b/src/configure.ac
+@@ -3441,7 +3441,7 @@ else
+ # include <stddef.h>
+ #endif
+ main() {char *s; s=(char *)tgoto("%p1%d", 0, 1); exit(0); }])],
+- res="OK", res="FAIL", res="FAIL")
++ res="OK", res="FAIL", res="OK")
+ if test "$res" = "OK"; then
+ break
+ fi
+@@ -3512,7 +3512,7 @@ main()
+ ],[
+ vim_cv_tgetent=non-zero
+ ],[
+- AC_MSG_ERROR(failed to compile test program.)
++ vim_cv_tgent=zero
+ ])
+ ])
+
+--