summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2020-10-14 15:17:14 +0000
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2020-10-14 15:17:14 +0000
commit057e26d7257302383e5a87071adaf9ca71f5c2ea (patch)
treedf13b11fe5b993aea883f01260a5f066f3cba563
parentwww-apps/drupal: Drop vulnerable releases. (diff)
downloadjmbsvicetto-057e26d7257302383e5a87071adaf9ca71f5c2ea.tar.gz
jmbsvicetto-057e26d7257302383e5a87071adaf9ca71f5c2ea.tar.bz2
jmbsvicetto-057e26d7257302383e5a87071adaf9ca71f5c2ea.zip
www-apps/drupal: Add 8.9.7 and 9.0.7 releases.
Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
-rw-r--r--www-apps/drupal/Manifest2
-rw-r--r--www-apps/drupal/drupal-8.9.7.ebuild68
-rw-r--r--www-apps/drupal/drupal-9.0.7.ebuild68
3 files changed, 138 insertions, 0 deletions
diff --git a/www-apps/drupal/Manifest b/www-apps/drupal/Manifest
index f102fd8..f7657ab 100644
--- a/www-apps/drupal/Manifest
+++ b/www-apps/drupal/Manifest
@@ -1,4 +1,6 @@
DIST drupal-7.73.tar.gz 3324289 BLAKE2B 85b40994ef336e8a155175597aaf36652850118400533b531d5bfe4ffd797abb9b362ccfb2a52cdf2e326fa4865492406c3ed4cf1a59a4e0aff0613c337c4301 SHA512 45f518ef8bc085eafc2292f6a41c17c2d034fa9261ba8c61549a46adb194020e036355c322abc64a355ff81d00ecd1f0acf0834d46ec028aac506c81f7297849
DIST drupal-8.8.10.tar.gz 19510031 BLAKE2B daae5669bdaa79ad1ae56a52993a390127fff56307b0256c0dfd9d118f1b09d3e8414b71334c74b01f9e9609870f75b25936bf72a78d051f543862d848daedb8 SHA512 1ebfb7f1f3d29ef00bd560e4ff4d236ee739bafb4f9687bce77dcd6da9746d42db4423a278b22a1b394bbf7eb769975eb69eaeeb16f4ea601cc13d9209309425
DIST drupal-8.9.6.tar.gz 19789145 BLAKE2B aaa2c5e866fd74dc4e5d19bb4f00eae3333cb86b2b54969f31936cb627e2af0cc14b0e6d1d26b1366040cb3860752d3507b82341d706490fef35ff6ed5ca2316 SHA512 3938cca2736eb2a0fa5c2b12c0d8543f54d0480bbb42b51283f694aa67e7785b94e6d3b2bbeadfd304e9fc429c57b73c12243b178813b658537c42c1303c0d81
+DIST drupal-8.9.7.tar.gz 19791241 BLAKE2B dda9be1c810549134d591fd05f9fa52a59536ae5036bb87f23b972c732489efdc9278ba16e9c41d09e71448543543c12091b68273369af2ecde4d16afb7f039f SHA512 3bf9923e18a0fec49e06d798b555f5df7cd171cb341613a6619595bce7eeceb4ebb16160fc0b15ad845cfcf07edde67f5e103a286dc058b52fb9b078af8dd28e
DIST drupal-9.0.6.tar.gz 16857960 BLAKE2B 0e85e16330b5c3df70443d2f516b0a5d4854db4c3e101dc29a04af7e76cb913b0349deb82643644e722d90c78f7ba4497b8712f229b4eede2fb867c95469d57f SHA512 ee5b0ab3f0fd25c70b6a44e10a2e54c945a3843c460d5769ba5022a82fc2726909f2c34b9823c5f82ee01d8145b739daf2fed3a78ef22454ad0db7f08a0812f1
+DIST drupal-9.0.7.tar.gz 16863270 BLAKE2B 6fa9ed549bf53c0c3a9ade1da8002c9fc7d6c8c29f9a258a82dcc0e0240dbf61892df6fd5997460076b759a1db79d3cd428f1441a067d0134092c9d43a5d8d73 SHA512 7ba5ba42d04e188b02908480ee483935799bca562bc2c927fc8fbf6862499eafd83a1680e19d692d7c08313d5801bf709af04c86285c32fe7ae6cd5c4c5539af
diff --git a/www-apps/drupal/drupal-8.9.7.ebuild b/www-apps/drupal/drupal-8.9.7.ebuild
new file mode 100644
index 0000000..50acdd3
--- /dev/null
+++ b/www-apps/drupal/drupal-8.9.7.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash(+),mysql?,pdo,postgres?,simplexml,sqlite?,xml]
+ virtual/httpd-php
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="LICENSE.txt README.txt core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+ core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt "
+
+ dodoc ${docs}
+ rm -f ${docs} core/INSTALL core/COPYRIGHT.txt core/LICENSE.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+ ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+ ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+ echo
+ ewarn "If you're doing a new drupal-8 install, you'll have to copy /sites/default/default.services.yml"
+ ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+ ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+ ewarn "reported by the setup."
+ echo
+}
diff --git a/www-apps/drupal/drupal-9.0.7.ebuild b/www-apps/drupal/drupal-9.0.7.ebuild
new file mode 100644
index 0000000..50acdd3
--- /dev/null
+++ b/www-apps/drupal/drupal-9.0.7.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash(+),mysql?,pdo,postgres?,simplexml,sqlite?,xml]
+ virtual/httpd-php
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="LICENSE.txt README.txt core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+ core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt "
+
+ dodoc ${docs}
+ rm -f ${docs} core/INSTALL core/COPYRIGHT.txt core/LICENSE.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+ ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+ ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+ echo
+ ewarn "If you're doing a new drupal-8 install, you'll have to copy /sites/default/default.services.yml"
+ ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+ ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+ ewarn "reported by the setup."
+ echo
+}