summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-apps/drupal/Manifest3
-rw-r--r--www-apps/drupal/drupal-8.9.18.ebuild68
-rw-r--r--www-apps/drupal/drupal-9.1.12.ebuild68
-rw-r--r--www-apps/drupal/drupal-9.2.4.ebuild68
4 files changed, 207 insertions, 0 deletions
diff --git a/www-apps/drupal/Manifest b/www-apps/drupal/Manifest
index 7d1bbf4..cda46b8 100644
--- a/www-apps/drupal/Manifest
+++ b/www-apps/drupal/Manifest
@@ -1,4 +1,7 @@
DIST drupal-7.82.tar.gz 3348407 BLAKE2B c01c93fda768d587a009c9007a019f01461ae3fed1010c80a4636971fcdf4ce97e1cad61a60b447698d8e2d6d39217ead52de3cf915f04ad620357aafb3209a0 SHA512 41b844df868971ea21fa574daf46502edcb78f4287c223694fe967541da72dfe9b360e1764441eddafb64b782d14408eac58ecff7eaed4bc1fd832b35f0c7e2d
DIST drupal-8.9.17.tar.gz 19829635 BLAKE2B 58ff2623121ab1a283e5d89bc5983154f5c040c024ceaa3728d5a54b1a519b72d4c834b9535f5de38df11217a2e25f8e18225d6ea521b0e5f51fa9c7b29f337f SHA512 7c805092a182d660dec9d060662cb510debb4732ddce616089c32df8c12e4c945b25c904c8bf3b186e868e2a33615cb5483651e9aea0b51f5cb47ec55e8ab55d
+DIST drupal-8.9.18.tar.gz 19831928 BLAKE2B e8f42a00e8efe1c3a0b7a995bb9f55b37c590945f12268e86887f0243ab2691222449acce5f61d4ec853e0d13bb81b2d8d39a7702c2651368adaaa2438004114 SHA512 2c3103489d4b7ecee432fba1a1ef597b07701e46920a4cf82fc9d078368a0259a28e62e92a96550b23950c4ff6ae943877f7b8f6ef556381bf633daa3d4d0846
DIST drupal-9.1.11.tar.gz 18572070 BLAKE2B b1c2ad47bb9d36b47b6a74569b825fbf0ecb4e1ad951397778fd14c8eed9e633b685bbcbadae15b346d8c5944e53a4001c55e85d54a512aa639427054b90d0d3 SHA512 ac20865dc9791883fd684a455e753baedd1abc4f77617af5d1f57ba547a2c21f93909724919393a26058654592d68210d493fba9a593700239aa58b9f7939ddd
+DIST drupal-9.1.12.tar.gz 18568186 BLAKE2B 74f20477867adc92eb6a87d2e3f4bd9449a69c66c723a03af9789d99f913a839324406aedaca1c731b5616fbde70bbd8e1a5fc469b2cc259385655fae0209176 SHA512 43335b11cddfd73271afa66c825316d48b0dece4d221119c571629ee8d61aeeea85d48674bc53a479b954d3f24648cd7571c4b6c84e560abae8bb682abf3468e
DIST drupal-9.2.3.tar.gz 18860238 BLAKE2B c5a482d3a46aea128e92525d2339b26d68d3e92f11588643e5010dd4f36fab15df06203d02797badad0dd7519dfec0403b30bc02aa7ec72c8099c2281eb54f8f SHA512 9caaf1fe050ba1727f036a8aa0ecc0adde55ea37a66bd6e437602a86bedf368be86d0d0577ebc05d56615d161f93229026067f8c10ac6a656bd564a29229621d
+DIST drupal-9.2.4.tar.gz 18860644 BLAKE2B f7ed7f5bd4131c0a167fe5c51c54fa7499bf4cecab9ce41fed1516eba842e40ea1191e51a1e2cb4a0f5426d86803b511a57d08f056ad8635ca2a55496e0b1237 SHA512 956a1c62fd9294f7d5fa1de3d620fea71db08c4ccea6c8d575e5c2cd6f06afd8380601be5a66d7f3ed4c78bfde9a1d2fd662a7fcd2f16b4484fee298b8cdd93b
diff --git a/www-apps/drupal/drupal-8.9.18.ebuild b/www-apps/drupal/drupal-8.9.18.ebuild
new file mode 100644
index 0000000..1fa351c
--- /dev/null
+++ b/www-apps/drupal/drupal-8.9.18.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash(+),mysql?,pdo,postgres?,simplexml,sqlite?,xml]
+ virtual/httpd-php
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="LICENSE.txt README.txt core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+ core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt "
+
+ dodoc ${docs}
+ rm -f ${docs} core/INSTALL core/COPYRIGHT.txt core/LICENSE.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+ ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+ ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+ echo
+ ewarn "If you're doing a new drupal-8 install, you'll have to copy /sites/default/default.services.yml"
+ ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+ ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+ ewarn "reported by the setup."
+ echo
+}
diff --git a/www-apps/drupal/drupal-9.1.12.ebuild b/www-apps/drupal/drupal-9.1.12.ebuild
new file mode 100644
index 0000000..1fa351c
--- /dev/null
+++ b/www-apps/drupal/drupal-9.1.12.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash(+),mysql?,pdo,postgres?,simplexml,sqlite?,xml]
+ virtual/httpd-php
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="LICENSE.txt README.txt core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+ core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt "
+
+ dodoc ${docs}
+ rm -f ${docs} core/INSTALL core/COPYRIGHT.txt core/LICENSE.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+ ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+ ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+ echo
+ ewarn "If you're doing a new drupal-8 install, you'll have to copy /sites/default/default.services.yml"
+ ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+ ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+ ewarn "reported by the setup."
+ echo
+}
diff --git a/www-apps/drupal/drupal-9.2.4.ebuild b/www-apps/drupal/drupal-9.2.4.ebuild
new file mode 100644
index 0000000..23610d1
--- /dev/null
+++ b/www-apps/drupal/drupal-9.2.4.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash(+),mysql?,pdo,postgres?,simplexml,sqlite?,xml]
+ virtual/httpd-php
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="LICENSE.txt README.md core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+ core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt "
+
+ dodoc ${docs}
+ rm -f ${docs} core/INSTALL core/COPYRIGHT.txt core/LICENSE.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+ ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+ ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+ echo
+ ewarn "If you're doing a new drupal-8 install, you'll have to copy /sites/default/default.services.yml"
+ ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+ ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+ ewarn "reported by the setup."
+ echo
+}