summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-12 23:15:17 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-12 23:15:17 +0100
commitd26fe6da956e4f841b26e15ca590729555448c6d (patch)
tree1c3b2022341bb573cbcd7f9daaf1f1d7254471b9 /dev-binpkg
parentdev-binpkg/pypy: Remove obsolete USE=test (diff)
downloadmgorny-master.tar.gz
mgorny-master.tar.bz2
mgorny-master.zip
Remove obsolete dev-binpkg/*HEADmaster
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-binpkg')
-rw-r--r--dev-binpkg/pypy/Manifest1
-rw-r--r--dev-binpkg/pypy/files/5.9.0-shared-lib.patch12
-rw-r--r--dev-binpkg/pypy/metadata.xml12
-rw-r--r--dev-binpkg/pypy/pypy-7.2.0.ebuild206
-rw-r--r--dev-binpkg/pypy3/Manifest1
-rw-r--r--dev-binpkg/pypy3/files/5.9.0-shared-lib.patch12
-rw-r--r--dev-binpkg/pypy3/metadata.xml12
-rw-r--r--dev-binpkg/pypy3/pypy3-7.2.0.ebuild196
8 files changed, 0 insertions, 452 deletions
diff --git a/dev-binpkg/pypy/Manifest b/dev-binpkg/pypy/Manifest
deleted file mode 100644
index 79befee..0000000
--- a/dev-binpkg/pypy/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST pypy2.7-v7.2.0-src.tar.bz2 20219532 BLAKE2B 225e2cebdfa3ceb310f2a047b1d9e1d375b181c10707822890f39fc0a5ec9e6ddd7a8cf6e073074067960b766a0a813294042513a08b8e7e02b011f612e17917 SHA512 8f724490f9fa06686c8e25ddd3592b260bbffae460395de4c7d29d983780ce9b8925fa87434aac6446aac2034381cc1a13074faf252f5d1ac466a252f219f1ae
diff --git a/dev-binpkg/pypy/files/5.9.0-shared-lib.patch b/dev-binpkg/pypy/files/5.9.0-shared-lib.patch
deleted file mode 100644
index 5d89d3b..0000000
--- a/dev-binpkg/pypy/files/5.9.0-shared-lib.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -dupr a/rpython/translator/platform/posix.py b/rpython/translator/platform/posix.py
---- a/rpython/translator/platform/posix.py 2017-10-05 20:17:25.009954656 +0200
-+++ b/rpython/translator/platform/posix.py 2017-10-05 20:17:31.115666386 +0200
-@@ -227,7 +227,7 @@ class BasePosix(Platform):
- 'int main(int argc, char* argv[]) '
- '{ return $(PYPY_MAIN_FUNCTION)(argc, argv); }" > $@')
- m.rule('$(DEFAULT_TARGET)', ['$(TARGET)', 'main.o'],
-- ['$(CC_LINK) $(LDFLAGS_LINK) main.o -L. -l$(SHARED_IMPORT_LIB) -o $@ $(RPATH_FLAGS)', '$(MAKE) postcompile BIN=$(DEFAULT_TARGET)'])
-+ ['$(CC_LINK) $(LDFLAGS_LINK) main.o -L. -l$(SHARED_IMPORT_LIB) \'-Wl,-rpath,$$ORIGIN\' -o $@', '$(MAKE) postcompile BIN=$(DEFAULT_TARGET)'])
-
- return m
-
diff --git a/dev-binpkg/pypy/metadata.xml b/dev-binpkg/pypy/metadata.xml
deleted file mode 100644
index 5915221..0000000
--- a/dev-binpkg/pypy/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>mgorny@gentoo.org</email>
- <name>Michał Górny</name>
- </maintainer>
- <use>
- <flag name="low-memory">Build using PyPy with the engine configured towards low memory footprint. This makes it possible to build PyPy using ~3.5G of RAM on amd64 and ~half of that on x86, at the cost of lengthened build time. Please note that you will need an extra ~1G of extra RAM or swap since the translation memory (unused at the time) is not freed when the C compiler is spawned.</flag>
- <flag name="sandbox">Enable sandboxing functionality</flag>
- </use>
-</pkgmetadata>
diff --git a/dev-binpkg/pypy/pypy-7.2.0.ebuild b/dev-binpkg/pypy/pypy-7.2.0.ebuild
deleted file mode 100644
index 3acab0e..0000000
--- a/dev-binpkg/pypy/pypy-7.2.0.ebuild
+++ /dev/null
@@ -1,206 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 pypy )
-inherit check-reqs pax-utils python-any-r1 toolchain-funcs
-
-# note: remember to update this to newest dev-lang/python:2.7 on bump
-CPY_PATCHSET_VERSION="2.7.15"
-MY_P=pypy2.7-v${PV}
-
-DESCRIPTION="A fast, compliant alternative implementation of the Python language"
-HOMEPAGE="http://pypy.org/"
-SRC_URI="https://bitbucket.org/pypy/pypy/downloads/${MY_P}-src.tar.bz2"
-
-LICENSE="MIT"
-# pypy -c 'import sysconfig; print sysconfig.get_config_var("SOABI")'
-# pypy 7.0.0: install directory changed to 'pypy2.7'
-SLOT="0/41-py27"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="bzip2 +jit low-memory ncurses sandbox cpu_flags_x86_sse2"
-
-DEPEND=">=sys-libs/zlib-1.1.3:0=
- virtual/libffi:0=
- virtual/libintl:0=
- dev-libs/expat:0=
- bzip2? ( app-arch/bzip2:0= )
- ncurses? ( sys-libs/ncurses:0= )
- app-arch/lzip
- ${PYTHON_DEPS}"
-
-S="${WORKDIR}/${MY_P}-src"
-
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- if use low-memory; then
- if ! python_is_installed pypy; then
- eerror "USE=low-memory requires a (possibly old) version of dev-python/pypy"
- eerror "or dev-python/pypy-bin being installed. Please install it using e.g.:"
- eerror
- eerror " $ emerge -1v dev-python/pypy-bin"
- eerror
- eerror "before attempting to build dev-python/pypy[low-memory]."
- die "dev-python/pypy-bin (or dev-python/pypy) needs to be installed for USE=low-memory"
- fi
-
- CHECKREQS_MEMORY="1750M"
- use amd64 && CHECKREQS_MEMORY="3500M"
- else
- CHECKREQS_MEMORY="3G"
- use amd64 && CHECKREQS_MEMORY="6G"
- fi
-
- check-reqs_pkg_pretend
- fi
-
- [[ ${PYPY_BINPKG_STORE} ]] || die 'PYPY_BINPKG_STORE unset, wtf?!'
-}
-
-pkg_setup() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- pkg_pretend
-
- if python_is_installed pypy; then
- if [[ ! ${EPYTHON} || ${EPYTHON} == pypy ]] || use low-memory; then
- einfo "Using already-installed PyPy to perform the translation."
- local EPYTHON=pypy
- else
- einfo "Using ${EPYTHON} to perform the translation. Please note that upstream"
- einfo "recommends using PyPy for that. If you wish to do so, please unset"
- einfo "the EPYTHON variable."
- fi
- fi
-
- python-any-r1_pkg_setup
-
- local cpu
- if use amd64; then
- # common denominator between Intel & AMD
- cpu='x86-64'
- elif use x86; then
- if use cpu_flags_x86_sse2; then
- # lowest with SSE2
- cpu='pentium-m'
- else
- # lowest with SSE, compat. with athlon-xp
- # TODO: do we want to support something older?
- cpu='pentium3'
- fi
- else
- die "Unsupported arch ${ARCH}"
- fi
-
- export CFLAGS="-march=${cpu} -mtune=generic -O2 -pipe"
- export CXXFLAGS=${CFLAGS}
-
- elog "CFLAGS: ${CFLAGS}"
- fi
-}
-
-src_prepare() {
- eapply "${FILESDIR}"/5.9.0-shared-lib.patch # 517002
-
- eapply_user
-}
-
-src_configure() {
- tc-export CC
-
- local jit_backend
- if use jit; then
- jit_backend='--jit-backend='
-
- # We only need the explicit sse2 switch for x86.
- # On other arches we can rely on autodetection which uses
- # compiler macros. Plus, --jit-backend= doesn't accept all
- # the modern values...
-
- if use x86; then
- if use cpu_flags_x86_sse2; then
- jit_backend+=x86
- else
- jit_backend+=x86-without-sse2
- fi
- else
- jit_backend+=auto
- fi
- fi
-
- local args=(
- --shared
- $(usex jit -Ojit -O2)
- $(usex sandbox --sandbox '')
-
- ${jit_backend}
-
- pypy/goal/targetpypystandalone
- )
-
- # Avoid linking against libraries disabled by use flags
- local opts=(
- bzip2:bz2
- ncurses:_minimal_curses
- )
-
- local opt
- for opt in "${opts[@]}"; do
- local flag=${opt%:*}
- local mod=${opt#*:}
-
- args+=(
- $(usex ${flag} --withmod --withoutmod)-${mod}
- )
- done
-
- local interp=( "${PYTHON}" )
- if use low-memory; then
- interp=( env PYPY_GC_MAX_DELTA=200MB
- "${PYTHON}" --jit loop_longevity=300 )
- fi
-
- # translate into the C sources
- # we're going to make them ourselves since otherwise pypy does not
- # free up the unneeded memory before spawning the compiler
- set -- "${interp[@]}" rpython/bin/rpython --batch --source "${args[@]}"
- echo -e "\033[1m${@}\033[0m"
- "${@}" || die "translation failed"
-}
-
-src_compile() {
- emake -C "${T}"/usession*-0/testing_1
-
- # copy back to make sys.prefix happy
- cp -p "${T}"/usession*-0/testing_1/{pypy-c,libpypy-c.so} . || die
- pax-mark m pypy-c libpypy-c.so
-}
-
-src_install() {
- local flags=( bzip2 jit ncurses sandbox )
- use x86 && flags+=( cpu_flags_x86_sse2 )
- local f suffix="-${ARCH}"
-
- for f in ${flags[@]}; do
- use ${f} && suffix+="+${f#cpu_flags_x86_}"
- done
-
- local BIN_P=pypy-bin-${PV}
-
- einfo "Zipping PyPy ..."
- mkdir "${BIN_P}${suffix}"{,/include} || die
- mv pypy-c libpypy-c.so "${BIN_P}${suffix}"/ || die
- mv include/pypy_* "${BIN_P}${suffix}"/include/ || die
- chmod +x "${BIN_P}${suffix}"/pypy-c || die
-
- tar -cf "${BIN_P}${suffix}.tar" "${BIN_P}${suffix}" || die
- lzip -v9 "${BIN_P}${suffix}.tar" || die
-}
-
-# Yup, very hacky.
-pkg_preinst() {
- # integrity check.
- [[ ${PYPY_BINPKG_STORE} ]] || die 'PYPY_BINPKG_STORE unset, wtf?!'
- mkdir -p "${ROOT}${PYPY_BINPKG_STORE}" || die
- mv "${S}"/*.tar.lz "${ROOT}${PYPY_BINPKG_STORE}" || die
-}
diff --git a/dev-binpkg/pypy3/Manifest b/dev-binpkg/pypy3/Manifest
deleted file mode 100644
index 4fa9943..0000000
--- a/dev-binpkg/pypy3/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST pypy3.6-v7.2.0-src.tar.bz2 21850076 BLAKE2B 756ea3034fe8971c979ec83c9cbfac55a680f3ef03b276475aa4318f3480ae5ede609b8413412df64db553a33979670498b1f97184f3b57406619c9db7f01127 SHA512 bcbb53062a473d504bcc082cf6286f6169c83d1f38d22c4d7c4e46ddc32bca9d91e71194637e6650db5bec02b29fe262b22fe236d627b6bc3e6e0c59c66c07cc
diff --git a/dev-binpkg/pypy3/files/5.9.0-shared-lib.patch b/dev-binpkg/pypy3/files/5.9.0-shared-lib.patch
deleted file mode 100644
index 5d89d3b..0000000
--- a/dev-binpkg/pypy3/files/5.9.0-shared-lib.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -dupr a/rpython/translator/platform/posix.py b/rpython/translator/platform/posix.py
---- a/rpython/translator/platform/posix.py 2017-10-05 20:17:25.009954656 +0200
-+++ b/rpython/translator/platform/posix.py 2017-10-05 20:17:31.115666386 +0200
-@@ -227,7 +227,7 @@ class BasePosix(Platform):
- 'int main(int argc, char* argv[]) '
- '{ return $(PYPY_MAIN_FUNCTION)(argc, argv); }" > $@')
- m.rule('$(DEFAULT_TARGET)', ['$(TARGET)', 'main.o'],
-- ['$(CC_LINK) $(LDFLAGS_LINK) main.o -L. -l$(SHARED_IMPORT_LIB) -o $@ $(RPATH_FLAGS)', '$(MAKE) postcompile BIN=$(DEFAULT_TARGET)'])
-+ ['$(CC_LINK) $(LDFLAGS_LINK) main.o -L. -l$(SHARED_IMPORT_LIB) \'-Wl,-rpath,$$ORIGIN\' -o $@', '$(MAKE) postcompile BIN=$(DEFAULT_TARGET)'])
-
- return m
-
diff --git a/dev-binpkg/pypy3/metadata.xml b/dev-binpkg/pypy3/metadata.xml
deleted file mode 100644
index 5915221..0000000
--- a/dev-binpkg/pypy3/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>mgorny@gentoo.org</email>
- <name>Michał Górny</name>
- </maintainer>
- <use>
- <flag name="low-memory">Build using PyPy with the engine configured towards low memory footprint. This makes it possible to build PyPy using ~3.5G of RAM on amd64 and ~half of that on x86, at the cost of lengthened build time. Please note that you will need an extra ~1G of extra RAM or swap since the translation memory (unused at the time) is not freed when the C compiler is spawned.</flag>
- <flag name="sandbox">Enable sandboxing functionality</flag>
- </use>
-</pkgmetadata>
diff --git a/dev-binpkg/pypy3/pypy3-7.2.0.ebuild b/dev-binpkg/pypy3/pypy3-7.2.0.ebuild
deleted file mode 100644
index e366d41..0000000
--- a/dev-binpkg/pypy3/pypy3-7.2.0.ebuild
+++ /dev/null
@@ -1,196 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# pypy3 needs to be built using python 2
-PYTHON_COMPAT=( python2_7 pypy )
-inherit check-reqs pax-utils python-any-r1 toolchain-funcs
-
-MY_P=pypy3.6-v${PV}
-
-DESCRIPTION="A fast, compliant alternative implementation of the Python (3.6) language"
-HOMEPAGE="http://pypy.org/"
-SRC_URI="https://bitbucket.org/pypy/pypy/downloads/${MY_P}-src.tar.bz2"
-
-LICENSE="MIT"
-# pypy3 -c 'import sysconfig; print(sysconfig.get_config_var("SOABI"))'
-SLOT="0/71"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="bzip2 +jit low-memory ncurses sandbox cpu_flags_x86_sse2"
-
-DEPEND=">=sys-libs/zlib-1.1.3:0=
- virtual/libffi:0=
- virtual/libintl:0=
- dev-libs/expat:0=
- bzip2? ( app-arch/bzip2:0= )
- ncurses? ( sys-libs/ncurses:0= )
- app-arch/lzip
- low-memory? ( virtual/pypy:0 )
- !low-memory? ( ${PYTHON_DEPS} )"
-# doc? ( dev-python/sphinx )
-
-S="${WORKDIR}/${MY_P}-src"
-
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- if use low-memory; then
- CHECKREQS_MEMORY="1750M"
- use amd64 && CHECKREQS_MEMORY="3500M"
- else
- CHECKREQS_MEMORY="3G"
- use amd64 && CHECKREQS_MEMORY="6G"
- fi
-
- check-reqs_pkg_pretend
- fi
-}
-
-pkg_setup() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- pkg_pretend
-
- # unset to allow forcing pypy below :)
- use low-memory && local EPYTHON=
- if python_is_installed pypy && [[ ! ${EPYTHON} || ${EPYTHON} == pypy ]]; then
- einfo "Using PyPy to perform the translation."
- local EPYTHON=pypy
- else
- einfo "Using ${EPYTHON:-python2} to perform the translation. Please note that upstream"
- einfo "recommends using PyPy for that. If you wish to do so, please install"
- einfo "virtual/pypy and ensure that EPYTHON variable is unset."
- fi
-
- python-any-r1_pkg_setup
-
- local cpu
- if use amd64; then
- # common denominator between Intel & AMD
- cpu='x86-64'
- elif use x86; then
- if use cpu_flags_x86_sse2; then
- # lowest with SSE2
- cpu='pentium-m'
- else
- # lowest with SSE, compat. with athlon-xp
- # TODO: do we want to support something older?
- cpu='pentium3'
- fi
- else
- die "Unsupported arch ${ARCH}"
- fi
-
- export CFLAGS="-march=${cpu} -mtune=generic -O2 -pipe"
- export CXXFLAGS=${CFLAGS}
-
- elog "CFLAGS: ${CFLAGS}"
- fi
-}
-
-src_prepare() {
- eapply "${FILESDIR}"/5.9.0-shared-lib.patch # 517002
-
- eapply_user
-}
-
-src_configure() {
- tc-export CC
-
- local jit_backend
- if use jit; then
- jit_backend='--jit-backend='
-
- # We only need the explicit sse2 switch for x86.
- # On other arches we can rely on autodetection which uses
- # compiler macros. Plus, --jit-backend= doesn't accept all
- # the modern values...
-
- if use x86; then
- if use cpu_flags_x86_sse2; then
- jit_backend+=x86
- else
- jit_backend+=x86-without-sse2
- fi
- else
- jit_backend+=auto
- fi
- fi
-
- local args=(
- --shared
- $(usex jit -Ojit -O2)
- $(usex sandbox --sandbox '')
-
- ${jit_backend}
-
- pypy/goal/targetpypystandalone
- )
-
- # Avoid linking against libraries disabled by use flags
- local opts=(
- bzip2:bz2
- ncurses:_minimal_curses
- )
-
- local opt
- for opt in "${opts[@]}"; do
- local flag=${opt%:*}
- local mod=${opt#*:}
-
- args+=(
- $(usex ${flag} --withmod --withoutmod)-${mod}
- )
- done
-
- local interp=( "${PYTHON}" )
- if use low-memory; then
- interp=( env PYPY_GC_MAX_DELTA=200MB
- "${PYTHON}" --jit loop_longevity=300 )
- fi
-
- # translate into the C sources
- # we're going to make them ourselves since otherwise pypy does not
- # free up the unneeded memory before spawning the compiler
- set -- "${interp[@]}" rpython/bin/rpython --batch --source "${args[@]}"
- echo -e "\033[1m${@}\033[0m"
- "${@}" || die "translation failed"
-}
-
-src_compile() {
- emake -C "${T}"/usession*-0/testing_1
-
- # copy back to make sys.prefix happy
- cp -p "${T}"/usession*-0/testing_1/{pypy3-c,libpypy3-c.so} . || die
- pax-mark m pypy3-c libpypy3-c.so
-
- #use doc && emake -C pypy/doc html
-}
-
-src_install() {
- local flags=( bzip2 jit ncurses sandbox )
- use x86 && flags+=( cpu_flags_x86_sse2 )
- local f suffix="-${ARCH}"
-
- for f in ${flags[@]}; do
- use ${f} && suffix+="+${f#cpu_flags_x86_}"
- done
-
- local BIN_P=pypy3-bin-${PV}
-
- einfo "Zipping PyPy ..."
- mkdir "${BIN_P}${suffix}"{,/include} || die
- mv pypy3-c libpypy3-c.so "${BIN_P}${suffix}"/ || die
- mv include/pypy_* "${BIN_P}${suffix}"/include/ || die
- chmod +x "${BIN_P}${suffix}"/pypy3-c || die
-
- tar -cf "${BIN_P}${suffix}.tar" "${BIN_P}${suffix}" || die
- lzip -v9 "${BIN_P}${suffix}.tar" || die
-}
-
-# Yup, very hacky.
-pkg_preinst() {
- # integrity check.
- [[ ${PYPY_BINPKG_STORE} ]] || die 'PYPY_BINPKG_STORE unset, wtf?!'
- mkdir -p "${ROOT}${PYPY_BINPKG_STORE}" || die
- mv "${S}"/*.tar.lz "${ROOT}${PYPY_BINPKG_STORE}" || die
-}