summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-08-15 10:10:13 +0200
committerMichał Górny <mgorny@gentoo.org>2019-08-15 10:10:13 +0200
commit21aeb29ab2c7b8162467b4b679e1e946a0f1754a (patch)
tree4ec644996f480f9bc3cd624bc9bd190a434d03d4 /dev-binpkg
parentdev-binpkg/pypy3: Bump to 7.1.1 (diff)
downloadmgorny-21aeb29ab2c7b8162467b4b679e1e946a0f1754a.tar.gz
mgorny-21aeb29ab2c7b8162467b4b679e1e946a0f1754a.tar.bz2
mgorny-21aeb29ab2c7b8162467b4b679e1e946a0f1754a.zip
dev-binpkg/pypy3: Restore non-SSE2 x86 backend
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-binpkg')
-rw-r--r--dev-binpkg/pypy3/pypy3-7.1.1.ebuild22
1 files changed, 21 insertions, 1 deletions
diff --git a/dev-binpkg/pypy3/pypy3-7.1.1.ebuild b/dev-binpkg/pypy3/pypy3-7.1.1.ebuild
index f1e198c..c104421 100644
--- a/dev-binpkg/pypy3/pypy3-7.1.1.ebuild
+++ b/dev-binpkg/pypy3/pypy3-7.1.1.ebuild
@@ -98,12 +98,32 @@ src_prepare() {
src_configure() {
tc-export CC
+ local jit_backend
+ if use jit; then
+ jit_backend='--jit-backend='
+
+ # We only need the explicit sse2 switch for x86.
+ # On other arches we can rely on autodetection which uses
+ # compiler macros. Plus, --jit-backend= doesn't accept all
+ # the modern values...
+
+ if use x86; then
+ if use cpu_flags_x86_sse2; then
+ jit_backend+=x86
+ else
+ jit_backend+=x86-without-sse2
+ fi
+ else
+ jit_backend+=auto
+ fi
+ fi
+
local args=(
--shared
$(usex jit -Ojit -O2)
$(usex sandbox --sandbox '')
- --jit-backend=auto
+ ${jit_backend}
pypy/goal/targetpypystandalone
)