summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-binpkg/pypy3/pypy3-7.0.0.ebuild')
-rw-r--r--dev-binpkg/pypy3/pypy3-7.0.0.ebuild178
1 files changed, 0 insertions, 178 deletions
diff --git a/dev-binpkg/pypy3/pypy3-7.0.0.ebuild b/dev-binpkg/pypy3/pypy3-7.0.0.ebuild
deleted file mode 100644
index e9d7985..0000000
--- a/dev-binpkg/pypy3/pypy3-7.0.0.ebuild
+++ /dev/null
@@ -1,178 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# pypy3 needs to be built using python 2
-PYTHON_COMPAT=( python2_7 pypy )
-inherit check-reqs pax-utils python-any-r1 toolchain-funcs
-
-MY_P=pypy3.5-v${PV}
-
-DESCRIPTION="A fast, compliant alternative implementation of the Python (3.5) language"
-HOMEPAGE="http://pypy.org/"
-SRC_URI="https://bitbucket.org/pypy/pypy/downloads/${MY_P}-src.tar.bz2"
-
-LICENSE="MIT"
-# pypy3 -c 'import sysconfig; print(sysconfig.get_config_var("SOABI"))'
-SLOT="0/71"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="bzip2 +jit libressl low-memory ncurses sandbox cpu_flags_x86_sse2"
-
-DEPEND=">=sys-libs/zlib-1.1.3:0=
- virtual/libffi:0=
- virtual/libintl:0=
- dev-libs/expat:0=
- !libressl? ( dev-libs/openssl:0=[-bindist] )
- libressl? ( dev-libs/libressl:0= )
- bzip2? ( app-arch/bzip2:0= )
- ncurses? ( sys-libs/ncurses:0= )
- app-arch/lzip
- low-memory? ( virtual/pypy:0 )
- !low-memory? ( ${PYTHON_DEPS} )"
-# doc? ( dev-python/sphinx )
-
-S="${WORKDIR}/${MY_P}-src"
-
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- if use low-memory; then
- CHECKREQS_MEMORY="1750M"
- use amd64 && CHECKREQS_MEMORY="3500M"
- else
- CHECKREQS_MEMORY="3G"
- use amd64 && CHECKREQS_MEMORY="6G"
- fi
-
- check-reqs_pkg_pretend
- fi
-}
-
-pkg_setup() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- pkg_pretend
-
- # unset to allow forcing pypy below :)
- use low-memory && local EPYTHON=
- if python_is_installed pypy && [[ ! ${EPYTHON} || ${EPYTHON} == pypy ]]; then
- einfo "Using PyPy to perform the translation."
- local EPYTHON=pypy
- else
- einfo "Using ${EPYTHON:-python2} to perform the translation. Please note that upstream"
- einfo "recommends using PyPy for that. If you wish to do so, please install"
- einfo "virtual/pypy and ensure that EPYTHON variable is unset."
- fi
-
- python-any-r1_pkg_setup
-
- local cpu
- if use amd64; then
- # common denominator between Intel & AMD
- cpu='x86-64'
- elif use x86; then
- if use cpu_flags_x86_sse2; then
- # lowest with SSE2
- cpu='pentium-m'
- else
- # lowest with SSE, compat. with athlon-xp
- # TODO: do we want to support something older?
- cpu='pentium3'
- fi
- else
- die "Unsupported arch ${ARCH}"
- fi
-
- export CFLAGS="-march=${cpu} -mtune=generic -O2 -pipe"
- export CXXFLAGS=${CFLAGS}
-
- elog "CFLAGS: ${CFLAGS}"
- fi
-}
-
-src_prepare() {
- eapply "${FILESDIR}"/5.9.0-shared-lib.patch # 517002
-
- eapply_user
-}
-
-src_configure() {
- tc-export CC
-
- local args=(
- --shared
- $(usex jit -Ojit -O2)
- $(usex sandbox --sandbox '')
-
- --jit-backend=auto
-
- pypy/goal/targetpypystandalone
- )
-
- # Avoid linking against libraries disabled by use flags
- local opts=(
- bzip2:bz2
- ncurses:_minimal_curses
- )
-
- local opt
- for opt in "${opts[@]}"; do
- local flag=${opt%:*}
- local mod=${opt#*:}
-
- args+=(
- $(usex ${flag} --withmod --withoutmod)-${mod}
- )
- done
-
- local interp=( "${PYTHON}" )
- if use low-memory; then
- interp=( env PYPY_GC_MAX_DELTA=200MB
- "${PYTHON}" --jit loop_longevity=300 )
- fi
-
- # translate into the C sources
- # we're going to make them ourselves since otherwise pypy does not
- # free up the unneeded memory before spawning the compiler
- set -- "${interp[@]}" rpython/bin/rpython --batch --source "${args[@]}"
- echo -e "\033[1m${@}\033[0m"
- "${@}" || die "translation failed"
-}
-
-src_compile() {
- emake -C "${T}"/usession*-0/testing_1
-
- # copy back to make sys.prefix happy
- cp -p "${T}"/usession*-0/testing_1/{pypy3-c,libpypy3-c.so} . || die
- pax-mark m pypy3-c libpypy3-c.so
-
- #use doc && emake -C pypy/doc html
-}
-
-src_install() {
- local flags=( bzip2 jit ncurses sandbox )
- use x86 && flags+=( cpu_flags_x86_sse2 )
- local f suffix="-${ARCH}"
-
- for f in ${flags[@]}; do
- use ${f} && suffix+="+${f#cpu_flags_x86_}"
- done
-
- local BIN_P=pypy3-bin-${PV}
-
- einfo "Zipping PyPy ..."
- mkdir "${BIN_P}${suffix}"{,/include} || die
- mv pypy3-c libpypy3-c.so "${BIN_P}${suffix}"/ || die
- mv include/pypy_* "${BIN_P}${suffix}"/include/ || die
- chmod +x "${BIN_P}${suffix}"/pypy3-c || die
-
- tar -cf "${BIN_P}${suffix}.tar" "${BIN_P}${suffix}" || die
- lzip -v9 "${BIN_P}${suffix}.tar" || die
-}
-
-# Yup, very hacky.
-pkg_preinst() {
- # integrity check.
- [[ ${PYPY_BINPKG_STORE} ]] || die 'PYPY_BINPKG_STORE unset, wtf?!'
- mkdir -p "${ROOT%/}${PYPY_BINPKG_STORE}" || die
- mv "${S}"/*.tar.lz "${ROOT%/}${PYPY_BINPKG_STORE}" || die
-}