summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-08-10 14:44:03 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-08-10 15:37:11 +0200
commit00852cae56d2f9c5764686f328e0925f90fe44f6 (patch)
treeaffd7874f06c138c77a43ea5332c78916f23ac8b
parentapp-emacs/string-inflection: new package; add version 1.0.16 (diff)
downloadgentoo-00852cae56d2f9c5764686f328e0925f90fe44f6.tar.gz
gentoo-00852cae56d2f9c5764686f328e0925f90fe44f6.tar.bz2
gentoo-00852cae56d2f9c5764686f328e0925f90fe44f6.zip
app-emacs/yaml: new package; add version 0.5.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/yaml/Manifest1
-rw-r--r--app-emacs/yaml/files/50yaml-gentoo.el1
-rw-r--r--app-emacs/yaml/metadata.xml18
-rw-r--r--app-emacs/yaml/yaml-0.5.1.ebuild25
4 files changed, 45 insertions, 0 deletions
diff --git a/app-emacs/yaml/Manifest b/app-emacs/yaml/Manifest
new file mode 100644
index 000000000000..4035343c164a
--- /dev/null
+++ b/app-emacs/yaml/Manifest
@@ -0,0 +1 @@
+DIST yaml-0.5.1.tar.gz 44335 BLAKE2B dbcaf29d5d0a18e167cf0fd43d5ea0536d3879ed8bc924930c06aa1eedb2c268f91fd2d0c8981ab81f928db82148ad7fbc01a5926b3dd4645ec57cc78bac7256 SHA512 4ed2dc26a87137deb2d06cffac7c9b0748f66a9b05d91e33022da0edee0966b94ac2dfdb5a181628357dd3714ac55cfb48b1a35f9f6352c01d745a1d69131381
diff --git a/app-emacs/yaml/files/50yaml-gentoo.el b/app-emacs/yaml/files/50yaml-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/yaml/files/50yaml-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/yaml/metadata.xml b/app-emacs/yaml/metadata.xml
new file mode 100644
index 000000000000..ebb91ed4f6fa
--- /dev/null
+++ b/app-emacs/yaml/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ yaml.el is a YAML parser written in Emacs List without any external
+ dependencies. It provides an interface similar to the Emacs JSON parsing
+ utility.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/zkry/yaml.el/issues/</bugs-to>
+ <remote-id type="github">zkry/yaml.el</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/yaml/yaml-0.5.1.ebuild b/app-emacs/yaml/yaml-0.5.1.ebuild
new file mode 100644
index 000000000000..7e951ead7442
--- /dev/null
+++ b/app-emacs/yaml/yaml-0.5.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=25.1
+
+inherit elisp
+
+DESCRIPTION="YAML parser in Emacs Lisp"
+HOMEPAGE="https://github.com/zkry/yaml.el/"
+SRC_URI="https://github.com/zkry/yaml.el/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/yaml.el-${PV}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ # "test/string-inflection-test.el" calls "(ert-run-tests-batch t)"
+ ${EMACS} ${EMACSFLAGS} -L . -l yaml-tests.el || die
+}