summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-03-22 02:55:12 -0500
committerJames Le Cuirot <chewi@gentoo.org>2018-03-22 21:06:05 +0000
commit00de856ef8bed699cf27efa738c705d929e2786e (patch)
treeeb0a83d73666676c54e8525dedefaec64d73254f
parentnet-dns/dnsmasq: Add "missingok" to logrotate script (diff)
downloadgentoo-00de856ef8bed699cf27efa738c705d929e2786e.tar.gz
gentoo-00de856ef8bed699cf27efa738c705d929e2786e.tar.bz2
gentoo-00de856ef8bed699cf27efa738c705d929e2786e.zip
app-crypt/rhash: pass --target=${CHOST} to configure
Without this change, app-crypt/rhash when built with a mingw-w64 crossdev toolchain ends up with the various rhash binaries being PE32 binaries without an '*.exe' extension and librhash having a '*.so' extension, also a PE32 library, and no import library ('*.dll.a'). Package-Manager: Portage-2.3.24, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/7548
-rw-r--r--app-crypt/rhash/rhash-1.3.6-r1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/app-crypt/rhash/rhash-1.3.6-r1.ebuild b/app-crypt/rhash/rhash-1.3.6-r1.ebuild
index affa82411479..69f97e6e47ab 100644
--- a/app-crypt/rhash/rhash-1.3.6-r1.ebuild
+++ b/app-crypt/rhash/rhash-1.3.6-r1.ebuild
@@ -34,6 +34,7 @@ src_prepare() {
multilib_src_configure() {
set -- \
./configure \
+ --target="${CHOST}" \
--cc="$(tc-getCC)" \
--ar="$(tc-getAR)" \
--extra-cflags="${CFLAGS}" \
@@ -59,8 +60,9 @@ multilib_src_configure() {
multilib_src_install() {
# -j1 needed due to race condition.
emake DESTDIR="${D}" -j1 \
- install{,-lib-so-link,-pkg-config} \
- $(use nls && echo install-gmo)
+ install{,-pkg-config} \
+ $(use nls && echo install-gmo) \
+ $(use kernel_Winnt || echo install-lib-so-link)
emake DESTDIR="${D}" -j1 \
-C lib${PN} install-headers