summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-20 09:37:33 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-20 10:29:20 +0200
commit012b60feafc66ebf183c3eb0b0c124288cb8e3d8 (patch)
tree4161dd4368db9a7303c21bedfcd2ab3ec3b94373
parentdev-python/fsspec: Bump to 2022.5.0 (diff)
downloadgentoo-012b60feafc66ebf183c3eb0b0c124288cb8e3d8.tar.gz
gentoo-012b60feafc66ebf183c3eb0b0c124288cb8e3d8.tar.bz2
gentoo-012b60feafc66ebf183c3eb0b0c124288cb8e3d8.zip
dev-python/cfn-lint: Bump to 0.60.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.60.1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index e3cda892df25..de2ed1a1a1f9 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -1,3 +1,4 @@
DIST cfn-lint-0.59.0.tar.gz 9004743 BLAKE2B e778c1081e45dacc813f8a4ae7726eb929fabcdbfaafcbbc5f0d925cfe32773851366c9488363728ae42349cbe899a6cacd114940ee8d76dc284b30ea87fe19a SHA512 e8e9d0fb1f366c49f8a008000a808ec4b6c4299ff3c9650229619d8e48f1812709ecd54274163d8bd389c6823f20accd7d31f6147bec926ec233ede3ee51ee10
DIST cfn-lint-0.59.1.tar.gz 9065067 BLAKE2B 63fc591f7ed60eed2ef7fa1e9ea212e3e8569cfd20dec8bb8505dbfb8e96ee8f8ab6136d88de58b2db8823675946dc99b38adeb3b5c784d165083e1353100b00 SHA512 a08b4bf4dc8e7ab41bb72eb9309ca4f03eed3b6f5c31b3876dc9d08610312377a7c229de883c287e7e5ed6597f8eada79a111882785888e43b0ff20160e39fe0
DIST cfn-lint-0.60.0.tar.gz 9127890 BLAKE2B f3e1e99f4657cad13037a74e94cca53548ecfb5bd41c11f8dc82c5fe962d7dc87b7a62aeaa12bc7012a11472736d9026fa51a7e7bc39e67b062a4e8449dd0eb6 SHA512 5eb0ecd51a2d845bad52e2aa7decc6ff7d28d008bc63aa1419ba122bca6df56b5689cb91e669384ca98418537bd36e460f19fb9dfd96e718260d29e228ea824e
+DIST cfn-lint-0.60.1.tar.gz 9144208 BLAKE2B ff0cc155aee6fb0c72a3011a5fbaf147158d23ab8ed11426a9fc922971019cb276b74ca4e8972ddc2dbab7b1239ddb00b1d7a60281763a9773157b97ce5a8105 SHA512 8d023773a82b0b8486431e438d298e80812726d197017aafd925d6d9aa8272db99dc594f1b8f7582843ffaa9d421d6d9300f80c3bb6e932e705ae019d1cd8e21
diff --git a/dev-python/cfn-lint/cfn-lint-0.60.1.ebuild b/dev-python/cfn-lint/cfn-lint-0.60.1.ebuild
new file mode 100644
index 000000000000..5ec074be0d4b
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-0.60.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+SRC_URI="
+ https://github.com/aws-cloudformation/cfn-lint/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.45.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema_to_python-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/sarif_om-1.0.4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_2
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+)
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ distutils-r1_src_prepare
+}