summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-10 15:48:23 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-10 15:49:39 +0100
commit0175275d8be0aeba6fd81d2d2529304f74af5cf2 (patch)
tree05f6d7d9294c327156ebc2ab279d20818c393dd0
parentdev-python/boto3: Remove old (diff)
downloadgentoo-0175275d8be0aeba6fd81d2d2529304f74af5cf2.tar.gz
gentoo-0175275d8be0aeba6fd81d2d2529304f74af5cf2.tar.bz2
gentoo-0175275d8be0aeba6fd81d2d2529304f74af5cf2.zip
dev-python/s3transfer: Remove Python < 3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/s3transfer/s3transfer-0.6.0-r1.ebuild4
-rw-r--r--dev-python/s3transfer/s3transfer-0.6.0.ebuild44
2 files changed, 2 insertions, 46 deletions
diff --git a/dev-python/s3transfer/s3transfer-0.6.0-r1.ebuild b/dev-python/s3transfer/s3transfer-0.6.0-r1.ebuild
index fb661e81e32a..efdb1aa6e19d 100644
--- a/dev-python/s3transfer/s3transfer-0.6.0-r1.ebuild
+++ b/dev-python/s3transfer/s3transfer-0.6.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -17,7 +17,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
RDEPEND="
>=dev-python/botocore-1.24.7[${PYTHON_USEDEP}]
diff --git a/dev-python/s3transfer/s3transfer-0.6.0.ebuild b/dev-python/s3transfer/s3transfer-0.6.0.ebuild
deleted file mode 100644
index abfa397eeb38..000000000000
--- a/dev-python/s3transfer/s3transfer-0.6.0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="An Amazon S3 Transfer Manager"
-HOMEPAGE="
- https://github.com/boto/s3transfer/
- https://pypi.org/project/s3transfer/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- >=dev-python/botocore-1.24.7[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # do not rely on bundled deps in botocore (sic!)
- find -name '*.py' -exec sed -i \
- -e 's:from botocore[.]vendored import:import:' \
- -e 's:from botocore[.]vendored[.]:from :' \
- {} + || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- epytest tests/{unit,functional}
-}