summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-06-28 14:07:59 -0400
committerMatt Turner <mattst88@gentoo.org>2022-06-28 14:10:48 -0400
commit0185de40852adb65d0a21aad34a0a157d3256f7f (patch)
treedb8a7e3e316102d96cf64ce1dbddddd68b530edb
parentmedia-libs/harfbuzz: Add Python 3.11 compatibility (diff)
downloadgentoo-0185de40852adb65d0a21aad34a0a157d3256f7f.tar.gz
gentoo-0185de40852adb65d0a21aad34a0a157d3256f7f.tar.bz2
gentoo-0185de40852adb65d0a21aad34a0a157d3256f7f.zip
media-libs/harfbuzz: Version bump to 4.4.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--media-libs/harfbuzz/Manifest1
-rw-r--r--media-libs/harfbuzz/harfbuzz-4.4.0.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/media-libs/harfbuzz/Manifest b/media-libs/harfbuzz/Manifest
index 868b6c512064..9a10f8e8a202 100644
--- a/media-libs/harfbuzz/Manifest
+++ b/media-libs/harfbuzz/Manifest
@@ -1,2 +1,3 @@
DIST harfbuzz-4.2.1.tar.gz 29096419 BLAKE2B eb523c2e3c956559e2445bd12719b14c244cfdedd239041afec71a17912e489adb94c0b6fe148c60ae9e908cc3e740752de2a33a255c123ef937debe6008d78b SHA512 de14b673f6bd03d561c45f94e9bda44ee41897a643ab8837493260a83b1eb1f1ca0fe105c1bee241f2ecd6ab869dbccf3ffba8e2c4ee9a3a1fca4e1c6c7ca4f3
DIST harfbuzz-4.3.0.tar.gz 29200217 BLAKE2B dfe5e3b47e3d89a5ad7c6eaf6d274027a0eb05d1994b922d3124c97270f34353384c0161d8815fb2e379e82c8bdf046843902ba53db38daa4348e99d99255900 SHA512 bccf7cfb06ac18a9a9bf465c30dbfb51d73762a6667b3a069a85f9f597e6d27858e9e39a36cce12e23ec5b002b9e572638bf00c76bdea66545ae67a2bb7915f4
+DIST harfbuzz-4.4.0.tar.gz 29226048 BLAKE2B 6534002bc750f12b960289aaff7129b15b2d53a043e67f6273f65fc311cb1767b9649eeb885b90358b595a12ac2f20e83dbe9252518852c8d0e2b213ff004004 SHA512 dd0a9768fa6c60c100d8b053ebc2ce06d236c9b06af0b99ca30ac6567298e94744d22d94ea1c8d8a0af8dcefaeda9328804964b80b8d278dab8978f933ef66d1
diff --git a/media-libs/harfbuzz/harfbuzz-4.4.0.ebuild b/media-libs/harfbuzz/harfbuzz-4.4.0.ebuild
new file mode 100644
index 000000000000..c0e115b06945
--- /dev/null
+++ b/media-libs/harfbuzz/harfbuzz-4.4.0.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit flag-o-matic meson-multilib python-any-r1 xdg-utils
+
+DESCRIPTION="An OpenType text shaping engine"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/HarfBuzz"
+
+if [[ ${PV} = 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/harfbuzz/harfbuzz.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+LICENSE="Old-MIT ISC icu"
+# 0.9.18 introduced the harfbuzz-icu split; bug #472416
+# 3.0.0 dropped some unstable APIs; bug #813705
+SLOT="0/4.0.0"
+
+IUSE="+cairo debug doc experimental +glib +graphite icu +introspection test +truetype"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="introspection? ( glib )"
+
+RDEPEND="
+ cairo? ( x11-libs/cairo:= )
+ glib? ( >=dev-libs/glib-2.38:2[${MULTILIB_USEDEP}] )
+ graphite? ( >=media-gfx/graphite2-1.2.1:=[${MULTILIB_USEDEP}] )
+ icu? ( >=dev-libs/icu-51.2-r1:=[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.34:= )
+ truetype? ( >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/gobject-introspection-common-1.34
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )
+ introspection? ( dev-util/glib-utils )
+"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ if ! use debug ; then
+ append-cppflags -DHB_NDEBUG
+ fi
+}
+
+src_prepare() {
+ default
+
+ xdg_environment_reset
+
+ sed -i \
+ -e '/tests\/macos\.tests/d' \
+ test/shape/data/in-house/Makefile.sources \
+ || die # bug 726120
+
+ # bug 618772
+ append-cxxflags -std=c++14
+
+ # bug 790359
+ filter-flags -fexceptions -fthreadsafe-statics
+
+ # bug 762415
+ local pyscript
+ for pyscript in $(find -type f -name "*.py") ; do
+ python_fix_shebang -q "${pyscript}"
+ done
+}
+
+multilib_src_configure() {
+ # harfbuzz-gobject only used for introspection, bug #535852
+ local emesonargs=(
+ -Dcoretext="disabled"
+ -Dchafa="disabled"
+
+ $(meson_feature glib)
+ $(meson_feature graphite graphite2)
+ $(meson_feature icu)
+ $(meson_feature introspection gobject)
+ $(meson_feature test tests)
+ $(meson_feature truetype freetype)
+
+ $(meson_native_use_feature cairo)
+ $(meson_native_use_feature doc docs)
+ $(meson_native_use_feature introspection)
+
+ $(meson_use experimental experimental_api)
+ )
+ meson_src_configure
+}