summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-05-23 10:09:29 -0400
committerMike Gilbert <floppym@gentoo.org>2020-05-23 10:14:50 -0400
commit01a4e92dc9136172e3ef15378790bb12cd617cb1 (patch)
treec9d1b2ca9f5ec2272db64d7ddd30305c893ead1d
parentgames-fps/eduke32: fix compilation with gcc-10 (diff)
downloadgentoo-01a4e92dc9136172e3ef15378790bb12cd617cb1.tar.gz
gentoo-01a4e92dc9136172e3ef15378790bb12cd617cb1.tar.bz2
gentoo-01a4e92dc9136172e3ef15378790bb12cd617cb1.zip
net-p2p/transmission: bump to 3.00
Closes: https://bugs.gentoo.org/607336 Bug: https://bugs.gentoo.org/723258 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--net-p2p/transmission/Manifest1
-rw-r--r--net-p2p/transmission/transmission-3.00.ebuild142
-rw-r--r--net-p2p/transmission/transmission-9999.ebuild10
3 files changed, 144 insertions, 9 deletions
diff --git a/net-p2p/transmission/Manifest b/net-p2p/transmission/Manifest
index 07399390981e..5fd51e6815c6 100644
--- a/net-p2p/transmission/Manifest
+++ b/net-p2p/transmission/Manifest
@@ -1 +1,2 @@
DIST transmission-2.94.tar.xz 3365952 BLAKE2B d0215a2c595dd3ebb2ed5c94cc3d380c78f62b98388557620534b88b9e2304bb6ac91960395541267f82d70800c4860d0e58125bca33dd158da992d19b4c0def SHA512 ee411743940f2897aa0bbc351ce79f11d860075d2e9e399d60301eae8cfc453e20426ef553fc62ee43019a07c052d512f5d7972cc4411fb57b1312c2c1558da7
+DIST transmission-3.00.tar.xz 3995080 BLAKE2B fb1be44aa630e6a1cf15511ab4ab40156edb16f9410b83058c53548f466fb9502c23157756a29e921e4468db1ebac7832b755cfcf98451c663c64401559f5498 SHA512 c8fb96086ba4b18f04d6181a29f6e2af85864840c533f3470a202dfa686e9431caeccd25f12c975a9a8f9b7802ca0bd73c4edc1ca06bdbada682326cad188a76
diff --git a/net-p2p/transmission/transmission-3.00.ebuild b/net-p2p/transmission/transmission-3.00.ebuild
new file mode 100644
index 000000000000..04a6fdf45294
--- /dev/null
+++ b/net-p2p/transmission/transmission-3.00.ebuild
@@ -0,0 +1,142 @@
+# Copyright 2006-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake systemd xdg-utils
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/transmission/transmission"
+else
+ SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A fast, easy, and free BitTorrent client"
+HOMEPAGE="https://transmissionbt.com/"
+
+# web/LICENSE is always GPL-2 whereas COPYING allows either GPL-2 or GPL-3 for the rest
+# transmission in licenses/ is for mentioning OpenSSL linking exception
+# MIT is in several libtransmission/ headers
+LICENSE="|| ( GPL-2 GPL-3 Transmission-OpenSSL-exception ) GPL-2 MIT"
+SLOT="0"
+IUSE="appindicator gtk libressl lightweight nls mbedtls qt5 systemd test"
+RESTRICT="!test? ( test )"
+
+ACCT_DEPEND="
+ acct-group/transmission
+ acct-user/transmission
+"
+BDEPEND="${ACCT_DEPEND}
+ virtual/pkgconfig
+ nls? (
+ gtk? (
+ dev-util/intltool
+ sys-devel/gettext
+ )
+ qt5? (
+ dev-qt/linguist-tools:5
+ )
+ )
+"
+COMMON_DEPEND="
+ dev-libs/libb64:0=
+ >=dev-libs/libevent-2.0.10:=
+ !mbedtls? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ mbedtls? ( net-libs/mbedtls:0= )
+ net-libs/libnatpmp
+ >=net-libs/miniupnpc-1.7:=
+ >=net-misc/curl-7.16.3[ssl]
+ sys-libs/zlib:=
+ nls? ( virtual/libintl )
+ gtk? (
+ >=dev-libs/dbus-glib-0.100
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/gtk+-3.4:3
+ appindicator? ( >=dev-libs/libappindicator-0.4.30:3 )
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtdbus:5
+ )
+ systemd? ( >=sys-apps/systemd-209:= )
+"
+DEPEND="${COMMON_DEPEND}
+ nls? (
+ virtual/libintl
+ gtk? (
+ dev-util/intltool
+ sys-devel/gettext
+ )
+ qt5? (
+ dev-qt/linguist-tools:5
+ )
+ )
+"
+RDEPEND="${COMMON_DEPEND}
+ ${ACCT_DEPEND}
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DOCDIR=share/doc/${PF}
+
+ -DENABLE_GTK=$(usex gtk ON OFF)
+ -DENABLE_LIGHTWEIGHT=$(usex lightweight ON OFF)
+ -DENABLE_NLS=$(usex nls ON OFF)
+ -DENABLE_QT=$(usex qt5 ON OFF)
+ -DENABLE_TESTS=$(usex test ON OFF)
+
+ -DUSE_SYSTEM_EVENT2=ON
+ -DUSE_SYSTEM_DHT=OFF
+ -DUSE_SYSTEM_MINIUPNPC=ON
+ -DUSE_SYSTEM_NATPMP=ON
+ -DUSE_SYSTEM_UTP=OFF
+ -DUSE_SYSTEM_B64=ON
+
+ -DWITH_CRYPTO=$(usex mbedtls polarssl openssl)
+ -DWITH_INOTIFY=ON
+ -DWITH_LIBAPPINDICATOR=$(usex appindicator ON OFF)
+ -DWITH_SYSTEMD=$(usex systemd ON OFF)
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ newinitd "${FILESDIR}"/transmission-daemon.initd.10 transmission-daemon
+ newconfd "${FILESDIR}"/transmission-daemon.confd.4 transmission-daemon
+ systemd_dounit daemon/transmission-daemon.service
+ systemd_install_serviced "${FILESDIR}"/transmission-daemon.service.conf
+
+ insinto /usr/lib/sysctl.d
+ doins "${FILESDIR}"/60-transmission.conf
+
+ if [[ ${EUID} == 0 ]]; then
+ diropts -o transmission -g transmission
+ fi
+ keepdir /var/lib/transmission
+}
+
+pkg_postrm() {
+ if use gtk || use qt5; then
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ fi
+}
+
+pkg_postinst() {
+ if use gtk || use qt5; then
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ fi
+}
diff --git a/net-p2p/transmission/transmission-9999.ebuild b/net-p2p/transmission/transmission-9999.ebuild
index 36907b345d40..50983831d05b 100644
--- a/net-p2p/transmission/transmission-9999.ebuild
+++ b/net-p2p/transmission/transmission-9999.ebuild
@@ -10,7 +10,7 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/transmission/transmission"
else
SRC_URI="https://github.com/transmission/transmission-releases/raw/master/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux"
+ KEYWORDS="~amd64 ~x86"
fi
DESCRIPTION="A fast, easy, and free BitTorrent client"
@@ -84,14 +84,6 @@ RDEPEND="${COMMON_DEPEND}
${ACCT_DEPEND}
"
-src_unpack() {
- if [[ ${PV} == 9999 ]]; then
- git-r3_src_unpack
- else
- unpack ${P}.tar.gz
- fi
-}
-
src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_DOCDIR=share/doc/${PF}