summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2023-01-27 12:54:35 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2023-01-27 13:01:34 -0600
commit01fc6402428f5a9ae1725df8950912af6ea3250d (patch)
treebb3a3ffce7df95dadf50d7b4c8476a6440792a69
parentpackage.mask: fix date in mask (diff)
downloadgentoo-01fc6402428f5a9ae1725df8950912af6ea3250d.tar.gz
gentoo-01fc6402428f5a9ae1725df8950912af6ea3250d.tar.bz2
gentoo-01fc6402428f5a9ae1725df8950912af6ea3250d.zip
www-apps/icingaweb2: add 2.11.4
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--www-apps/icingaweb2/Manifest1
-rw-r--r--www-apps/icingaweb2/icingaweb2-2.11.4.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/www-apps/icingaweb2/Manifest b/www-apps/icingaweb2/Manifest
index 769bd986825a..779f492245f0 100644
--- a/www-apps/icingaweb2/Manifest
+++ b/www-apps/icingaweb2/Manifest
@@ -1,2 +1,3 @@
DIST icingaweb2-2.11.2.tar.gz 11412429 BLAKE2B 76d47cfa3558ff647b425c725dae40e10359ec6aa117cb5f7dc615dff98bf9e4e2b73b21bb37f02e9c0737d2d734f816532edc3da34fb3f52238eae676b611bc SHA512 c316b918c7c2bdd77b5815ba1b4f52604f9fd3801f8a4896ae416d27b2979238fb2ae619cb0048048c99c69fbc28352f57cd73f118d7afc84fbe0668b85b59e1
DIST icingaweb2-2.11.3.tar.gz 11437384 BLAKE2B d77dfc6cb0640dcdae0206597ff7704fbebdc603672ed0ec1002dd2b125c23981d070b9a45c7363744856bc9313fd6c3f1f6310f1344ca268defc0677fd6c3bd SHA512 e3277f4b0136dfe5ca48fb52ee85414205433aa5aac5e4db5acbaeb0c8a84591270253cc7b195d107458e8d37d6b5994dab6fdfa941234fd4fb3a451ce5aa839
+DIST icingaweb2-2.11.4.tar.gz 11381515 BLAKE2B e524d04fd027377685826e1e3ff4a73efb040f8736d35fa496cf190a69dc2e6fedd82f678d5994d66a450efaff77764fd6a9504823ba17897506ff3d923566d8 SHA512 3012e75c35f3070a5dfcb356ed499f247651c99b7f39faf1917ade4568f5ba15a2820ff63cab2583748cdb7d158f86b7b87bf8f4c934d3bd6526929dd57e1eae
diff --git a/www-apps/icingaweb2/icingaweb2-2.11.4.ebuild b/www-apps/icingaweb2/icingaweb2-2.11.4.ebuild
new file mode 100644
index 000000000000..98d89648bfc1
--- /dev/null
+++ b/www-apps/icingaweb2/icingaweb2-2.11.4.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit depend.apache multilib
+
+DESCRIPTION="Icinga Web 2 - Frontend for icinga2"
+HOMEPAGE="http://www.icinga.org/"
+
+if [[ ${PV} == *9999 ]];then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Icinga/icingaweb2.git"
+ EGIT_BRANCH="master"
+else
+ SRC_URI="https://codeload.github.com/Icinga/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="apache2 apache2-server fpm ldap mysql nginx pdf postgres"
+REQUIRED_USE="( ^^ ( apache2-server nginx ) ) apache2? ( apache2-server )"
+
+DEPEND=">=net-analyzer/icinga2-2.1.1
+ dev-php/pecl-imagick
+ pdf? ( media-gfx/imagemagick[png] )
+ apache2-server? ( >=www-servers/apache-2.4.0 )
+ nginx? ( >=www-servers/nginx-1.7.0:* )
+ || (
+ dev-lang/php:7.3[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.4[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:8.0[apache2?,cli,fpm?,gd,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:8.1[apache2?,cli,fpm?,gd,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ )
+ >=dev-libs/icinga-php-library-0.8.1
+ >=dev-libs/icinga-php-thirdparty-0.11.0
+ acct-group/icingacmd
+ acct-group/icingaweb2"
+RDEPEND="${DEPEND}"
+
+want_apache2
+
+pkg_setup() {
+ depend.apache_pkg_setup
+
+ use nginx && usermod -a -G icingacmd,icingaweb2 nginx
+ use apache2 && usermod -a -G icingacmd,icingaweb2 apache
+}
+
+pkg_config() {
+ if [[ -d /etc/icingaweb2 ]] ; then
+ einfo "Updating existing installation ..."
+ else
+ einfo "Running first time setup ..."
+ einfo "Creating configuration directory ..."
+ /usr/share/${PN}/bin/icingacli setup config directory
+ einfo "Creating authentication token for web setup ..."
+ /usr/share/${PN}/bin/icingacli setup token create
+ if use apache2 ; then
+ einfo "The following might be useful for your Apache2 configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver apache --document-root /usr/share/${PN}/public
+ fi
+ if use nginx ; then
+ einfo "The following might be useful for your NGinx configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver nginx --document-root /usr/share/${PN}/public
+ fi
+ fi
+ einfo "All done."
+}
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ doins -r "${S}"/*
+ fperms -R a+rX "/usr/share/${PN}/public/"
+ fperms u+x,g+x "/usr/share/${PN}/bin/icingacli"
+ fowners root:icingaweb2 "/usr/share/${PN}/bin/icingacli"
+}
+
+pkg_postinst() {
+ einfo "Run 'emerge --config =${CATEGORY}/${PF}' to finish setup."
+}