summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-11-19 01:51:34 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-11-19 02:19:18 +0100
commit02f5ee88aff5b4ed5ce6f06eb281de702f540e15 (patch)
treed8691caf631101409c9c9702d7437d5cb8410e0b
parentnet-wireless/gr-osmosdr: Keyword 0.2.3_p20210128-r1 riscv, #881733 (diff)
downloadgentoo-02f5ee88aff5b4ed5ce6f06eb281de702f540e15.tar.gz
gentoo-02f5ee88aff5b4ed5ce6f06eb281de702f540e15.tar.bz2
gentoo-02f5ee88aff5b4ed5ce6f06eb281de702f540e15.zip
app-emacs/swift-mode: new package; add 8.6.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/swift-mode/Manifest1
-rw-r--r--app-emacs/swift-mode/files/50swift-mode-gentoo.el4
-rw-r--r--app-emacs/swift-mode/metadata.xml13
-rw-r--r--app-emacs/swift-mode/swift-mode-8.6.0.ebuild27
4 files changed, 45 insertions, 0 deletions
diff --git a/app-emacs/swift-mode/Manifest b/app-emacs/swift-mode/Manifest
new file mode 100644
index 000000000000..85f8c66475d8
--- /dev/null
+++ b/app-emacs/swift-mode/Manifest
@@ -0,0 +1 @@
+DIST swift-mode-8.6.0.tar.gz 226530 BLAKE2B c3e7a8912a0afbd62adc702f3692ecd4fd8f6938ab838f9e576969f50ded6e32040c33595c61974eb6778bb68ad9d4d0dbc3f5fd1a296a0836829ba93a75158f SHA512 5e8f4d2874dee93b47b4d5a191af7158a2b61f632e3838b0c8617020abc44736f51de40426f5e0bcb8a46844beaf6be310ed9e655fc7638eed3bff0aa78eb101
diff --git a/app-emacs/swift-mode/files/50swift-mode-gentoo.el b/app-emacs/swift-mode/files/50swift-mode-gentoo.el
new file mode 100644
index 000000000000..fa55ed725c57
--- /dev/null
+++ b/app-emacs/swift-mode/files/50swift-mode-gentoo.el
@@ -0,0 +1,4 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'swift-mode "swift-mode"
+ "Major mode for editing Swift code." t)
+(add-to-list 'auto-mode-alist '("\\.swift\\'" . swift-mode))
diff --git a/app-emacs/swift-mode/metadata.xml b/app-emacs/swift-mode/metadata.xml
new file mode 100644
index 000000000000..431933b41555
--- /dev/null
+++ b/app-emacs/swift-mode/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/swift-emacs/swift-mode/issues/</bugs-to>
+ <remote-id type="github">swift-emacs/swift-mode</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/swift-mode/swift-mode-8.6.0.ebuild b/app-emacs/swift-mode/swift-mode-8.6.0.ebuild
new file mode 100644
index 000000000000..ff1d4a1bc14c
--- /dev/null
+++ b/app-emacs/swift-mode/swift-mode-8.6.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.4
+
+inherit elisp
+
+DESCRIPTION="Emacs support for Apple's Swift programming language"
+HOMEPAGE="https://github.com/swift-emacs/swift-mode/"
+SRC_URI="https://github.com/swift-emacs/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md CONTRIBUTING.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} \
+ -L . -L test \
+ -l test/swift-mode-test.el \
+ -f swift-mode:run-test || die "tests failed"
+}