summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gmail.com>2021-07-24 19:51:26 +0300
committerMichał Górny <mgorny@gentoo.org>2021-07-29 20:46:54 +0200
commit0467886b731053bc339461912e0c4efe20dccf8f (patch)
tree11feae857167637d05d586874a5399b5702c96ec
parentdev-python/pytest-aiohttp: enable py3.10 and disable py3.7 (diff)
downloadgentoo-0467886b731053bc339461912e0c4efe20dccf8f.tar.gz
gentoo-0467886b731053bc339461912e0c4efe20dccf8f.tar.bz2
gentoo-0467886b731053bc339461912e0c4efe20dccf8f.zip
dev-python/aiohttp: enable py3.10
patch taken from comment here: https://github.com/aio-libs/aiohttp/issues/5905 Signed-off-by: Arthur Zamarin <arthurzam@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/aiohttp/aiohttp-3.7.4-r1.ebuild3
-rw-r--r--dev-python/aiohttp/files/aiohttp-3.7.4-fix-py3.10.patch73
2 files changed, 75 insertions, 1 deletions
diff --git a/dev-python/aiohttp/aiohttp-3.7.4-r1.ebuild b/dev-python/aiohttp/aiohttp-3.7.4-r1.ebuild
index 3871075876e4..4c0cea0a0d1e 100644
--- a/dev-python/aiohttp/aiohttp-3.7.4-r1.ebuild
+++ b/dev-python/aiohttp/aiohttp-3.7.4-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1 multiprocessing
@@ -42,6 +42,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/aiohttp-3.7.4-brotli.patch
+ "${FILESDIR}"/aiohttp-3.7.4-fix-py3.10.patch
)
DOCS=( CHANGES.rst CONTRIBUTORS.txt README.rst )
diff --git a/dev-python/aiohttp/files/aiohttp-3.7.4-fix-py3.10.patch b/dev-python/aiohttp/files/aiohttp-3.7.4-fix-py3.10.patch
new file mode 100644
index 000000000000..3c7593584b76
--- /dev/null
+++ b/dev-python/aiohttp/files/aiohttp-3.7.4-fix-py3.10.patch
@@ -0,0 +1,73 @@
+commit ec87d9f2b6541599dd7fc8aaebf0fdfbb812ade7
+Author: Louis Sautier <sautier.louis@gmail.com>
+Date: Tue Jul 20 23:37:27 2021 +0200
+
+ Remove deprecated loop argument from asyncio.sleep/gather calls
+
+diff --git a/aiohttp/web.py b/aiohttp/web.py
+index 557e3c3b..52dfdf93 100644
+--- a/aiohttp/web.py
++++ b/aiohttp/web.py
+@@ -441,7 +441,7 @@ def _cancel_tasks(
+ task.cancel()
+
+ loop.run_until_complete(
+- asyncio.gather(*to_cancel, loop=loop, return_exceptions=True)
++ asyncio.gather(*to_cancel, return_exceptions=True)
+ )
+
+ for task in to_cancel:
+diff --git a/tests/test_locks.py b/tests/test_locks.py
+index 55fd2330..5f434eac 100644
+--- a/tests/test_locks.py
++++ b/tests/test_locks.py
+@@ -18,7 +18,7 @@ class TestEventResultOrError:
+ return 1
+
+ t = loop.create_task(c())
+- await asyncio.sleep(0, loop=loop)
++ await asyncio.sleep(0)
+ e = Exception()
+ ev.set(exc=e)
+ assert (await t) == e
+@@ -31,7 +31,7 @@ class TestEventResultOrError:
+ return 1
+
+ t = loop.create_task(c())
+- await asyncio.sleep(0, loop=loop)
++ await asyncio.sleep(0)
+ ev.set()
+ assert (await t) == 1
+
+@@ -43,7 +43,7 @@ class TestEventResultOrError:
+
+ t1 = loop.create_task(c())
+ t2 = loop.create_task(c())
+- await asyncio.sleep(0, loop=loop)
++ await asyncio.sleep(0)
+ ev.cancel()
+ ev.set()
+
+diff --git a/tests/test_proxy_functional.py b/tests/test_proxy_functional.py
+index 68763cd4..65c773a1 100644
+--- a/tests/test_proxy_functional.py
++++ b/tests/test_proxy_functional.py
+@@ -238,7 +238,7 @@ async def test_proxy_http_multi_conn_limit(proxy_test_server, loop) -> None:
+ resp = await sess.get(url, proxy=proxy.url)
+
+ current_pid = pid
+- await asyncio.sleep(0.2, loop=loop)
++ await asyncio.sleep(0.2)
+ assert current_pid == pid
+
+ await resp.release()
+@@ -443,7 +443,7 @@ async def xtest_proxy_https_multi_conn_limit(proxy_test_server, loop):
+ resp = await sess.get(url, proxy=proxy.url)
+
+ current_pid = pid
+- await asyncio.sleep(0.2, loop=loop)
++ await asyncio.sleep(0.2)
+ assert current_pid == pid
+
+ await resp.release()
+