summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-03 00:49:46 +0100
committerSam James <sam@gentoo.org>2021-10-03 00:50:12 +0100
commit049927c0dc3152580db69e4c109f55315823bf3d (patch)
treef0785725a81db8eff7560da906ba070ad8c37fbd
parentnet-proxy/haproxy: Stabilize 2.4.4 x86, #812692 (diff)
downloadgentoo-049927c0dc3152580db69e4c109f55315823bf3d.tar.gz
gentoo-049927c0dc3152580db69e4c109f55315823bf3d.tar.bz2
gentoo-049927c0dc3152580db69e4c109f55315823bf3d.zip
dev-util/scons: skip irrelevant tests on non-amd64/x86
Work is ongoing upstream, it seems, too. Closes: https://bugs.gentoo.org/757534 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/scons/scons-4.2.0-r1.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-util/scons/scons-4.2.0-r1.ebuild b/dev-util/scons/scons-4.2.0-r1.ebuild
index e5a5c8637552..c87db3273b7c 100644
--- a/dev-util/scons/scons-4.2.0-r1.ebuild
+++ b/dev-util/scons/scons-4.2.0-r1.ebuild
@@ -73,6 +73,24 @@ src_prepare() {
test/option/option-v.py
test/Interactive/version.py
)
+
+ if ! use amd64 && ! use x86 ; then
+ # These tests are currently broken on arm and other non-amd64/x86 platforms
+ # Work seems to be ongoing in e.g. https://github.com/SCons/scons/pull/4022 to
+ # better plumb up the MSVC tests for alternative arches.
+ # Try again after 4.2.0.
+ # See also: https://pairlist4.pair.net/pipermail/scons-users/2020-November/008452.html
+ # bug #757534
+ remove_tests+=(
+ test/MSVS/vs-7.0-scc-files.py
+ test/MSVS/vs-7.0-scc-legacy-files.py
+ test/MSVS/vs-7.1-scc-files.py
+ test/MSVS/vs-7.1-scc-legacy-files.py
+ test/MSVS/vs-scc-files.py
+ test/MSVS/vs-scc-legacy-files.py
+ )
+ fi
+
rm -r "${remove_tests[@]}" || die
fi
}