summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-17 05:39:50 +0100
committerSam James <sam@gentoo.org>2023-04-17 05:41:25 +0100
commit04e95bd55dcb4d638c5b8814c994904308926598 (patch)
tree0f2164bee6e8870e3431365b1aca97c83c88df14
parentdev-python/jq: Remove old (diff)
downloadgentoo-04e95bd55dcb4d638c5b8814c994904308926598.tar.gz
gentoo-04e95bd55dcb4d638c5b8814c994904308926598.tar.bz2
gentoo-04e95bd55dcb4d638c5b8814c994904308926598.zip
net-misc/netifrc: add 0.7.4
Closes: https://bugs.gentoo.org/904422 Closes: https://bugs.gentoo.org/893290 Closes: https://bugs.gentoo.org/890238 Closes: https://bugs.gentoo.org/889922 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-misc/netifrc/Manifest1
-rw-r--r--net-misc/netifrc/netifrc-0.7.4.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/net-misc/netifrc/Manifest b/net-misc/netifrc/Manifest
index 8fc1d881195e..9fd9fa8dc33b 100644
--- a/net-misc/netifrc/Manifest
+++ b/net-misc/netifrc/Manifest
@@ -1 +1,2 @@
DIST netifrc-0.7.3.tar.gz 84770 BLAKE2B 075440bfd81e4dedd406d9555a18f530b07a47f9268130ebcca6d43d35e9cc5f01105a3eb0ddc084a16e17912aa10e378833b1eef1defd2fc6b22f817cd220bd SHA512 a82ac6835c15763becb5845a8c8d90dfd8d6c289ea5e00b0d7ae332d3e7ad6797f0fdcbf27bb9f44ff345c98884cdfa13210c76089585b8dd9970ded5f6236d8
+DIST netifrc-0.7.4.tar.bz2 75487 BLAKE2B 3ac3114ee4fb538c620284d02d3c1a0adc905f349ab40e7ff7065a4837113a36824b3962511160d997fc3a85701d55d569d8ac6b6b00c4665281d5b765827f76 SHA512 4934e2b7247a65847eed3a0f982c1c3996c486d7cb1cb401c29d8a6ea36eb94930a64e1cb84ff6ffdfb305e75f369fe6834062fcbb5e1d77d9f336d6592f3dff
diff --git a/net-misc/netifrc/netifrc-0.7.4.ebuild b/net-misc/netifrc/netifrc-0.7.4.ebuild
new file mode 100644
index 000000000000..e67405ca29c9
--- /dev/null
+++ b/net-misc/netifrc/netifrc-0.7.4.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd udev
+
+DESCRIPTION="Gentoo Network Interface Management Scripts"
+HOMEPAGE="https://www.gentoo.org/proj/en/base/openrc/"
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/netifrc.git"
+ #EGIT_REPO_URI="https://github.com/gentoo/${PN}" # Alternate
+ inherit git-r3
+else
+ SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="+dhcp"
+
+RDEPEND="sys-apps/gentoo-functions
+ >=sys-apps/openrc-0.15
+ dhcp? ( || ( net-misc/dhcpcd net-misc/dhcp[client] ) )"
+BDEPEND="kernel_linux? ( virtual/pkgconfig )"
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ local ver="git-${EGIT_VERSION:0:6}"
+ sed -i "/^GITVER[[:space:]]*=/s:=.*:=${ver}:" mk/git.mk || die
+ einfo "Producing ChangeLog from Git history"
+ GIT_DIR="${S}/.git" git log >"${S}"/ChangeLog
+ fi
+
+ default
+}
+
+src_compile() {
+ MAKE_ARGS=(
+ PREFIX="${EPREFIX}"
+ UPREFIX="${EPREFIX}/usr"
+ UDEVDIR="${EPREFIX}$(get_udevdir)"
+ LIBEXECDIR="${EPREFIX}/lib/${PN}"
+ PF="${PF}"
+ )
+
+ emake "${MAKE_ARGS[@]}" all
+}
+
+src_install() {
+ emake "${MAKE_ARGS[@]}" DESTDIR="${D}" install
+ dodoc README CREDITS FEATURE-REMOVAL-SCHEDULE STYLE TODO
+
+ # Install the service file
+ local LIBEXECDIR="${EPREFIX}/lib/${PN}"
+ sed "s:@LIBEXECDIR@:${LIBEXECDIR}:" "${S}/systemd/net_at.service.in" > "${T}/net_at.service" || die
+ systemd_newunit "${T}/net_at.service" 'net@.service'
+
+ local UNIT_DIR="$(systemd_get_systemunitdir)"
+ UNIT_DIR="${UNIT_DIR#"${EPREFIX}"}"
+ dosym net@.service "${UNIT_DIR}/net@lo.service"
+}
+
+pkg_postinst() {
+ udev_reload
+ if [[ ! -e "${EROOT}"/etc/conf.d/net && -z ${REPLACING_VERSIONS} ]]; then
+ elog "The network configuration scripts will use dhcp by"
+ elog "default to set up your interfaces."
+ elog "If you need to set up something more complete, see"
+ elog "${EROOT}/usr/share/doc/${P}/README"
+ fi
+}