summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-03-03 10:57:46 +0100
committerMichał Górny <mgorny@gentoo.org>2016-03-03 11:47:37 +0100
commit05bd4dd77c86d117c253b3f323e223ee94120766 (patch)
tree6c18470ee57b475c5359462c5cf8af9b8d0e0c2d
parentdev-python/pypy-bin: Drop old (diff)
downloadgentoo-05bd4dd77c86d117c253b3f323e223ee94120766.tar.gz
gentoo-05bd4dd77c86d117c253b3f323e223ee94120766.tar.bz2
gentoo-05bd4dd77c86d117c253b3f323e223ee94120766.zip
dev-python/pypy: Drop old
-rw-r--r--dev-python/pypy/Manifest2
-rw-r--r--dev-python/pypy/pypy-2.6.0-r1.ebuild252
-rw-r--r--dev-python/pypy/pypy-4.0.0-r1.ebuild252
3 files changed, 0 insertions, 506 deletions
diff --git a/dev-python/pypy/Manifest b/dev-python/pypy/Manifest
index 09e206bf9ca..1571b535962 100644
--- a/dev-python/pypy/Manifest
+++ b/dev-python/pypy/Manifest
@@ -1,4 +1,2 @@
-DIST pypy-2.6.0-src.tar.bz2 16858400 SHA256 9bf353f22d25e97a85a6d3766619966055edea1ea1b2218445d683a8ad0399d9 SHA512 82a6a44c0c551a1291215394610e5331cf83216b38ac9f1a79a3eab53ba2933b121c3154b58cead814c73a1da1fc95d895324bb0c43e8e0429438b0dea527cc4 WHIRLPOOL e536ff5d3b393c6834fd721f383318b5dcef79046f475b0f1fe737c67c56e8769cabc0a35f553da5dc475a255c5711de01bd6d42e541cabbab3b9e30f20c9a5c
-DIST pypy-4.0.0-src.tar.bz2 17244624 SHA256 acff480e44ce92acd057f2e786775af36dc3c2cd12e9efc60a1ac6a562ad7b4d SHA512 2bbdc2536a32b0aa28f7b12ec3d879ed28afe984fad38635bc3e1d950a9fe198cfbaf9b554f0fa245e7fd512ec7a76297f05a1d3e17f73fb49e8506561190f5b WHIRLPOOL e94bdf5e8ea2cbab8e25d37bb7cb36b9bae773ec051d603cfce784e0fd8e591ed16e6896f49d14d9ae094c5f613a0ba871380c8adc2a1cf0023157e3e2a51f52
DIST pypy-4.0.1-src.tar.bz2 17172844 SHA256 29f5aa6ba17b34fd980e85172dfeb4086fdc373ad392b1feff2677d2d8aea23c SHA512 66358cc3fe9ccb402b717379c48731aca8f9f85a1a754a54e3a060113398955b87a3f3048ba731a93be4b49c0f5c7e3bac49dc4523263e1bf4f4b5149d5db5c4 WHIRLPOOL 656a6c60aeb26cb6355db121a92bafcf2b744a7f09dccf21b4a16052c0117d239891ccf6762fcb4fee7f913862263c589becd5984498edc4a8b6d55784957994
DIST python-gentoo-patches-2.7.10-0.tar.xz 12892 SHA256 c9a838bd62ae50cc385da23a837acfd05f2b74e4f086c9c76eb4d3aa5366ef6d SHA512 5f100944635e360691dc0a2b340a906646c4ae9ee558246ddffc56e8b15d389f25f1fbdc1db4cc08e7d29560d04d66b058b3904902899d58ecae8c408ebdf056 WHIRLPOOL f69e9a518bb7ee50c1b262a21e70e1e2443f859ee6d2f4fa84421120dbd054a06ce8dd6cfea8512cbc64bce806322b879c25c561d5eb05e1ba6cc15035b373a9
diff --git a/dev-python/pypy/pypy-2.6.0-r1.ebuild b/dev-python/pypy/pypy-2.6.0-r1.ebuild
deleted file mode 100644
index 720c79d986c..00000000000
--- a/dev-python/pypy/pypy-2.6.0-r1.ebuild
+++ /dev/null
@@ -1,252 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 pypy )
-inherit check-reqs eutils multilib multiprocessing pax-utils python-any-r1 toolchain-funcs versionator
-
-CPY_PATCHSET_VERSION="2.7.10-0"
-
-DESCRIPTION="A fast, compliant alternative implementation of the Python language"
-HOMEPAGE="http://pypy.org/"
-SRC_URI="https://bitbucket.org/pypy/pypy/downloads/${P}-src.tar.bz2
- https://dev.gentoo.org/~floppym/python/python-gentoo-patches-${CPY_PATCHSET_VERSION}.tar.xz"
-
-LICENSE="MIT"
-SLOT="0/$(get_version_component_range 1-2 ${PV})"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="bzip2 doc gdbm +jit low-memory ncurses sandbox +shadowstack sqlite cpu_flags_x86_sse2 test tk"
-
-RDEPEND=">=sys-libs/zlib-1.1.3:0=
- virtual/libffi:0=
- virtual/libintl:0=
- dev-libs/expat:0=
- dev-libs/openssl:0=[-bindist]
- bzip2? ( app-arch/bzip2:0= )
- gdbm? ( sys-libs/gdbm:0= )
- ncurses? ( sys-libs/ncurses:0= )
- sqlite? ( dev-db/sqlite:3= )
- tk? (
- dev-lang/tk:0=
- dev-tcltk/tix:0=
- )
- !dev-python/pypy-bin:0"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )
- ${PYTHON_DEPS}
- test? ( dev-python/pytest )"
-PDEPEND="app-admin/python-updater"
-
-S="${WORKDIR}/${P}-src"
-
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- if use low-memory; then
- if ! python_is_installed pypy; then
- eerror "USE=low-memory requires a (possibly old) version of dev-python/pypy"
- eerror "or dev-python/pypy-bin being installed. Please install it using e.g.:"
- eerror
- eerror " $ emerge -1v dev-python/pypy-bin"
- eerror
- eerror "before attempting to build dev-python/pypy[low-memory]."
- die "dev-python/pypy-bin (or dev-python/pypy) needs to be installed for USE=low-memory"
- fi
-
- CHECKREQS_MEMORY="1750M"
- use amd64 && CHECKREQS_MEMORY="3500M"
- else
- CHECKREQS_MEMORY="3G"
- use amd64 && CHECKREQS_MEMORY="6G"
- fi
-
- check-reqs_pkg_pretend
- fi
-}
-
-pkg_setup() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- pkg_pretend
-
- if python_is_installed pypy; then
- if [[ ! ${EPYTHON} || ${EPYTHON} == pypy ]] || use low-memory; then
- einfo "Using already-installed PyPy to perform the translation."
- local EPYTHON=pypy
- else
- einfo "Using ${EPYTHON} to perform the translation. Please note that upstream"
- einfo "recommends using PyPy for that. If you wish to do so, please unset"
- einfo "the EPYTHON variable."
- fi
- fi
-
- python-any-r1_pkg_setup
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}/4.0.0-gentoo-path.patch" \
- "${FILESDIR}/1.9-distutils.unixccompiler.UnixCCompiler.runtime_library_dir_option.patch" \
- "${FILESDIR}"/2.5.0-shared-lib.patch # 517002
-
- sed -e "s^@EPREFIX@^${EPREFIX}^" \
- -e "s^@libdir@^$(get_libdir)^" \
- -i lib-python/2.7/distutils/command/install.py || die
-
- # apply CPython stdlib patches
- pushd lib-python/2.7 > /dev/null || die
- epatch "${FILESDIR}"/2.5.0_all_distutils_cxx.patch \
- "${WORKDIR}"/patches/22_all_turkish_locale.patch \
- "${WORKDIR}"/patches/62_all_xml.use_pyxml.patch
- popd > /dev/null || die
-
- epatch_user
-}
-
-src_compile() {
- tc-export CC
-
- local jit_backend
- if use jit; then
- jit_backend='--jit-backend='
-
- # We only need the explicit sse2 switch for x86.
- # On other arches we can rely on autodetection which uses
- # compiler macros. Plus, --jit-backend= doesn't accept all
- # the modern values...
-
- if use x86; then
- if use cpu_flags_x86_sse2; then
- jit_backend+=x86
- else
- jit_backend+=x86-without-sse2
- fi
- else
- jit_backend+=auto
- fi
- fi
-
- local args=(
- --shared
- $(usex jit -Ojit -O2)
- $(usex shadowstack --gcrootfinder=shadowstack '')
- $(usex sandbox --sandbox '')
-
- ${jit_backend}
- --make-jobs=$(makeopts_jobs)
-
- pypy/goal/targetpypystandalone
- )
-
- # Avoid linking against libraries disabled by use flags
- local opts=(
- bzip2:bz2
- ncurses:_minimal_curses
- )
-
- local opt
- for opt in "${opts[@]}"; do
- local flag=${opt%:*}
- local mod=${opt#*:}
-
- args+=(
- $(usex ${flag} --withmod --withoutmod)-${mod}
- )
- done
-
- local interp=( "${PYTHON}" )
- if use low-memory; then
- interp=( env PYPY_GC_MAX_DELTA=200MB
- "${PYTHON}" --jit loop_longevity=300 )
- fi
-
- set -- "${interp[@]}" rpython/bin/rpython --batch "${args[@]}"
- echo -e "\033[1m${@}\033[0m"
- "${@}" || die "compile error"
-
- use doc && emake -C pypy/doc/ html
- pax-mark m "${ED%/}${INSDESTTREE}/pypy-c"
-}
-
-src_test() {
- # (unset)
- local -x PYTHONDONTWRITEBYTECODE
-
- ./pypy-c ./pypy/test_all.py --pypy=./pypy-c lib-python || die
-}
-
-src_install() {
- einfo "Installing PyPy ..."
- insinto "/usr/$(get_libdir)/pypy"
- doins -r include lib_pypy lib-python pypy-c libpypy-c.so
- fperms a+x ${INSDESTTREE}/pypy-c ${INSDESTTREE}/libpypy-c.so
- pax-mark m "${ED%/}${INSDESTTREE}/pypy-c" "${ED%/}${INSDESTTREE}/libpypy-c.so"
- dosym ../$(get_libdir)/pypy/pypy-c /usr/bin/pypy
- dodoc README.rst
-
- if ! use gdbm; then
- rm -r "${ED%/}${INSDESTTREE}"/lib_pypy/gdbm.py \
- "${ED%/}${INSDESTTREE}"/lib-python/*2.7/test/test_gdbm.py || die
- fi
- if ! use sqlite; then
- rm -r "${ED%/}${INSDESTTREE}"/lib-python/*2.7/sqlite3 \
- "${ED%/}${INSDESTTREE}"/lib_pypy/_sqlite3.py \
- "${ED%/}${INSDESTTREE}"/lib-python/*2.7/test/test_sqlite.py || die
- fi
- if ! use tk; then
- rm -r "${ED%/}${INSDESTTREE}"/lib-python/*2.7/{idlelib,lib-tk} \
- "${ED%/}${INSDESTTREE}"/lib_pypy/_tkinter \
- "${ED%/}${INSDESTTREE}"/lib-python/*2.7/test/test_{tcl,tk,ttk*}.py || die
- fi
-
- # Install docs
- use doc && dohtml -r pypy/doc/_build/html/
-
- einfo "Generating caches and byte-compiling ..."
-
- local -x PYTHON=${ED%/}${INSDESTTREE}/pypy-c
- local -x LD_LIBRARY_PATH="${ED%/}${INSDESTTREE}"
- # we can't use eclass function since PyPy is dumb and always gives
- # paths relative to the interpreter
- local PYTHON_SITEDIR=${EPREFIX}/usr/$(get_libdir)/pypy/site-packages
- python_export pypy EPYTHON
-
- echo "EPYTHON='${EPYTHON}'" > epython.py || die
- python_domodule epython.py
-
- # Generate Grammar and PatternGrammar pickles.
- "${PYTHON}" -c "import lib2to3.pygram, lib2to3.patcomp; lib2to3.patcomp.PatternCompiler()" \
- || die "Generation of Grammar and PatternGrammar pickles failed"
-
- # Generate cffi modules
- # Please keep in sync with pypy/tool/release/package.py!
-#cffi_build_scripts = {
-# "sqlite3": "_sqlite3_build.py",
-# "audioop": "_audioop_build.py",
-# "tk": "_tkinter/tklib_build.py",
-# "curses": "_curses_build.py" if sys.platform != "win32" else None,
-# "syslog": "_syslog_build.py" if sys.platform != "win32" else None,
-# "gdbm": "_gdbm_build.py" if sys.platform != "win32" else None,
-# "pwdgrp": "_pwdgrp_build.py" if sys.platform != "win32" else None,
- cffi_targets=( audioop syslog pwdgrp )
- use gdbm && cffi_targets+=( gdbm )
- use ncurses && cffi_targets+=( curses )
- use sqlite && cffi_targets+=( sqlite3 )
- use tk && cffi_targets+=( tkinter/tklib )
-
- local t
- # all modules except tkinter output to .
- # tkinter outputs to the correct dir ...
- cd "${ED%/}${INSDESTTREE}"/lib_pypy || die
- for t in "${cffi_targets[@]}"; do
- # tkinter doesn't work via -m
- "${PYTHON}" "_${t}_build.py" || die "Failed to build CFFI bindings for ${t}"
- done
-
- # Cleanup temporary objects
- find "${ED%/}${INSDESTTREE}" -name "_cffi_*.[co]" -delete || die
- find "${ED%/}${INSDESTTREE}" -type d -empty -delete || die
-
- # compile the installed modules
- python_optimize "${ED%/}${INSDESTTREE}"
-}
diff --git a/dev-python/pypy/pypy-4.0.0-r1.ebuild b/dev-python/pypy/pypy-4.0.0-r1.ebuild
deleted file mode 100644
index 9a64dcbae0d..00000000000
--- a/dev-python/pypy/pypy-4.0.0-r1.ebuild
+++ /dev/null
@@ -1,252 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 pypy )
-inherit check-reqs eutils multilib multiprocessing pax-utils python-any-r1 toolchain-funcs versionator
-
-CPY_PATCHSET_VERSION="2.7.10-0"
-
-DESCRIPTION="A fast, compliant alternative implementation of the Python language"
-HOMEPAGE="http://pypy.org/"
-SRC_URI="https://bitbucket.org/pypy/pypy/downloads/${P}-src.tar.bz2
- https://dev.gentoo.org/~floppym/python/python-gentoo-patches-${CPY_PATCHSET_VERSION}.tar.xz"
-
-LICENSE="MIT"
-SLOT="0/$(get_version_component_range 1-2 ${PV})"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="bzip2 doc gdbm +jit low-memory ncurses sandbox +shadowstack sqlite cpu_flags_x86_sse2 test tk"
-
-RDEPEND=">=sys-libs/zlib-1.1.3:0=
- virtual/libffi:0=
- virtual/libintl:0=
- dev-libs/expat:0=
- dev-libs/openssl:0=[-bindist]
- bzip2? ( app-arch/bzip2:0= )
- gdbm? ( sys-libs/gdbm:0= )
- ncurses? ( sys-libs/ncurses:0= )
- sqlite? ( dev-db/sqlite:3= )
- tk? (
- dev-lang/tk:0=
- dev-tcltk/tix:0=
- )
- !dev-python/pypy-bin:0"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )
- ${PYTHON_DEPS}
- test? ( dev-python/pytest )"
-PDEPEND="app-admin/python-updater"
-
-S="${WORKDIR}/${P}-src"
-
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- if use low-memory; then
- if ! python_is_installed pypy; then
- eerror "USE=low-memory requires a (possibly old) version of dev-python/pypy"
- eerror "or dev-python/pypy-bin being installed. Please install it using e.g.:"
- eerror
- eerror " $ emerge -1v dev-python/pypy-bin"
- eerror
- eerror "before attempting to build dev-python/pypy[low-memory]."
- die "dev-python/pypy-bin (or dev-python/pypy) needs to be installed for USE=low-memory"
- fi
-
- CHECKREQS_MEMORY="1750M"
- use amd64 && CHECKREQS_MEMORY="3500M"
- else
- CHECKREQS_MEMORY="3G"
- use amd64 && CHECKREQS_MEMORY="6G"
- fi
-
- check-reqs_pkg_pretend
- fi
-}
-
-pkg_setup() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- pkg_pretend
-
- if python_is_installed pypy; then
- if [[ ! ${EPYTHON} || ${EPYTHON} == pypy ]] || use low-memory; then
- einfo "Using already-installed PyPy to perform the translation."
- local EPYTHON=pypy
- else
- einfo "Using ${EPYTHON} to perform the translation. Please note that upstream"
- einfo "recommends using PyPy for that. If you wish to do so, please unset"
- einfo "the EPYTHON variable."
- fi
- fi
-
- python-any-r1_pkg_setup
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}/4.0.0-gentoo-path.patch" \
- "${FILESDIR}/1.9-distutils.unixccompiler.UnixCCompiler.runtime_library_dir_option.patch" \
- "${FILESDIR}"/2.5.0-shared-lib.patch # 517002
-
- sed -e "s^@EPREFIX@^${EPREFIX}^" \
- -e "s^@libdir@^$(get_libdir)^" \
- -i lib-python/2.7/distutils/command/install.py || die
-
- # apply CPython stdlib patches
- pushd lib-python/2.7 > /dev/null || die
- epatch "${FILESDIR}"/2.5.0_all_distutils_cxx.patch \
- "${WORKDIR}"/patches/22_all_turkish_locale.patch \
- "${WORKDIR}"/patches/62_all_xml.use_pyxml.patch
- popd > /dev/null || die
-
- epatch_user
-}
-
-src_compile() {
- tc-export CC
-
- local jit_backend
- if use jit; then
- jit_backend='--jit-backend='
-
- # We only need the explicit sse2 switch for x86.
- # On other arches we can rely on autodetection which uses
- # compiler macros. Plus, --jit-backend= doesn't accept all
- # the modern values...
-
- if use x86; then
- if use cpu_flags_x86_sse2; then
- jit_backend+=x86
- else
- jit_backend+=x86-without-sse2
- fi
- else
- jit_backend+=auto
- fi
- fi
-
- local args=(
- --shared
- $(usex jit -Ojit -O2)
- $(usex shadowstack --gcrootfinder=shadowstack '')
- $(usex sandbox --sandbox '')
-
- ${jit_backend}
- --make-jobs=$(makeopts_jobs)
-
- pypy/goal/targetpypystandalone
- )
-
- # Avoid linking against libraries disabled by use flags
- local opts=(
- bzip2:bz2
- ncurses:_minimal_curses
- )
-
- local opt
- for opt in "${opts[@]}"; do
- local flag=${opt%:*}
- local mod=${opt#*:}
-
- args+=(
- $(usex ${flag} --withmod --withoutmod)-${mod}
- )
- done
-
- local interp=( "${PYTHON}" )
- if use low-memory; then
- interp=( env PYPY_GC_MAX_DELTA=200MB
- "${PYTHON}" --jit loop_longevity=300 )
- fi
-
- set -- "${interp[@]}" rpython/bin/rpython --batch "${args[@]}"
- echo -e "\033[1m${@}\033[0m"
- "${@}" || die "compile error"
-
- use doc && emake -C pypy/doc/ html
- pax-mark m "${ED%/}${INSDESTTREE}/pypy-c"
-}
-
-src_test() {
- # (unset)
- local -x PYTHONDONTWRITEBYTECODE
-
- ./pypy-c ./pypy/test_all.py --pypy=./pypy-c lib-python || die
-}
-
-src_install() {
- einfo "Installing PyPy ..."
- insinto "/usr/$(get_libdir)/pypy"
- doins -r include lib_pypy lib-python pypy-c libpypy-c.so
- fperms a+x ${INSDESTTREE}/pypy-c ${INSDESTTREE}/libpypy-c.so
- pax-mark m "${ED%/}${INSDESTTREE}/pypy-c" "${ED%/}${INSDESTTREE}/libpypy-c.so"
- dosym ../$(get_libdir)/pypy/pypy-c /usr/bin/pypy
- dodoc README.rst
-
- if ! use gdbm; then
- rm -r "${ED%/}${INSDESTTREE}"/lib_pypy/gdbm.py \
- "${ED%/}${INSDESTTREE}"/lib-python/*2.7/test/test_gdbm.py || die
- fi
- if ! use sqlite; then
- rm -r "${ED%/}${INSDESTTREE}"/lib-python/*2.7/sqlite3 \
- "${ED%/}${INSDESTTREE}"/lib_pypy/_sqlite3.py \
- "${ED%/}${INSDESTTREE}"/lib-python/*2.7/test/test_sqlite.py || die
- fi
- if ! use tk; then
- rm -r "${ED%/}${INSDESTTREE}"/lib-python/*2.7/{idlelib,lib-tk} \
- "${ED%/}${INSDESTTREE}"/lib_pypy/_tkinter \
- "${ED%/}${INSDESTTREE}"/lib-python/*2.7/test/test_{tcl,tk,ttk*}.py || die
- fi
-
- # Install docs
- use doc && dohtml -r pypy/doc/_build/html/
-
- einfo "Generating caches and byte-compiling ..."
-
- local -x PYTHON=${ED%/}${INSDESTTREE}/pypy-c
- local -x LD_LIBRARY_PATH="${ED%/}${INSDESTTREE}"
- # we can't use eclass function since PyPy is dumb and always gives
- # paths relative to the interpreter
- local PYTHON_SITEDIR=${EPREFIX}/usr/$(get_libdir)/pypy/site-packages
- python_export pypy EPYTHON
-
- echo "EPYTHON='${EPYTHON}'" > epython.py || die
- python_domodule epython.py
-
- # Generate Grammar and PatternGrammar pickles.
- "${PYTHON}" -c "import lib2to3.pygram, lib2to3.patcomp; lib2to3.patcomp.PatternCompiler()" \
- || die "Generation of Grammar and PatternGrammar pickles failed"
-
- # Generate cffi modules
- # Please keep in sync with pypy/tool/build_cffi_imports.py!
-#cffi_build_scripts = {
-# "sqlite3": "_sqlite3_build.py",
-# "audioop": "_audioop_build.py",
-# "tk": "_tkinter/tklib_build.py",
-# "curses": "_curses_build.py" if sys.platform != "win32" else None,
-# "syslog": "_syslog_build.py" if sys.platform != "win32" else None,
-# "gdbm": "_gdbm_build.py" if sys.platform != "win32" else None,
-# "pwdgrp": "_pwdgrp_build.py" if sys.platform != "win32" else None,
- cffi_targets=( audioop syslog pwdgrp )
- use gdbm && cffi_targets+=( gdbm )
- use ncurses && cffi_targets+=( curses )
- use sqlite && cffi_targets+=( sqlite3 )
- use tk && cffi_targets+=( tkinter/tklib )
-
- local t
- # all modules except tkinter output to .
- # tkinter outputs to the correct dir ...
- cd "${ED%/}${INSDESTTREE}"/lib_pypy || die
- for t in "${cffi_targets[@]}"; do
- # tkinter doesn't work via -m
- "${PYTHON}" "_${t}_build.py" || die "Failed to build CFFI bindings for ${t}"
- done
-
- # Cleanup temporary objects
- find "${ED%/}${INSDESTTREE}" -name "_cffi_*.[co]" -delete || die
- find "${ED%/}${INSDESTTREE}" -type d -empty -delete || die
-
- # compile the installed modules
- python_optimize "${ED%/}${INSDESTTREE}"
-}