summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-07-20 10:45:35 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2020-07-20 10:45:35 +0200
commit05c4d8c2c1e0ecb46c767d177642fede37eefde1 (patch)
treecd82287bf02df9ee2309a5d959dcfbf380e3340f
parentwww-servers/tomcat: removed obsolete and vulnerable (diff)
downloadgentoo-05c4d8c2c1e0ecb46c767d177642fede37eefde1.tar.gz
gentoo-05c4d8c2c1e0ecb46c767d177642fede37eefde1.tar.bz2
gentoo-05c4d8c2c1e0ecb46c767d177642fede37eefde1.zip
www-servers/tomcat: fixed building of javadoc for 8.5.57 and 9.0.37
Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
-rw-r--r--www-servers/tomcat/files/tomcat-8.5.57-build.xml.patch48
-rw-r--r--www-servers/tomcat/files/tomcat-9.0.37-build.xml.patch50
-rw-r--r--www-servers/tomcat/tomcat-8.5.57.ebuild7
3 files changed, 61 insertions, 44 deletions
diff --git a/www-servers/tomcat/files/tomcat-8.5.57-build.xml.patch b/www-servers/tomcat/files/tomcat-8.5.57-build.xml.patch
index 2eb3329b3ce6..c01699945e0c 100644
--- a/www-servers/tomcat/files/tomcat-8.5.57-build.xml.patch
+++ b/www-servers/tomcat/files/tomcat-8.5.57-build.xml.patch
@@ -1,5 +1,5 @@
diff --git a/build.xml b/build.xml
-index 348487c..04e40fa 100644
+index 348487c..d0b8b81 100644
--- a/build.xml
+++ b/build.xml
@@ -762,25 +762,28 @@
@@ -106,14 +106,14 @@ index 348487c..04e40fa 100644
<antcall target="downloadfile">
<param name="sourcefile" value="${jaxrpc-lib.loc}"/>
-@@ -1874,6 +1879,7 @@ Apache Tomcat ${version} native binaries for Win64 AMD64/EMT64 platform.
-
- <target name="javadoc" depends="dist-source,extras-webservices-prepare"
- description="Create the Tomcat javadoc" >
+@@ -1895,6 +1900,7 @@ Apache Tomcat ${version} native binaries for Win64 AMD64/EMT64 platform.
+ <path location="${ant.core.lib}"/>
+ </classpath>
+ </javadoc>
+<!--
- <javadoc packagenames="javax.annotation.*"
+ <javadoc packagenames="javax.servlet.*"
+ excludepackagenames="javax.servlet.jsp.*"
sourcepath="${tomcat.dist}/src/java"
- destdir="${tomcat.dist}/webapps/docs/annotationapi"
@@ -1962,6 +1968,7 @@ Apache Tomcat ${version} native binaries for Win64 AMD64/EMT64 platform.
<path location="${ant.core.lib}"/>
</classpath>
@@ -122,7 +122,7 @@ index 348487c..04e40fa 100644
<javadoc packagenames="javax.websocket.*"
sourcepath="${tomcat.dist}/src/java"
destdir="${tomcat.dist}/webapps/docs/websocketapi"
-@@ -2025,9 +2032,11 @@ Apache Tomcat ${version} native binaries for Win64 AMD64/EMT64 platform.
+@@ -2025,13 +2032,17 @@ Apache Tomcat ${version} native binaries for Win64 AMD64/EMT64 platform.
<path location="${ant.core.lib}"/>
</classpath>
<link href="../annotationapi"/>
@@ -133,8 +133,14 @@ index 348487c..04e40fa 100644
+-->
<link href="../websocketapi"/>
<link href="../jaspicapi"/>
++<!--
<link href="https://docs.oracle.com/javase/7/docs/api/"/>
-@@ -2759,7 +2768,7 @@ skip.installer property in build.properties" />
+ <link href="https://docs.oracle.com/javaee/7/api/"/>
++-->
+ <packageset dir="${tomcat.dist}/src/java/">
+ <include name="org/**"/>
+ <exclude name="org/apache/el/parser/**"/>
+@@ -2759,7 +2770,7 @@ skip.installer property in build.properties" />
</target>
<target name="download-compile"
@@ -143,7 +149,7 @@ index 348487c..04e40fa 100644
<!-- Download Commons Daemon -->
<antcall target="downloadgz-2">
-@@ -2795,7 +2804,7 @@ skip.installer property in build.properties" />
+@@ -2795,7 +2806,7 @@ skip.installer property in build.properties" />
</target>
<target name="download-test-compile"
@@ -152,7 +158,7 @@ index 348487c..04e40fa 100644
<antcall target="downloadfile">
<param name="sourcefile" value="${junit.loc}"/>
-@@ -2873,7 +2882,7 @@ skip.installer property in build.properties" />
+@@ -2873,7 +2884,7 @@ skip.installer property in build.properties" />
</target>
<target name="download-dist"
@@ -161,7 +167,7 @@ index 348487c..04e40fa 100644
<antcall target="downloadfile-2">
<param name="sourcefile.1" value="${tomcat-native.loc.1}"/>
-@@ -2928,13 +2937,13 @@ skip.installer property in build.properties" />
+@@ -2928,13 +2939,13 @@ skip.installer property in build.properties" />
<!-- =============== Utility Targets to support downloads ================ -->
@@ -177,7 +183,7 @@ index 348487c..04e40fa 100644
<echo message="Testing for ${destfile}"/>
<available file="${destfile}" property="exist"/>
</target>
-@@ -3056,7 +3065,7 @@ skip.installer property in build.properties" />
+@@ -3056,7 +3067,7 @@ skip.installer property in build.properties" />
</sequential>
</macrodef>
@@ -186,7 +192,7 @@ index 348487c..04e40fa 100644
<!-- Download and extract the package -->
<local name="temp.file"/>
<mkdir dir="${base.path}"/>
-@@ -3073,7 +3082,7 @@ skip.installer property in build.properties" />
+@@ -3073,7 +3084,7 @@ skip.installer property in build.properties" />
<delete file="${temp.file}.tar.gz"/>
</target>
@@ -195,7 +201,7 @@ index 348487c..04e40fa 100644
<!-- Download and extract the package from the two alternative locations -->
<local name="temp.file"/>
<mkdir dir="${base.path}"/>
-@@ -3098,7 +3107,7 @@ skip.installer property in build.properties" />
+@@ -3098,7 +3109,7 @@ skip.installer property in build.properties" />
<delete file="${temp.file}.tar.gz"/>
</target>
@@ -204,7 +210,7 @@ index 348487c..04e40fa 100644
<!-- Download and extract the package -->
<local name="temp.file"/>
<mkdir dir="${base.path}"/>
-@@ -3114,7 +3123,7 @@ skip.installer property in build.properties" />
+@@ -3114,7 +3125,7 @@ skip.installer property in build.properties" />
<delete file="${temp.file}"/>
</target>
@@ -213,7 +219,7 @@ index 348487c..04e40fa 100644
<!-- Download and extract the package from the two alternative locations -->
<local name="temp.file"/>
<mkdir dir="${base.path}"/>
-@@ -3138,7 +3147,7 @@ skip.installer property in build.properties" />
+@@ -3138,7 +3149,7 @@ skip.installer property in build.properties" />
<delete file="${temp.file}"/>
</target>
@@ -222,7 +228,7 @@ index 348487c..04e40fa 100644
<!-- Download the file -->
<local name="temp.file"/>
<mkdir dir="${base.path}"/>
-@@ -3153,7 +3162,7 @@ skip.installer property in build.properties" />
+@@ -3153,7 +3164,7 @@ skip.installer property in build.properties" />
<move file="${temp.file}" tofile="${destfile}"/>
</target>
@@ -231,7 +237,7 @@ index 348487c..04e40fa 100644
<!-- Download the file from the two alternative locations -->
<local name="temp.file"/>
<mkdir dir="${base.path}"/>
-@@ -3181,7 +3190,7 @@ skip.installer property in build.properties" />
+@@ -3181,7 +3192,7 @@ skip.installer property in build.properties" />
<move file="${temp.file}" tofile="${destfile}"/>
</target>
@@ -240,7 +246,7 @@ index 348487c..04e40fa 100644
<condition property="trydownload.run">
<and>
<not>
-@@ -3192,7 +3201,7 @@ skip.installer property in build.properties" />
+@@ -3192,7 +3203,7 @@ skip.installer property in build.properties" />
</condition>
</target>
@@ -249,7 +255,7 @@ index 348487c..04e40fa 100644
<!-- Downloads a file if not yet downloaded and the source URL is available -->
<get src="${sourcefile}" httpusecaches="${trydownload.httpusecaches}" dest="${destfile}" />
</target>
-@@ -3203,7 +3212,7 @@ skip.installer property in build.properties" />
+@@ -3203,7 +3214,7 @@ skip.installer property in build.properties" />
<target name="ide-eclipse"
depends="download-compile, extras-webservices-prepare, download-test-compile"
diff --git a/www-servers/tomcat/files/tomcat-9.0.37-build.xml.patch b/www-servers/tomcat/files/tomcat-9.0.37-build.xml.patch
index 92540986e9c8..ea902b4b922f 100644
--- a/www-servers/tomcat/files/tomcat-9.0.37-build.xml.patch
+++ b/www-servers/tomcat/files/tomcat-9.0.37-build.xml.patch
@@ -1,5 +1,5 @@
diff --git a/build.xml b/build.xml
-index 8e02cb5..e07b2d7 100644
+index 8e02cb5..9007e8b 100644
--- a/build.xml
+++ b/build.xml
@@ -760,6 +760,7 @@
@@ -115,14 +115,14 @@ index 8e02cb5..e07b2d7 100644
<!-- platform README files -->
<echo append="false" file="${tomcat.dist}/bin/x64/README">
Apache Tomcat ${version} native binaries for Win64 AMD64/EMT64 platform.
-@@ -1877,6 +1883,7 @@ Apache Tomcat ${version} native binaries for Win64 AMD64/EMT64 platform.
-
- <target name="javadoc" depends="dist-source"
- description="Create the Tomcat javadoc" >
+@@ -1898,6 +1904,7 @@ Apache Tomcat ${version} native binaries for Win64 AMD64/EMT64 platform.
+ <path location="${ant.core.lib}"/>
+ </classpath>
+ </javadoc>
+<!--
- <javadoc packagenames="javax.annotation.*"
+ <javadoc packagenames="javax.servlet.*"
+ excludepackagenames="javax.servlet.jsp.*"
sourcepath="${tomcat.dist}/src/java"
- destdir="${tomcat.dist}/webapps/docs/annotationapi"
@@ -1962,6 +1969,7 @@ Apache Tomcat ${version} native binaries for Win64 AMD64/EMT64 platform.
<path location="${ant.core.lib}"/>
</classpath>
@@ -131,7 +131,7 @@ index 8e02cb5..e07b2d7 100644
<javadoc packagenames="javax.websocket.*"
sourcepath="${tomcat.dist}/src/java"
destdir="${tomcat.dist}/webapps/docs/websocketapi"
-@@ -2023,9 +2031,11 @@ Apache Tomcat ${version} native binaries for Win64 AMD64/EMT64 platform.
+@@ -2023,13 +2031,17 @@ Apache Tomcat ${version} native binaries for Win64 AMD64/EMT64 platform.
<path location="${ant.core.lib}"/>
</classpath>
<link href="../annotationapi"/>
@@ -142,8 +142,14 @@ index 8e02cb5..e07b2d7 100644
+-->
<link href="../websocketapi"/>
<link href="../jaspicapi"/>
++<!--
<link href="https://docs.oracle.com/javase/8/docs/api/"/>
-@@ -2756,7 +2766,7 @@ skip.installer property in build.properties" />
+ <link href="https://javaee.github.io/javaee-spec/javadocs/"/>
++-->
+ <packageset dir="${tomcat.dist}/src/java/">
+ <include name="org/**"/>
+ <exclude name="org/apache/el/parser/**"/>
+@@ -2756,7 +2768,7 @@ skip.installer property in build.properties" />
</target>
<target name="download-compile"
@@ -152,7 +158,7 @@ index 8e02cb5..e07b2d7 100644
<!-- Download Commons Daemon -->
<antcall target="downloadgz-2">
-@@ -2811,7 +2821,7 @@ skip.installer property in build.properties" />
+@@ -2811,7 +2823,7 @@ skip.installer property in build.properties" />
</target>
<target name="download-test-compile"
@@ -161,7 +167,7 @@ index 8e02cb5..e07b2d7 100644
<antcall target="downloadfile">
<param name="sourcefile" value="${junit.loc}"/>
-@@ -2889,7 +2899,7 @@ skip.installer property in build.properties" />
+@@ -2889,7 +2901,7 @@ skip.installer property in build.properties" />
</target>
<target name="download-dist"
@@ -170,7 +176,7 @@ index 8e02cb5..e07b2d7 100644
<antcall target="downloadfile-2">
<param name="sourcefile.1" value="${tomcat-native.loc.1}"/>
-@@ -2944,13 +2954,13 @@ skip.installer property in build.properties" />
+@@ -2944,13 +2956,13 @@ skip.installer property in build.properties" />
<!-- =============== Utility Targets to support downloads ================ -->
@@ -186,7 +192,7 @@ index 8e02cb5..e07b2d7 100644
<echo message="Testing for ${destfile}"/>
<available file="${destfile}" property="exist"/>
</target>
-@@ -3072,7 +3082,7 @@ skip.installer property in build.properties" />
+@@ -3072,7 +3084,7 @@ skip.installer property in build.properties" />
</sequential>
</macrodef>
@@ -195,7 +201,7 @@ index 8e02cb5..e07b2d7 100644
<!-- Download and extract the package -->
<local name="temp.file"/>
<mkdir dir="${base.path}"/>
-@@ -3089,7 +3099,7 @@ skip.installer property in build.properties" />
+@@ -3089,7 +3101,7 @@ skip.installer property in build.properties" />
<delete file="${temp.file}.tar.gz"/>
</target>
@@ -204,7 +210,7 @@ index 8e02cb5..e07b2d7 100644
<!-- Download and extract the package from the two alternative locations -->
<local name="temp.file"/>
<mkdir dir="${base.path}"/>
-@@ -3114,7 +3124,7 @@ skip.installer property in build.properties" />
+@@ -3114,7 +3126,7 @@ skip.installer property in build.properties" />
<delete file="${temp.file}.tar.gz"/>
</target>
@@ -213,7 +219,7 @@ index 8e02cb5..e07b2d7 100644
<!-- Download and extract the package -->
<local name="temp.file"/>
<mkdir dir="${base.path}"/>
-@@ -3130,7 +3140,7 @@ skip.installer property in build.properties" />
+@@ -3130,7 +3142,7 @@ skip.installer property in build.properties" />
<delete file="${temp.file}"/>
</target>
@@ -222,7 +228,7 @@ index 8e02cb5..e07b2d7 100644
<!-- Download and extract the package from the two alternative locations -->
<local name="temp.file"/>
<mkdir dir="${base.path}"/>
-@@ -3154,7 +3164,7 @@ skip.installer property in build.properties" />
+@@ -3154,7 +3166,7 @@ skip.installer property in build.properties" />
<delete file="${temp.file}"/>
</target>
@@ -231,7 +237,7 @@ index 8e02cb5..e07b2d7 100644
<!-- Download the file -->
<local name="temp.file"/>
<mkdir dir="${base.path}"/>
-@@ -3169,7 +3179,7 @@ skip.installer property in build.properties" />
+@@ -3169,7 +3181,7 @@ skip.installer property in build.properties" />
<move file="${temp.file}" tofile="${destfile}"/>
</target>
@@ -240,7 +246,7 @@ index 8e02cb5..e07b2d7 100644
<!-- Download the file from the two alternative locations -->
<local name="temp.file"/>
<mkdir dir="${base.path}"/>
-@@ -3197,7 +3207,7 @@ skip.installer property in build.properties" />
+@@ -3197,7 +3209,7 @@ skip.installer property in build.properties" />
<move file="${temp.file}" tofile="${destfile}"/>
</target>
@@ -249,7 +255,7 @@ index 8e02cb5..e07b2d7 100644
<condition property="trydownload.run">
<and>
<not>
-@@ -3208,7 +3218,7 @@ skip.installer property in build.properties" />
+@@ -3208,7 +3220,7 @@ skip.installer property in build.properties" />
</condition>
</target>
@@ -258,7 +264,7 @@ index 8e02cb5..e07b2d7 100644
<!-- Downloads a file if not yet downloaded and the source URL is available -->
<get src="${sourcefile}" httpusecaches="${trydownload.httpusecaches}" dest="${destfile}" />
</target>
-@@ -3219,7 +3229,7 @@ skip.installer property in build.properties" />
+@@ -3219,7 +3231,7 @@ skip.installer property in build.properties" />
<target name="ide-eclipse"
depends="download-compile, download-test-compile"
@@ -267,7 +273,7 @@ index 8e02cb5..e07b2d7 100644
<!-- Copy the sample project files into the root directory -->
<copy file="${tomcat.home}/res/ide-support/eclipse/eclipse.project" tofile="${tomcat.home}/.project"/>
-@@ -3237,7 +3247,7 @@ Read the Building page on the Apache Tomcat documentation site for details on ho
+@@ -3237,7 +3249,7 @@ Read the Building page on the Apache Tomcat documentation site for details on ho
<target name="ide-intellij"
depends="download-compile, download-test-compile"
diff --git a/www-servers/tomcat/tomcat-8.5.57.ebuild b/www-servers/tomcat/tomcat-8.5.57.ebuild
index 35dcf4223442..1895d41a8f02 100644
--- a/www-servers/tomcat/tomcat-8.5.57.ebuild
+++ b/www-servers/tomcat/tomcat-8.5.57.ebuild
@@ -31,6 +31,10 @@ DEPEND="${COMMON_DEP}
app-admin/pwgen
>=dev-java/ant-core-1.9.13
virtual/jdk:1.8
+ doc? (
+ dev-java/glassfish-xmlrpc-api:0
+ dev-java/wsdl4j:0
+ )
test? (
>=dev-java/ant-junit-1.9:0
dev-java/easymock:3.2
@@ -76,7 +80,8 @@ IM_REV="-r2"
INIT_REV="-r1"
src_compile() {
- EANT_GENTOO_CLASSPATH_EXTRA+=":$(java-pkg_getjar --build-only ant-core ant.jar)"
+ EANT_GENTOO_CLASSPATH_EXTRA+=":$(java-pkg_getjar --build-only ant-core ant.jar):$(java-pkg_getjar --build-only glassfish-xmlrpc-api glassfish-xmlrpc-api.jar)"
+ use doc && EANT_GENTOO_CLASSPATH_EXTRA+=":$(java-pkg_getjar --build-only glassfish-xmlrpc-api glassfish-xmlrpc-api.jar):$(java-pkg_getjar --build-only wsdl4j wsdl4j.jar)"
java-pkg-2_src_compile
}