summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2022-06-28 10:40:15 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2022-06-28 10:40:15 +0200
commit05f267a97e975ef53b9c02a5fd2bcea0ed75f581 (patch)
tree9137e4340ea79819545c3ee4f62ae2353abb0f85
parentmedia-sound/audiotools: eapi8, added python 3.10 (diff)
downloadgentoo-05f267a97e975ef53b9c02a5fd2bcea0ed75f581.tar.gz
gentoo-05f267a97e975ef53b9c02a5fd2bcea0ed75f581.tar.bz2
gentoo-05f267a97e975ef53b9c02a5fd2bcea0ed75f581.zip
media-sound/mps-youtube: eapi8, added python 3.10
Bug: https://bugs.gentoo.org/846083 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
-rw-r--r--media-sound/mps-youtube/mps-youtube-0.2.8-r3.ebuild28
-rw-r--r--media-sound/mps-youtube/mps-youtube-9999.ebuild6
2 files changed, 31 insertions, 3 deletions
diff --git a/media-sound/mps-youtube/mps-youtube-0.2.8-r3.ebuild b/media-sound/mps-youtube/mps-youtube-0.2.8-r3.ebuild
new file mode 100644
index 000000000000..4c3f4d17ba0c
--- /dev/null
+++ b/media-sound/mps-youtube/mps-youtube-0.2.8-r3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/mps-youtube/mps-youtube.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Terminal-based YouTube player and downloader"
+HOMEPAGE="https://github.com/mps-youtube/mps-youtube https://pypi.org/project/mps-youtube/"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ dev-python/pafy[${PYTHON_USEDEP}]
+ media-video/ffmpeg
+ || ( media-video/mpv media-video/mplayer )
+"
diff --git a/media-sound/mps-youtube/mps-youtube-9999.ebuild b/media-sound/mps-youtube/mps-youtube-9999.ebuild
index 82b44f71fd65..4c3f4d17ba0c 100644
--- a/media-sound/mps-youtube/mps-youtube-9999.ebuild
+++ b/media-sound/mps-youtube/mps-youtube-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1