summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2019-12-06 00:40:54 +0100
committerConrad Kostecki <conikost@gentoo.org>2019-12-06 00:56:00 +0100
commit06efa701e5e82191262d9999441bdce9891d8671 (patch)
treeeeda2c06fc80da09dd4fdf876fc7b1e5fc997747
parentdev-tex/dot2tex: 2.11.3 bump (diff)
downloadgentoo-06efa701e5e82191262d9999441bdce9891d8671.tar.gz
gentoo-06efa701e5e82191262d9999441bdce9891d8671.tar.bz2
gentoo-06efa701e5e82191262d9999441bdce9891d8671.zip
app-misc/fr24feed: New package
The package app-misc/fr24feed is used for collecting ADS-B data and submitting to Flightradar24. Closes: https://github.com/gentoo/gentoo/pull/12926 Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--app-misc/fr24feed/Manifest2
-rw-r--r--app-misc/fr24feed/files/fr24feed.confd5
-rw-r--r--app-misc/fr24feed/files/fr24feed.ini2
-rw-r--r--app-misc/fr24feed/files/fr24feed.initd25
-rw-r--r--app-misc/fr24feed/fr24feed-1.0.24_p5.ebuild44
-rw-r--r--app-misc/fr24feed/metadata.xml20
6 files changed, 98 insertions, 0 deletions
diff --git a/app-misc/fr24feed/Manifest b/app-misc/fr24feed/Manifest
new file mode 100644
index 000000000000..01fbbfced428
--- /dev/null
+++ b/app-misc/fr24feed/Manifest
@@ -0,0 +1,2 @@
+DIST fr24feed_1.0.24-5_amd64.tgz 3943670 BLAKE2B d8d7b031872c1220f2f6ba5843d0c457279d393ae78dc947fe5cbc81e5ee1d4bf629ecddee093020ed3e01937fcecd9f225dcfd5c55fc47e7a31a23007122a18 SHA512 9ed5391e7faf1ab3352b95d6eaab8cccd77f0759e4852c3e0283a930d8f7dff2f38c59eb00639a2be0c6decd9f4db49fcdefb6b3de3533b8453a02f66224d503
+DIST fr24feed_1.0.24-5_i386.tgz 3645172 BLAKE2B 074d6535d09ab77baa9d954bcd9c87c3099b6938ad57ab67f16b14a6a8f865868eb3d82b49eeb6559a6929f8cb28f3591563f007490dd45782b4452cf2da12f2 SHA512 05d9a7ad64e047d3b2934d6421d1fcfb8aa6eb955739f9fa58726d2e45cb7141fad73ea1943ce01a071077a8155e07672acade75ce9068d5c932b0b24ff2b194
diff --git a/app-misc/fr24feed/files/fr24feed.confd b/app-misc/fr24feed/files/fr24feed.confd
new file mode 100644
index 000000000000..90288849bf59
--- /dev/null
+++ b/app-misc/fr24feed/files/fr24feed.confd
@@ -0,0 +1,5 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Pass various options to the daemon.
+FR24FEED_OPTS="--log-rotate=2 --quiet"
diff --git a/app-misc/fr24feed/files/fr24feed.ini b/app-misc/fr24feed/files/fr24feed.ini
new file mode 100644
index 000000000000..fdeb5adb6e4f
--- /dev/null
+++ b/app-misc/fr24feed/files/fr24feed.ini
@@ -0,0 +1,2 @@
+bs=yes
+raw=yes
diff --git a/app-misc/fr24feed/files/fr24feed.initd b/app-misc/fr24feed/files/fr24feed.initd
new file mode 100644
index 000000000000..a0f1b9aa6b93
--- /dev/null
+++ b/app-misc/fr24feed/files/fr24feed.initd
@@ -0,0 +1,25 @@
+#!/sbin/openrc-run
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+description="Flightradar24 data sharing software"
+name="Flightradar24 feed daemon"
+pidfile="/run/${RC_SVCNAME}.pid"
+retry="TERM/10"
+dev_shm_path="/dev/shm"
+stopsig="SIGTERM"
+
+command="/usr/bin/fr24feed"
+command_args="--monitor-file=${dev_shm_path}/${RC_SVCNAME}.txt --write-pid=${pidfile} ${FR24FEED_OPTS}"
+command_background="true"
+
+depend() {
+ use net
+}
+
+start_pre() {
+ if [ ! -d "${dev_shm_path}" ]; then
+ eerror "A mounted ${dev_shm_path} is needed in order to run fr24feed!'"
+ return 1
+ fi
+}
diff --git a/app-misc/fr24feed/fr24feed-1.0.24_p5.ebuild b/app-misc/fr24feed/fr24feed-1.0.24_p5.ebuild
new file mode 100644
index 000000000000..4b625d172962
--- /dev/null
+++ b/app-misc/fr24feed/fr24feed-1.0.24_p5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV="${PV/-/_}"
+MY_PV="${MY_PV/_p/-}"
+MY_P="${PN}_${MY_PV}"
+
+DESCRIPTION="Flightradar24 data sharing software"
+HOMEPAGE="https://www.flightradar24.com/share-your-data"
+SRC_URI="
+ amd64? ( https://repo-feed.flightradar24.com/linux_x86_64_binaries/${MY_P}_amd64.tgz )
+ x86? ( https://repo-feed.flightradar24.com/linux_x86_binaries/${MY_P}_i386.tgz )
+"
+
+LICENSE="Flightradar24"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+RDEPEND="
+ net-wireless/dump1090
+ virtual/libusb:1
+"
+
+RESTRICT="bindist mirror"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="usr/bin/fr24feed"
+
+src_install() {
+ dobin fr24feed_$(usex amd64 'amd64' 'i386')/fr24feed
+
+ insinto /etc
+ doins "${FILESDIR}"/fr24feed.ini
+
+ newinitd "${FILESDIR}"/fr24feed.initd fr24feed
+ newconfd "${FILESDIR}"/fr24feed.confd fr24feed
+}
+
+pkg_postinst() {
+ elog "Please run '/usr/bin/fr24feed --signup', to register yourself as a data feeder."
+}
diff --git a/app-misc/fr24feed/metadata.xml b/app-misc/fr24feed/metadata.xml
new file mode 100644
index 000000000000..20445ea2d98b
--- /dev/null
+++ b/app-misc/fr24feed/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>conikost@gentoo.org</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <longdescription>
+ Flightradar24 operates the world's largest network of ADS-B/Mode S receivers.
+ This network, together with government air traffic control and other data sources,
+ is how Flightradar24 is able to track aircraft around the globe.
+
+ You can help us increase the flight tracking coverage in your area
+ by uploading data from your ADS-B receiver.
+
+ By sharing ADS-B data with Flightradar24, not only will you help make real-time
+ flight data available to millions of aviation enthusiasts around the world,
+ but as a thank you, you will also receive a free Flightradar24 Business Plan subscription.
+ </longdescription>
+</pkgmetadata>