summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2025-01-10 03:01:03 +0100
committerJason A. Donenfeld <zx2c4@gentoo.org>2025-01-10 21:47:33 +0100
commit070b02f7823b52f5b98a20d14441feddb358b218 (patch)
tree44bb9350be7d8e561ca773fa0d1fe5e866489732
parentdev-python/inline-snapshot: Bump to 0.19.0 (diff)
downloadgentoo-070b02f7823b52f5b98a20d14441feddb358b218.tar.gz
gentoo-070b02f7823b52f5b98a20d14441feddb358b218.tar.bz2
gentoo-070b02f7823b52f5b98a20d14441feddb358b218.zip
media-gfx/clockphoto: update deps for qt6
Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
-rw-r--r--media-gfx/clockphoto/clockphoto-1.2-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-gfx/clockphoto/clockphoto-1.2-r1.ebuild b/media-gfx/clockphoto/clockphoto-1.2-r1.ebuild
new file mode 100644
index 000000000000..609fa4a2539f
--- /dev/null
+++ b/media-gfx/clockphoto/clockphoto-1.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils
+
+DESCRIPTION="Adjusts photo timestamps based on clock photos"
+HOMEPAGE="https://git.zx2c4.com/clockphoto/about/"
+SRC_URI="https://git.zx2c4.com/clockphoto/snapshot/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtbase:6[gui,widgets]
+"
+RDEPEND="${DEPEND}
+ media-gfx/exiv2
+"
+
+src_configure() {
+ eqmake6
+}
+
+src_install() {
+ dobin clockphoto
+}