summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Shkardoon <ss23@ss23.geek.nz>2019-08-01 02:42:31 +1200
committerJason Zaman <perfinion@gentoo.org>2019-08-05 21:49:51 +0800
commit079e42a45f9611bd6b731d0f916e2e672769eaed (patch)
tree0a09065cee9f88a2b4c52d11eb6601a55f820f2d
parentsys-cluster/kube-controller-manager: Version bump to 1.15.2 (diff)
downloadgentoo-079e42a45f9611bd6b731d0f916e2e672769eaed.tar.gz
gentoo-079e42a45f9611bd6b731d0f916e2e672769eaed.tar.bz2
gentoo-079e42a45f9611bd6b731d0f916e2e672769eaed.zip
net-libs/libtorrent: Add version 0.13.8 ebuild
Also removes dependency on dev-libs/libsigc++ Bug: https://bugs.gentoo.org/687996 Signed-off-by: Stephen Shkardoon <ss23@ss23.geek.nz> Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Jason Zaman <perfinion@gentoo.org>
-rw-r--r--net-libs/libtorrent/Manifest1
-rw-r--r--net-libs/libtorrent/libtorrent-0.13.8.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/net-libs/libtorrent/Manifest b/net-libs/libtorrent/Manifest
index 400d43d513e9..c8b8a25f9e6b 100644
--- a/net-libs/libtorrent/Manifest
+++ b/net-libs/libtorrent/Manifest
@@ -1 +1,2 @@
DIST libtorrent-0.13.7.tar.gz 782854 BLAKE2B 940e6162567d391f3d05034bf6d7d55a40070da7e2fd3279b1aa6acd169ca2783e7a2040efc472285f918c434e74380ec40fcddb823871ecf441c85670b9f273 SHA512 7bf3e87dbd19eb4e6806dff8a01c3ec61ea960bbd809d4bcbee96a46e169f97d0baf0fc85ab4a1efbbab07850e9b1060bae46c453ea6c42f5c23f8d921295efb
+DIST libtorrent-0.13.8.tar.gz 834027 BLAKE2B 374f33af52a45c244182d36bacd6b42eea9edc179e42fb40f4170a47a0cdd39cfb3f42f82fc26ab36718afb9a28a8dd72ca139b3646bbc1c2887444905438cdd SHA512 417177df5b27cd8c6a6317063b0846da2690de4633836466728605c2edad2de407d29d321cc481b8d1352dd0ff6dd89f4566a830424a8cf986f2fddb04704da4
diff --git a/net-libs/libtorrent/libtorrent-0.13.8.ebuild b/net-libs/libtorrent/libtorrent-0.13.8.ebuild
new file mode 100644
index 000000000000..e461b0222d6f
--- /dev/null
+++ b/net-libs/libtorrent/libtorrent-0.13.8.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="BitTorrent library written in C++ for *nix"
+HOMEPAGE="https://rakshasa.github.io/rtorrent/"
+SRC_URI="http://rtorrent.net/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+
+# The README says that the library ABI is not yet stable and dependencies on
+# the library should be an explicit, syncronized version until the library
+# has had more time to mature. Until it matures we should not include a soname
+# subslot.
+SLOT="0"
+
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="debug libressl ssl test"
+
+RDEPEND="
+ sys-libs/zlib
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-util/cppunit"
+# cppunit dependency - https://github.com/rakshasa/libtorrent/issues/182
+
+src_configure() {
+ # bug 518582
+ local disable_instrumentation
+ echo -e "#include <inttypes.h>\nint main(){ int64_t var = 7; __sync_add_and_fetch(&var, 1); return 0;}" > "${T}/sync_add_and_fetch.c" || die
+ $(tc-getCC) ${CFLAGS} -o /dev/null -x c "${T}/sync_add_and_fetch.c" >/dev/null 2>&1
+ if [[ $? -ne 0 ]]; then
+ disable_instrumentation="--disable-instrumentation"
+ fi
+
+ # configure needs bash or script bombs out on some null shift, bug #291229
+ CONFIG_SHELL=${BASH} econf \
+ --enable-aligned \
+ $(use_enable debug) \
+ $(use_enable ssl openssl) \
+ ${disable_instrumentation} \
+ --with-posix-fallocate \
+ --with-zlib="${EROOT%/}/usr/"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete
+}