summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-05-06 11:22:41 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-05-06 11:23:14 -0500
commit07be3fee9291d14d24c36c3c5215ef90331b18f5 (patch)
tree83da470bd799d05aac007587183b2bf824ef791f
parentvirtual/dotnet-sdk: Reassign from dead dotnet@ project (diff)
downloadgentoo-07be3fee9291d14d24c36c3c5215ef90331b18f5.tar.gz
gentoo-07be3fee9291d14d24c36c3c5215ef90331b18f5.tar.bz2
gentoo-07be3fee9291d14d24c36c3c5215ef90331b18f5.zip
app-accessibility/edbrowse: add 3.8.2.1
Closes: https://bugs.gentoo.org/732616 Closes: https://bugs.gentoo.org/838001 Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--app-accessibility/edbrowse/Manifest2
-rw-r--r--app-accessibility/edbrowse/edbrowse-3.8.2.1.ebuild50
-rw-r--r--app-accessibility/edbrowse/files/edbrowse-3.8.2.1-respect-ldflags.patch13
3 files changed, 65 insertions, 0 deletions
diff --git a/app-accessibility/edbrowse/Manifest b/app-accessibility/edbrowse/Manifest
index 383cdd368c26..85a299692e6d 100644
--- a/app-accessibility/edbrowse/Manifest
+++ b/app-accessibility/edbrowse/Manifest
@@ -1 +1,3 @@
DIST edbrowse-3.7.5.1.tar.gz 790742 BLAKE2B 7047cc2b1c7bc51aaa88f7a6aa981020ae80b6498bcb97f670646267dab94bab565b9ecc23c36f75d2653175917720dbb9e40a0f9bfd44251716669155e8de9e SHA512 ec217bf98334e8b493a1a80082cebfb11da9fa84d20d8b5f3f3286a78ae1dc6a2731c578d000f9f0f19d3dcbec9aa2c3e2a6b5b35f7ea7672840b9bcd1c5c67a
+DIST edbrowse-3.8.2.1.tar.gz 909574 BLAKE2B e5358861f6747dfe12498403b2d4761ab16dabc513fe94455d88c44e07793fb1128b0c1b7ebdf9ef922e371148182f8127f67f11eb123877e804858cb7e6378b SHA512 b5774a836efe96aae77052b02f6fcc85920b5f86a6ab8436a6dc363d81531b30e7f9c7555aacb20af27e59565042bdd685eed2acd4dfde8b99e2ad0358f19927
+DIST quickjs-2788d71.tar.gz 599260 BLAKE2B 67618f491c3efd1aa15a8906557983dd7123a3cfb2584f2f499f005667ccac4ded1c77934d2807cfce9e042572c6c41d63982b3df7afab5b2c67f4ce9f357879 SHA512 4493d11bc60855711955e0159e9f568d7e3db59c9843ef3aae00846f82c5e33f501372f7f5861b431353355f400f77720f3265963ea7bc0e38635ab5b89a27a0
diff --git a/app-accessibility/edbrowse/edbrowse-3.8.2.1.ebuild b/app-accessibility/edbrowse/edbrowse-3.8.2.1.ebuild
new file mode 100644
index 000000000000..53a246557d29
--- /dev/null
+++ b/app-accessibility/edbrowse/edbrowse-3.8.2.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+QUICKJS_HASH=2788d71e823b522b178db3b3660ce93689534e6d
+QUICKJS_SHORT=2788d71
+QUICKJS_S="${WORKDIR}/quickjs-${QUICKJS_HASH}"
+QUICKJS_P="quickjs-${QUICKJS_SHORT}"
+
+DESCRIPTION="Combination editor, browser, and mail client that is 100% text based"
+HOMEPAGE="https://edbrowse.org"
+SRC_URI="https://github.com/CMB/edbrowse/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/bellard/quickjs/archive/${QUICKJS_HASH}.tar.gz -> ${QUICKJS_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="odbc"
+
+RDEPEND="
+ >=app-text/htmltidy-5.0.0:=
+ dev-libs/libpcre:=
+ net-misc/curl
+ sys-libs/readline:=
+ odbc? ( dev-db/unixODBC )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-lang/perl
+ sys-apps/ed
+ virtual/pkgconfig"
+
+ PATCHES=(
+ "${FILESDIR}/${P}"-respect-ldflags.patch
+ )
+
+src_compile() {
+ # First build quickjs so we can link to its static library.
+ # Also, quickjs doesn't appear to tag releases.
+ tools/quickjobfixup "${QUICKJS_S}" || die
+ emake -C "${QUICKJS_S}"
+ emake -C src QUICKJS_DIR="${QUICKJS_S}" STRIP=
+}
+
+src_install() {
+ dobin src/edbrowse
+ newman doc/man-edbrowse-debian.1 edbrowse.1
+ DOCS="doc/sample*"
+ HTML_DOCS="doc/*.html"
+ einstalldocs
+}
diff --git a/app-accessibility/edbrowse/files/edbrowse-3.8.2.1-respect-ldflags.patch b/app-accessibility/edbrowse/files/edbrowse-3.8.2.1-respect-ldflags.patch
new file mode 100644
index 000000000000..3b511e1d2b38
--- /dev/null
+++ b/app-accessibility/edbrowse/files/edbrowse-3.8.2.1-respect-ldflags.patch
@@ -0,0 +1,13 @@
+diff --git a/src/makefile b/src/makefile
+index d65369a3..410d3e9d 100644
+--- a/src/makefile
++++ b/src/makefile
+@@ -31,7 +31,7 @@ endif
+ CFLAGS += $(DEBUGFLAGS)
+
+ # Libraries and linker flags for edbrowse.
+-LDFLAGS = $(STRIP) $(LINKER_LIBS) -lpthread -lm
++LDFLAGS += $(STRIP) $(LINKER_LIBS) -lpthread -lm
+
+ # LDFLAGS for quickjs loading.
+ QUICKJS_LDFLAGS = $(QUICKJS_DIR)/libquickjs.a -ldl