summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-09 20:29:53 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-09 20:52:51 +0200
commit07dfe377620a4f2d61a475dd2a065001e7902270 (patch)
tree48b2239840094e5298a8bbc680419d8d72dd9764
parentdev-python/pyasn1-modules: Enable py3.13 (diff)
downloadgentoo-07dfe377620a4f2d61a475dd2a065001e7902270.tar.gz
gentoo-07dfe377620a4f2d61a475dd2a065001e7902270.tar.bz2
gentoo-07dfe377620a4f2d61a475dd2a065001e7902270.zip
dev-python/semantic-version: Enable py3.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/semantic-version/semantic-version-2.10.0.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-python/semantic-version/semantic-version-2.10.0.ebuild b/dev-python/semantic-version/semantic-version-2.10.0.ebuild
index 94bca6f84951..6cde6827cc60 100644
--- a/dev-python/semantic-version/semantic-version-2.10.0.ebuild
+++ b/dev-python/semantic-version/semantic-version-2.10.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
inherit distutils-r1 pypi
@@ -23,5 +23,6 @@ distutils_enable_sphinx docs \
distutils_enable_tests pytest
python_test() {
- epytest -p no:django
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
}