summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHuang Rui <vowstar@gmail.com>2021-05-11 12:17:02 +0800
committerAndreas K. Hüttel <dilfridge@gentoo.org>2022-01-28 00:36:06 +0100
commit07f8823ea56d6d185798ffda411b6dc3ee66b90f (patch)
treea46756cf20c62129e5dcc2230eebadceea729bb6
parentdev-python/httpx: Remove old (diff)
downloadgentoo-07f8823ea56d6d185798ffda411b6dc3ee66b90f.tar.gz
gentoo-07f8823ea56d6d185798ffda411b6dc3ee66b90f.tar.bz2
gentoo-07f8823ea56d6d185798ffda411b6dc3ee66b90f.zip
sci-mathematics/mathematica: bump to 12.2.0
Closes: https://bugs.gentoo.org/789387 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Huang Rui <vowstar@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/20766 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
-rw-r--r--sci-mathematics/mathematica/Manifest1
-rw-r--r--sci-mathematics/mathematica/mathematica-12.2.0.ebuild104
2 files changed, 105 insertions, 0 deletions
diff --git a/sci-mathematics/mathematica/Manifest b/sci-mathematics/mathematica/Manifest
index 4abc79ccc18c..7aec0d486c57 100644
--- a/sci-mathematics/mathematica/Manifest
+++ b/sci-mathematics/mathematica/Manifest
@@ -1,3 +1,4 @@
DIST Mathematica_10.3.1_LINUX.sh 3200459545 BLAKE2B 5a057b4e714eabb0afebe5a3ef536dbdc2d49a775130442e21493d6a0756527362fddfa7fabf927f996464456309c37b10b70a37f05718cb9f79d8ffc5912098 SHA512 08658a01a18c14a9b3f422816007980bf6576162e4cca6779ed1bdaf6b9748fb36a195006529ed6725f462042a264e7ee7753e802af8072ba6bebfee0cad8543
DIST Mathematica_12.1.0_LINUX.sh 5889770327 BLAKE2B b0e637714f376d4066d5e484ef9facdcac36db691f7fd93e4a8228960acc9ec4b74b12ca19556c01247bd7927497f01f0c339a099b7f5abc7547051cc99c1fce SHA512 a661aa644944ee1058d7429f352ba6508514314086676a6eb918aac32773cc949feb531951b614be53198fa863575d8db456c66aa1306fd858c23423ef590fbb
DIST Mathematica_12.1.1_LINUX.sh 4438946649 BLAKE2B 473f814a3e0686bb3a6ac1f49c887842bc17db11439b65c1dad1dae8cd5797e6762d94bccdf156f6f9ba1edb9a16ed5172936a6884d2f0f98c29808214b1eabe SHA512 5cfdd91bae9bad53afe405b40759732589119256c3f785058808b20faf21f593d90bf7bb2dbaccf3e983aa84ff380a1fa6d40fd63f5ba17109c1cd6818c63490
+DIST Mathematica_12.2.0_LINUX.sh 4454613844 BLAKE2B 03b0567afe001fd0781ea6daf0f23ccaccf44ed6ce225cc190239d228c684099a1fa1070cedc0c5bf1517804a4b8b34903d56b2b028392895437a304b56f682d SHA512 0b98d0f2a15ea834892897a64089da08bee5783a8a51b1a0e624618105c896c91c865cca5b5c7b8e72569a5065ef091be7138b7d72d94e4697a213a91d5b8770
diff --git a/sci-mathematics/mathematica/mathematica-12.2.0.ebuild b/sci-mathematics/mathematica/mathematica-12.2.0.ebuild
new file mode 100644
index 000000000000..85cab466a173
--- /dev/null
+++ b/sci-mathematics/mathematica/mathematica-12.2.0.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop multilib unpacker xdg
+
+DESCRIPTION="Wolfram Mathematica"
+SRC_URI="Mathematica_${PV}_LINUX.sh"
+HOMEPAGE="https://www.wolfram.com/mathematica/"
+
+LICENSE="all-rights-reserved"
+KEYWORDS="-* ~amd64"
+SLOT="0"
+IUSE="+doc"
+
+RESTRICT="strip mirror bindist fetch"
+
+DEPEND=""
+
+# Mathematica comes with a lot of bundled stuff. We should place here only what we
+# explicitly override with LD_PRELOAD.
+RDEPEND="
+ media-libs/freetype
+"
+
+# we need this a few times
+MPN="Mathematica"
+MPV=$(ver_cut 1-2)
+M_BINARIES="MathKernel Mathematica MathematicaScript WolframKernel WolframScript math mathematica mcc wolfram"
+M_TARGET="opt/Wolfram/${MPN}/${MPV}"
+
+# we might as well list all files in all QA variables...
+QA_PREBUILT="opt/*"
+
+S=${WORKDIR}
+
+src_unpack() {
+ /bin/sh "${DISTDIR}/${A}" --nox11 --keep --target "${S}/unpack" -- "-help" || die
+}
+
+src_prepare() {
+ pushd "${S}/unpack" > /dev/null || die
+ # fix ACCESS DENIED issue when installer check the avahi-daemon
+ sed -e "s:avahi-daemon -c:true:g" -i "Unix/Installer/MathInstaller" || die
+ /bin/sh "Unix/Installer/MathInstaller" -auto "-targetdir=${S}/${M_TARGET}" "-execdir=${S}/opt/bin" || die
+ popd > /dev/null || die
+ eapply_user
+}
+
+src_install() {
+ local ARCH='-x86-64'
+
+ if ! use doc; then
+ einfo "Removing documentation"
+ rm -r "${S}/${M_TARGET}/Documentation"
+ fi
+
+ einfo 'Removing MacOS- and Windows-specific files'
+ find AddOns SystemFiles -type d -\( -name Windows -o -name Windows-x86-64 \
+ -o -name MacOSX -o -name MacOSX-x86-64 -\) -delete
+
+ # move all over
+ mv "${S}"/opt "${D}"/opt || die
+
+ # the autogenerated symlinks point into sandbox, remove
+ rm "${D}"/opt/bin/* || die
+
+ # install wrappers instead
+ for name in ${M_BINARIES} ; do
+ einfo "Generating wrapper for ${name}"
+ echo '#!/bin/sh' >> "${T}/${name}"
+ echo "LD_PRELOAD=/usr/$(get_libdir)/libfreetype.so.6:/$(get_libdir)/libz.so.1 /${M_TARGET}/Executables/${name} \$*" \
+ >> "${T}/${name}"
+ dobin "${T}/${name}"
+ done
+ for name in ${M_BINARIES} ; do
+ einfo "Symlinking ${name} to /opt/bin"
+ dosym ../../usr/bin/${name} /opt/bin/${name}
+ done
+
+ # fix some embedded paths and install desktop files
+ for filename in $(find "${D}/${M_TARGET}/SystemFiles/Installation" -name "wolfram-mathematica*.desktop") ; do
+ echo Fixing "${filename}"
+ sed -e "s:${S}::g" -e 's:^\t\t::g' -i "${filename}"
+ echo "Categories=Physics;Science;Engineering;2DGraphics;Graphics;" >> "${filename}"
+ domenu "${filename}"
+ done
+
+ # install mime types
+ insinto /usr/share/mime/application
+ for filename in $(find "${D}/${M_TARGET}/SystemFiles/Installation" -name "application-*.xml"); do
+ basefilename=$(basename "${filename}")
+ mv "${filename}" "${T}/${basefilename#application-}"
+ doins "${T}/${basefilename#application-}"
+ done
+}
+
+pkg_nofetch() {
+ einfo "Please place the Wolfram Mathematica installation file ${SRC_URI}"
+ einfo "in your \$\{DISTDIR\}."
+ einfo "Note that to actually run and use Mathematica you need a valid license."
+ einfo "Wolfram provides time-limited evaluation licenses at ${HOMEPAGE}"
+}