summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-04-27 12:25:30 +0200
committerDavid Seifert <soap@gentoo.org>2023-04-27 12:25:30 +0200
commit0838abfa3431104f78ed99c99d4337b4b71b4ed3 (patch)
treef20e9f203f69626d1d74cbe0a3729c7f526f328c
parentdev-libs/libgcrypt-1.10.2: marked ~arm64-macos (diff)
downloadgentoo-0838abfa3431104f78ed99c99d4337b4b71b4ed3.tar.gz
gentoo-0838abfa3431104f78ed99c99d4337b4b71b4ed3.tar.bz2
gentoo-0838abfa3431104f78ed99c99d4337b4b71b4ed3.zip
net-im/skypeforlinux: add 8.97.0.204
Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--net-im/skypeforlinux/Manifest1
-rw-r--r--net-im/skypeforlinux/skypeforlinux-8.97.0.204.ebuild100
2 files changed, 101 insertions, 0 deletions
diff --git a/net-im/skypeforlinux/Manifest b/net-im/skypeforlinux/Manifest
index 68f6ca210471..6e80899649e4 100644
--- a/net-im/skypeforlinux/Manifest
+++ b/net-im/skypeforlinux/Manifest
@@ -2,3 +2,4 @@ DIST skypeforlinux_8.94.0.428-1.x86_64.rpm 126374668 BLAKE2B e90c5207c1ec0d28351
DIST skypeforlinux_8.95.0.408-1.x86_64.rpm 126523292 BLAKE2B 5e6018b7a2aef8a8cf4311cb50475af7f7799e93d2a1e8b4755428b0ce670819db9c106ac830121b75543c03fed7fc08c910544eb7d3dfb57c11fd7f30df9319 SHA512 c4acdb94e962753e61386e0c0ff18e217a395d5f919ed70ef83e655ca5bd7758f53391dbe977f0b0ffc27c5ea7ec465bf168fec557de3040db425cc365e8eff7
DIST skypeforlinux_8.96.0.207-1.x86_64.rpm 124580688 BLAKE2B 8bd2dfecee6730d4aeb49bef0e08fd1fd17aecf31a8cd81b5d0ba3d4a8bc6808bd6e08d7c91d39aa46982502b23c8e37c5f4ce2ae87da963cc0df8a8b8ed430d SHA512 27406615892a12a390d47e2a2087149c29a195e942d9fb1748ad1f7cb39012fdad0836b01c4bfe6e690e1a27f67ccdd6d0da2f4baa3cf6567733d95b5a35be17
DIST skypeforlinux_8.96.0.408_amd64.deb 124565400 BLAKE2B 56f8e20c3f192322267afb308fb211bb1af13f144c19e4d42ea2df3ac6a4f1648f47738ca9f1f44ed13f8f20b796726ffc41d9a658431bbd12ecb92579ae3d04 SHA512 b7aa70435c6d0f2b821a8f33b5b33ef6204dafe1467f92024389498c013260ea86649928d93c10ad3a29ffe5b277f0c57b2732d4ed6efe93568b7053ecdfbf44
+DIST skypeforlinux_8.97.0.204_amd64.deb 124991858 BLAKE2B 0b56817a9c181546348a9b34ef746be1040574709a127a8d421bbc698ac9f1e34aa1594dfc292c0c23459719aaedee6ba30bbac0d3f8aeef13b3894448c4f87a SHA512 4dbf16491d6a63d9c20c24a8d80671e968ca1fe7d7fa5cee700c3b411341b9432ee69fa723a231f4e992a5cacac69ad7700da06068a9e4a648c8d7e7b3924b8d
diff --git a/net-im/skypeforlinux/skypeforlinux-8.97.0.204.ebuild b/net-im/skypeforlinux/skypeforlinux-8.97.0.204.ebuild
new file mode 100644
index 000000000000..aa8b927e61ba
--- /dev/null
+++ b/net-im/skypeforlinux/skypeforlinux-8.97.0.204.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MULTILIB_COMPAT=( abi_x86_64 )
+
+inherit chromium-2 desktop pax-utils unpacker multilib-build xdg
+
+DESCRIPTION="Instant messaging client, with support for audio and video"
+HOMEPAGE="https://www.skype.com/"
+SRC_URI="https://repo.skype.com/deb/pool/main/s/skypeforlinux/${PN}_${PV}_amd64.deb"
+S="${WORKDIR}"
+
+LICENSE="Skype-TOS MIT MIT-with-advertising BSD-1 BSD-2 BSD Apache-2.0 Boost-1.0 ISC CC-BY-SA-3.0 CC0-1.0 openssl ZLIB APSL-2 icu Artistic-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+QA_PREBUILT="*"
+RESTRICT="mirror bindist strip" #299368
+
+RDEPEND="
+ app-crypt/libsecret[${MULTILIB_USEDEP}]
+ app-accessibility/at-spi2-core:2[${MULTILIB_USEDEP}]
+ dev-libs/expat[${MULTILIB_USEDEP}]
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ dev-libs/nspr[${MULTILIB_USEDEP}]
+ dev-libs/nss[${MULTILIB_USEDEP}]
+ media-libs/alsa-lib[${MULTILIB_USEDEP}]
+ media-libs/fontconfig:1.0[${MULTILIB_USEDEP}]
+ media-libs/freetype:2[${MULTILIB_USEDEP}]
+ media-libs/libv4l[${MULTILIB_USEDEP}]
+ net-print/cups[${MULTILIB_USEDEP}]
+ sys-apps/dbus[${MULTILIB_USEDEP}]
+ sys-devel/gcc[cxx]
+ sys-libs/glibc
+ virtual/ttf-fonts
+ x11-libs/cairo[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:3[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXScrnSaver[${MULTILIB_USEDEP}]
+ x11-libs/libXcomposite[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr[${MULTILIB_USEDEP}]
+ x11-libs/libXrender[${MULTILIB_USEDEP}]
+ x11-libs/libXtst[${MULTILIB_USEDEP}]
+ x11-libs/libxcb[${MULTILIB_USEDEP}]
+ x11-libs/libxkbcommon[${MULTILIB_USEDEP}]
+ x11-libs/libxkbfile[${MULTILIB_USEDEP}]
+ x11-libs/pango[${MULTILIB_USEDEP}]"
+
+pkg_setup() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_unpack() {
+ unpack_deb ${A}
+}
+
+src_prepare() {
+ default
+ sed -e "s!^SKYPE_PATH=.*!SKYPE_PATH=${EPREFIX}/opt/skypeforlinux/skypeforlinux!" \
+ -i usr/bin/skypeforlinux || die
+ sed -e "s!^Categories=.*!Categories=Network;InstantMessaging;Telephony;!" \
+ -e "/^OnlyShowIn=/d" \
+ -i usr/share/applications/skypeforlinux.desktop || die
+}
+
+src_install() {
+ dodir /opt
+ cp -a usr/share/skypeforlinux "${ED}"/opt || die
+
+ # remove chrome-sandbox binary, users should use kernel namespaces
+ # https://bugs.gentoo.org/692692#c18
+ rm "${ED}"/opt/skypeforlinux/chrome-sandbox || die
+
+ dobin usr/bin/skypeforlinux
+
+ dodoc usr/share/skypeforlinux/*.html
+ dodoc -r usr/share/doc/skypeforlinux/.
+ # symlink required for the "Help->3rd Party Notes" menu entry (otherwise frozen skype -> xdg-open)
+ dosym ${PF} usr/share/doc/skypeforlinux
+
+ doicon usr/share/pixmaps/skypeforlinux.png
+
+ local res
+ for res in 16 32 256 512; do
+ newicon -s ${res} usr/share/icons/hicolor/${res}x${res}/apps/skypeforlinux.png skypeforlinux.png
+ done
+
+ domenu usr/share/applications/skypeforlinux.desktop
+
+ pax-mark -m "${ED}"/opt/skypeforlinux/skypeforlinux
+ pax-mark -m "${ED}"/opt/skypeforlinux/resources/app.asar.unpacked/node_modules/slimcore/bin/slimcore.node
+}