summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2022-05-27 08:55:28 -0500
committerBen Kohler <bkohler@gentoo.org>2022-05-27 09:08:03 -0500
commit09983d4d443f6a3ec1213261d3a301ed0e98c75c (patch)
tree8cfc541b501993309b4c2463e60362bf51f95f0c
parentsys-apps/fwupd: Bump to version 1.8.1 (diff)
downloadgentoo-09983d4d443f6a3ec1213261d3a301ed0e98c75c.tar.gz
gentoo-09983d4d443f6a3ec1213261d3a301ed0e98c75c.tar.bz2
gentoo-09983d4d443f6a3ec1213261d3a301ed0e98c75c.zip
Revert "app-text/discount: drop 2.2.7b"
This reverts commit 9718c1a27e32c11a10b2321a69a2f02e72a74a55. Signed-off-by: Ben Kohler <bkohler@gentoo.org>
-rw-r--r--app-text/discount/Manifest1
-rw-r--r--app-text/discount/discount-2.2.7b.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/app-text/discount/Manifest b/app-text/discount/Manifest
index da7336021400..9bab7d77019f 100644
--- a/app-text/discount/Manifest
+++ b/app-text/discount/Manifest
@@ -1 +1,2 @@
DIST discount-2.2.7.tar.bz2 102277 BLAKE2B 58ec3bce2b8fc41a090d9b81b4326cbf54e36bf774f4f9ef63c2a2b1d34ba464e9f0a021f19b4fef165da426742af3045a631af005371d1a8a4cd81dc0be3367 SHA512 1b61eb7c625bb50da0dbe97350a0ccbb15930ccaef449c4b4659950907bce3c0564dabf20578379a7fdd0e375f5d4d5b61acd34db474a85e942b60373688bd08
+DIST discount-2.2.7b.tar.bz2 102685 BLAKE2B 1af4d47248e4a65ea1517b03d0b1a0b15eb79bdb7d1f00779515e2a1113b2a923f5d9e5d0a93d63cfc6c7257f11d3825d9baa55c7f2252fe3d2513785ab67ae3 SHA512 d68ffb85ae3e6d6ce8a2e506609bd4cb042617e350d113dd632a1ed81adb0b076df75ca4e70e97d43f3a3a2907555a9f28087a3762f41806289c526af3c55806
diff --git a/app-text/discount/discount-2.2.7b.ebuild b/app-text/discount/discount-2.2.7b.ebuild
new file mode 100644
index 000000000000..e53c8e7547af
--- /dev/null
+++ b/app-text/discount/discount-2.2.7b.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A Markdown-to HTML translator written in C"
+HOMEPAGE="http://www.pell.portland.or.us/~orc/Code/discount/"
+SRC_URI="http://www.pell.portland.or.us/~orc/Code/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ppc ppc64 ~riscv sparc x86"
+IUSE="minimal test"
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ default
+
+ # for QA, we remove the Makefile’s usage of install -s.
+ # Drop ldconfig invocation.
+ # Force “librarian.sh” to respect LDFLAGS ($FLAGS should have CFLAGS
+ # at that point).
+ sed -i \
+ -e '/INSTALL_PROGRAM/s,\$_strip ,,' \
+ -e 's/\(LDCONFIG=\).*/\1:/' \
+ -e 's/\(.\)\$FLAGS/& \1$LDFLAGS/' \
+ configure.inc || die "sed configure.inc failed"
+}
+
+src_configure() {
+ local configure_call=(
+ ./configure.sh
+ --libdir="${EPREFIX}/usr/$(get_libdir)"
+ --prefix="${EPREFIX}/usr"
+ --mandir="${EPREFIX}/usr/share/man"
+ --shared
+ --pkg-config
+ $(usex minimal '' --enable-all-features)
+ # Enable deterministic HTML generation behavior. Otherwise, will
+ # actually call rand() as part of its serialization code...
+ --debian-glitch
+ )
+ einfo "Running ${configure_call[@]}"
+ CC="$(tc-getCC)" AR="$(tc-getAR)" \
+ "${configure_call[@]}" || die
+}
+
+src_compile() {
+ emake libmarkdown
+ emake
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ $(usex minimal install install.everything) \
+ SAMPLE_PFX="${PN}-"
+}
+
+pkg_postinst() {
+ if ! use minimal; then
+ elog 'Sample binaries with overly-generic names have been'
+ elog "prefixed with \"${PN}-\"."
+ fi
+}