summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2018-10-10 20:03:45 -0400
committerChris Reffett <creffett@gentoo.org>2018-10-10 20:05:11 -0400
commit0a486b6ed5e7ad6dfce634d0b2dc574bed81c825 (patch)
treef449580cffdd8be7c5f1fe6c6ec3bc9f5742adf1
parentapp-text/xdvik: add missing dependency to virtual/emacs (diff)
downloadgentoo-0a486b6ed5e7ad6dfce634d0b2dc574bed81c825.tar.gz
gentoo-0a486b6ed5e7ad6dfce634d0b2dc574bed81c825.tar.bz2
gentoo-0a486b6ed5e7ad6dfce634d0b2dc574bed81c825.zip
app-text/sword: Version bump, fix ICU
Bump to 1.8.1, add patch from Fedora to fix builds with ICU >= 62 Bug: https://bugs.gentoo.org/666518 Signed-off-by: Chris Reffett <creffett@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--app-text/sword/Manifest2
-rw-r--r--app-text/sword/files/sword-1.8.1-icu61.diff138
-rw-r--r--app-text/sword/sword-1.8.1.ebuild (renamed from app-text/sword/sword-1.8.0.ebuild)3
3 files changed, 141 insertions, 2 deletions
diff --git a/app-text/sword/Manifest b/app-text/sword/Manifest
index 739447b1e03e..ed1a2c41782e 100644
--- a/app-text/sword/Manifest
+++ b/app-text/sword/Manifest
@@ -1,2 +1,2 @@
DIST sword-1.7.4.tar.gz 2157882 BLAKE2B 7ed50430500ec428a125e24550a1f7d0437a0253cf4fabad4c8af452d2aa82c71c11e4a6c334ef1a95d82f14ce1cc092f3774210113e9668ba207875b3a11b20 SHA512 4c8b183e613367364439cc7a8a842012f75180fccc8eb775b9af2dc4c10f39c152261d35f0aadaaa91a11df36ab1a4057c2edc50ea4b0b3bb0ab0a847ff68f75
-DIST sword-1.8.0.tar.gz 2444386 BLAKE2B dd74ca409cdc3e4563ec5f0ed225556cfc3d1c89e63b41df8335b4abdd4f36b1423a2953a86105d2efe8d57c0e57065f74e74629309bab93f2a0222b9a8fcc86 SHA512 c45f3135255322a77e955297997db2529f31b397c42cc4b9474dc6ec8d329b2233b292078979de5fbf33cad4a1a607aabb66f86501072a729d68e9fc840c8c8e
+DIST sword-1.8.1.tar.gz 2449503 BLAKE2B 4cc130ade49211dd4def6d9410ad6a0f01b35d11df246e26bb7fd0ee5c27ef02ee06ed3ec33c7becd140fa303b4fb4b3d4ba4d62de78b86be343949d5fcf7c6d SHA512 5c08c070ea0c86b7d929bbf94c89730eb5a487986deb9edf01c08d1710356aecd1ab3bde4437a778e5fc1ceb05b63287612ec6161381c0986a36344c27d2ab36
diff --git a/app-text/sword/files/sword-1.8.1-icu61.diff b/app-text/sword/files/sword-1.8.1-icu61.diff
new file mode 100644
index 000000000000..2129f279ddc6
--- /dev/null
+++ b/app-text/sword/files/sword-1.8.1-icu61.diff
@@ -0,0 +1,138 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 5cbd06a..1d3a2d2 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,5 +1,4 @@
+-# TODO: write FindICU (icu-config only for 2.2 and up) -- currently taken from another CMake system
+-# limit pkg-config version to >= 0.14, demo, utilities, doc, tests
++# TODO: limit pkg-config version to >= 0.14, demo, utilities, doc, tests
+ # use BUILD_SHARED_LIBS
+ # convince perl swig bindings to build properly
+ #
+@@ -13,7 +12,7 @@
+ # all posterity and eternity, wherever such transfer is possible. Where it is
+ # not, then this file is released under the GPLv2 by myself.
+ PROJECT(libsword CXX C)
+-CMAKE_MINIMUM_REQUIRED(VERSION 2.6.0)
++CMAKE_MINIMUM_REQUIRED(VERSION 3.7.0)
+ SET(SWORD_VERSION 1.8.1)
+
+ # Make sure it's an out-of-stream build
+@@ -56,7 +55,8 @@ IF(MSVC)
+ ELSE(MSVC)
+ FIND_PACKAGE(BZIP2 QUIET)
+ FIND_PACKAGE(XZ QUIET)
+- FIND_PACKAGE(ICU QUIET)
++ FIND_PACKAGE(ICU
++ COMPONENTS data i18n io uc)
+ FIND_PACKAGE(CURL QUIET)
+ ENDIF(MSVC)
+ FIND_PACKAGE(CLucene QUIET)
+@@ -237,7 +237,11 @@ ENDIF(WITH_CLUCENE)
+ IF(WITH_ICU)
+ INCLUDE_DIRECTORIES(${ICU_INCLUDE_DIRS})
+ ADD_DEFINITIONS(${ICU_DEFINITIONS})
+- SET(SWORD_LINK_LIBRARIES ${SWORD_LINK_LIBRARIES} ${ICU_LIBRARIES} ${ICU_I18N_LIBRARIES})
++ MESSAGE(STATUS "ICU Version: ${ICU_VERSION}")
++ IF("${ICU_VERSION}" VERSION_GREATER "61")
++ ADD_DEFINITIONS(-DU_USING_ICU_NAMESPACE)
++ ENDIF("${ICU_VERSION}" VERSION_GREATER "61")
++ SET(SWORD_LINK_LIBRARIES ${SWORD_LINK_LIBRARIES} ${ICU_LIBRARIES})
+ ENDIF(WITH_ICU)
+ IF(REGEX_FOUND AND CROSS_COMPILE_MINGW32)
+ SET(SWORD_LINK_LIBRARIES ${SWORD_LINK_LIBRARIES} ${REGEX_LIBRARY})
+diff --git a/cmake/FindICU.cmake b/cmake/FindICU.cmake
+deleted file mode 100644
+index 451c2f3..0000000
+--- a/cmake/FindICU.cmake
++++ /dev/null
+@@ -1,68 +0,0 @@
+-# Finds the International Components for Unicode (ICU) Library
+-#
+-# ICU_FOUND - True if ICU found.
+-# ICU_I18N_FOUND - True if ICU's internationalization library found.
+-# ICU_INCLUDE_DIRS - Directory to include to get ICU headers
+-# Note: always include ICU headers as, e.g.,
+-# unicode/utypes.h
+-# ICU_LIBRARIES - Libraries to link against for the common ICU
+-# ICU_I18N_LIBRARIES - Libraries to link against for ICU internationaliation
+-# (note: in addition to ICU_LIBRARIES)
+-
+-# Look for the header file.
+-find_path(
+- ICU_INCLUDE_DIR
+- NAMES unicode/utypes.h
+- DOC "Include directory for the ICU library")
+-mark_as_advanced(ICU_INCLUDE_DIR)
+-
+-# Look for the library.
+-find_library(
+- ICU_LIBRARY
+- NAMES icuuc cygicuuc cygicuuc32
+- DOC "Libraries to link against for the common parts of ICU")
+-mark_as_advanced(ICU_LIBRARY)
+-
+-# Copy the results to the output variables.
+-if(ICU_INCLUDE_DIR AND ICU_LIBRARY)
+- set(ICU_FOUND 1)
+- set(ICU_LIBRARIES ${ICU_LIBRARY})
+- set(ICU_INCLUDE_DIRS ${ICU_INCLUDE_DIR})
+-
+- # Look for the ICU internationalization libraries
+- find_library(
+- ICU_I18N_LIBRARY
+- NAMES icuin icui18n cygicuin cygicuin32
+- DOC "Libraries to link against for ICU internationalization")
+- if(MSVC)
+- find_library(ICU_DATA_LIBRARY
+- NAMES icudt
+- DOC "Libraries to link against for ICU data")
+- set(ICU_LIBRARIES ${ICU_LIBRARIES} ${ICU_DATA_LIBRARY})
+- endif(MSVC)
+- mark_as_advanced(ICU_I18N_LIBRARY)
+- mark_as_advanced(ICU_DATA_LIBRARY)
+- if (ICU_I18N_LIBRARY)
+- set(ICU_I18N_FOUND 1)
+- set(ICU_I18N_LIBRARIES ${ICU_I18N_LIBRARY})
+- else (ICU_I18N_LIBRARY)
+- set(ICU_I18N_FOUND 0)
+- set(ICU_I18N_LIBRARIES)
+- endif (ICU_I18N_LIBRARY)
+-else(ICU_INCLUDE_DIR AND ICU_LIBRARY)
+- set(ICU_FOUND 0)
+- set(ICU_I18N_FOUND 0)
+- set(ICU_LIBRARIES)
+- set(ICU_I18N_LIBRARIES)
+- set(ICU_INCLUDE_DIRS)
+-endif(ICU_INCLUDE_DIR AND ICU_LIBRARY)
+-
+-IF(ICU_FOUND)
+- IF(NOT ICU_FIND_QUIETLY)
+- MESSAGE(STATUS "ICU: Yes ${ICU_I18N_LIBRARY}")
+- ENDIF(NOT ICU_FIND_QUIETLY)
+-ELSE(ICU_FOUND)
+- IF(ICU_FIND_REQUIRED)
+- MESSAGE(FATAL_ERROR "ICU: No")
+- ENDIF(ICU_FIND_REQUIRED)
+-ENDIF(ICU_FOUND)
+diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
+index 30818a8..08bc573 100644
+--- a/tests/CMakeLists.txt
++++ b/tests/CMakeLists.txt
+@@ -75,10 +75,12 @@ ENDFOREACH(TEST ${test_PROGRAMS})
+
+ ########################################################################################
+ # The following tests require extra libraries to run
+-#
+-FOREACH(ICUTEST icutest translittest)
+- TARGET_LINK_LIBRARIES(${ICUTEST} ${ICU_LIBRARIES} ${ICU_I18N_LIBRARIES})
+-ENDFOREACH(ICUTEST icutest translittest)
++#
++IF(WITH_ICU)
++ FOREACH(ICUTEST icutest translittest)
++ TARGET_LINK_LIBRARIES(${ICUTEST} ${ICU_LIBRARIES} ${ICU_I18N_LIBRARIES})
++ ENDFOREACH(ICUTEST icutest translittest)
++ENDIF(WITH_ICU)
+
+ # Excluded until I know we have the tests working
+ ADD_SUBDIRECTORY(testsuite)
diff --git a/app-text/sword/sword-1.8.0.ebuild b/app-text/sword/sword-1.8.1.ebuild
index bb6ed4a2b108..1ddc808294c4 100644
--- a/app-text/sword/sword-1.8.0.ebuild
+++ b/app-text/sword/sword-1.8.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -40,6 +40,7 @@ src_prepare() {
DataPath=${EPREFIX}/usr/share/${PN}/
EOF
eapply "${FILESDIR}/${PN}-1.7.4-configure.patch"
+ eapply "${FILESDIR}/${PN}-1.8.1-icu61.diff"
eapply_user
}