summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-08 10:07:53 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-08 10:56:39 +0200
commit0a70f988e0826c64522414ffa6d66c96b4622d14 (patch)
treef1649f7b3eb76cba990320ca26e4872c50d8be75
parentdev-python/rope: Bump to 1.0.0 (diff)
downloadgentoo-0a70f988e0826c64522414ffa6d66c96b4622d14.tar.gz
gentoo-0a70f988e0826c64522414ffa6d66c96b4622d14.tar.bz2
gentoo-0a70f988e0826c64522414ffa6d66c96b4622d14.zip
dev-python/pylast: Bump to 5.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pylast/Manifest1
-rw-r--r--dev-python/pylast/pylast-5.0.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pylast/Manifest b/dev-python/pylast/Manifest
index c299db153428..9f35e7582c8a 100644
--- a/dev-python/pylast/Manifest
+++ b/dev-python/pylast/Manifest
@@ -1 +1,2 @@
DIST pylast-4.5.0.tar.gz 40175 BLAKE2B 394a6329d0c7f03ae70cf7ee5e19e310d4fc4b70f86a6e8ed66ad93674465433ff7ab06cfbfa82fd33302a6d85b9fe582402c2166746e7853d1bada9de5f2449 SHA512 c885f0ea415c2a6b96454abdbcef0b61732a5253ddff45a03d85a2b7d733f6bff47d1806576e4acc6d07763e404985e5c35341e37b88d586d1cbec811d984551
+DIST pylast-5.0.0.tar.gz 39868 BLAKE2B 0cb6d96ac74a2e62325b8a91cc3601ab4ea7ea629ef40c02ce1afe13fd067abc48f24092138fc4584382c9c7f8c62eb070f1a3173b39768ac4ff8e3904c255d2 SHA512 ebad77e66d39b5625d0afae3bba346769159f39dfbbca0fea6aa0e6ad683fea6ea04093dd4738e378ac419edcc9970e8070d7ff912cc08110a5f41f7993489ce
diff --git a/dev-python/pylast/pylast-5.0.0.ebuild b/dev-python/pylast/pylast-5.0.0.ebuild
new file mode 100644
index 000000000000..a96497534862
--- /dev/null
+++ b/dev-python/pylast/pylast-5.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to last.fm and other api-compatible websites"
+HOMEPAGE="
+ https://pypi.org/project/pylast/
+ https://github.com/pylast/pylast/
+"
+SRC_URI="
+ https://github.com/pylast/pylast/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/httpx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}