summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-02-24 01:41:35 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-02-24 04:20:59 +0100
commit0a7bd2580410d78ffbfae66fc1ac8268120a8917 (patch)
treeecef75e182530ac146803b73ecd7f4eeb82b0d16
parentnet-misc/ntpsec: fix config files and remove strip executables (diff)
downloadgentoo-0a7bd258.tar.gz
gentoo-0a7bd258.tar.bz2
gentoo-0a7bd258.zip
dev-python/pluggy: Bump to v0.6.0
Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--dev-python/pluggy/Manifest1
-rw-r--r--dev-python/pluggy/pluggy-0.6.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pluggy/Manifest b/dev-python/pluggy/Manifest
index 9b330d8b55e4..1817273c8ece 100644
--- a/dev-python/pluggy/Manifest
+++ b/dev-python/pluggy/Manifest
@@ -1 +1,2 @@
DIST pluggy-0.5.2.tar.gz 18935 BLAKE2B 8e5bbab9ed0c78a0c6da076ad03618e66780f9ff209f4d08223e7a381eb4d7573727793f4543799e0e557991d4edcdbfd22c0565b69814379806912a4631abf3 SHA512 850b1a7b9e55d46d5deb16b8bc71e3f9d6c26b78fe34379b295a9780f3da8abb3c44f524f175d0392b61fc2d36d66d156db3f499a3c1666e2ff3e3c6344153cb
+DIST pluggy-0.6.0.tar.gz 19678 BLAKE2B 79db59c5f0ce0dd157630d039ec50643f615789b6b993d84e9ab1bdc9ce04b32df336d88df13f13a16a1f0bd4acb7b900208e98c84f007bdc3654f9a1d5f19a2 SHA512 dd58dabe2e65eee64d62c8748c2bbd99457288e99b819eb12312f2acdb0740ac46fd08f83522bc992297b9f14eec14c216c2c9688580f68393bf6fc609e65812
diff --git a/dev-python/pluggy/pluggy-0.6.0.ebuild b/dev-python/pluggy/pluggy-0.6.0.ebuild
new file mode 100644
index 000000000000..09df42b74198
--- /dev/null
+++ b/dev-python/pluggy/pluggy-0.6.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="plugin and hook calling mechanisms for python"
+HOMEPAGE="https://pluggy.readthedocs.io/ https://github.com/pytest-dev/pluggy https://pypi.python.org/pypi/pluggy"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -v || die "tests failed with ${EPYTHON}"
+}